summaryrefslogtreecommitdiffstats
path: root/meta/packages/hal
diff options
context:
space:
mode:
authorRoss Burton <ross@openedhand.com>2007-01-20 14:19:55 +0000
committerRoss Burton <ross@openedhand.com>2007-01-20 14:19:55 +0000
commitecf5c0976289166eacffef3786a79973d71bc769 (patch)
tree30cf6ccc081e3eb298aacccefeb32427ef0e5048 /meta/packages/hal
parent38ae29b09179c5e38666a32fce30252cc8470653 (diff)
downloadpoky-ecf5c0976289166eacffef3786a79973d71bc769.tar.gz
Add HAL from git, faster and uses less memory
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1179 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/hal')
-rw-r--r--meta/packages/hal/hal_git.bb82
1 files changed, 82 insertions, 0 deletions
diff --git a/meta/packages/hal/hal_git.bb b/meta/packages/hal/hal_git.bb
new file mode 100644
index 0000000000..f76f21323d
--- /dev/null
+++ b/meta/packages/hal/hal_git.bb
@@ -0,0 +1,82 @@
1DESCRIPTION = "Hardware Abstraction Layer"
2HOMEPAGE = "http://freedesktop.org/Software/hal"
3SECTION = "unknown"
4LICENSE = "GPL LGPL AFL"
5
6DEPENDS = "dbus-glib expat libusb"
7RDEPENDS += "udev"
8#RDEPENDS_hal-device-manager = "python hal python-pygnome"
9RRECOMMENDS = "udev-utils"
10
11SRC_URI = "git://anongit.freedesktop.org/hal/;protocol=git \
12 file://99_hal"
13
14S = "${WORKDIR}/git"
15
16inherit autotools pkgconfig
17
18EXTRA_OECONF = "--with-hwdata=${datadir}/hwdata \
19 --with-expat=${STAGING_LIBDIR}/.. \
20 --with-dbus-sys=${sysconfdir}/dbus-1/system.d \
21 --with-hotplug=${sysconfdir}/hotplug.d \
22 --disable-docbook-docs \
23 --disable-policy-kit \
24 --disable-acpi --disable-pmu \
25 "
26
27do_install_append() {
28 install -d ${D}/etc/default/volatiles
29 install -m 0644 ${WORKDIR}/99_hal ${D}/etc/default/volatiles
30}
31
32do_stage() {
33 autotools_stage_all
34 install -d ${STAGING_LIBDIR}
35 install -m 755 libhal/.libs/libhal.so.1.0.0 ${STAGING_LIBDIR}/libhal.so
36 install -m 755 libhal-storage/.libs/libhal-storage.so.1.0.0 ${STAGING_LIBDIR}/libhal-storage.so
37}
38
39# At the time the postinst runs, dbus might not be setup so only restart if running
40pkg_postinst_hal () {
41 # can't do this offline
42 if [ "x$D" != "x" ]; then
43 exit 1
44 fi
45
46 /etc/init.d/populate-volatile.sh update
47
48 grep haldaemon /etc/group || addgroup haldaemon
49 grep haldaemon /etc/passwd || adduser --disabled-password --system --home /var/run/hald --no-create-home haldaemon --ingroup haldaemon -g HAL
50
51 DBUSPID=`pidof dbus-daemon`
52
53 if [ "x$DBUSPID" != "x" ]; then
54 /etc/init.d/dbus-1 force-reload
55 fi
56}
57
58pkg_postrm_hal () {
59 deluser haldaemon || true
60 delgroup haldaemon || true
61}
62
63#PACKAGES += "hal-device-manager"
64
65#FILES_hal-device-manager = " \
66# ${datadir}/hal/device-manager/ \
67# ${bindir}/hal-device-manager"
68
69FILES_${PN} = "${sysconfdir} \
70 ${bindir}/lshal \
71 ${bindir}/hal-find-by-capability \
72 ${bindir}/hal-find-by-property \
73 ${bindir}/hal-device \
74 ${bindir}/hal-get-property \
75 ${bindir}/hal-set-property \
76 ${sbindir} \
77 ${libdir}/libhal.so* \
78 ${libdir}/libhal-storage.so* \
79 ${libdir}/hal \
80 ${libexecdir} \
81 ${datadir}/hal/fdi \
82 ${datadir}/hal/scripts"