summaryrefslogtreecommitdiffstats
path: root/meta/packages/hal
diff options
context:
space:
mode:
authorKevin Tian <kevin.tian@intel.com>2010-08-11 13:34:54 +0800
committerRichard Purdie <rpurdie@linux.intel.com>2010-08-12 15:39:24 +0100
commite101642a61fc418273c1cd4d58a9564b4bdecc5c (patch)
tree8890d90be0403bd1a9161f32ceb3d5cd1b7a27b5 /meta/packages/hal
parentcf1e754b3fee3c7ae907e7ae30233083d7892215 (diff)
downloadpoky-e101642a61fc418273c1cd4d58a9564b4bdecc5c.tar.gz
populate-volatile.sh: cleanup duplicated invocations and remove boot warning
For one, populate-volatile.sh is itself a rcS script which is invoked earlier than package's own postinst method (last one in rcS). If package has already installed their volatile files correctly, it doesn't make sense to update volatile again in postinst since nothing is changed. On the other hand, dbus/hal are special since their user/group are only created in the target. If they pre-install volatiles like others, populate-volatile.sh will report "undefined user" since at that time their user/group haven't been created. The better way solving this is to generate their volatile in the fly after user/group are created, and then update volatiles. This fix [BUGID #121] Signed-off-by: Kevin Tian <kevin.tian@intel.com>
Diffstat (limited to 'meta/packages/hal')
-rw-r--r--meta/packages/hal/files/99_hal2
-rw-r--r--meta/packages/hal/hal.inc6
-rw-r--r--meta/packages/hal/hal_0.5.14.bb2
-rw-r--r--meta/packages/hal/hal_git.bb2
4 files changed, 5 insertions, 7 deletions
diff --git a/meta/packages/hal/files/99_hal b/meta/packages/hal/files/99_hal
deleted file mode 100644
index c82da990ba..0000000000
--- a/meta/packages/hal/files/99_hal
+++ /dev/null
@@ -1,2 +0,0 @@
1d root root 0700 /var/run/hald none
2d haldaemon haldaemon 0755 /var/cache/hald none
diff --git a/meta/packages/hal/hal.inc b/meta/packages/hal/hal.inc
index 29ceadcfa6..839dfd0652 100644
--- a/meta/packages/hal/hal.inc
+++ b/meta/packages/hal/hal.inc
@@ -10,7 +10,6 @@ DEPENDS = "virtual/kernel dbus-glib udev util-linux intltool intltool-native exp
10RDEPENDS += "udev hal-info" 10RDEPENDS += "udev hal-info"
11 11
12SRC_URI = "http://hal.freedesktop.org/releases/hal-${PV}.tar.gz \ 12SRC_URI = "http://hal.freedesktop.org/releases/hal-${PV}.tar.gz \
13 file://99_hal \
14 file://20hal" 13 file://20hal"
15 14
16inherit autotools pkgconfig 15inherit autotools pkgconfig
@@ -37,8 +36,6 @@ PACKAGE_ARCH = "${@base_contains('MACHINE_FEATURES', 'pci', '${MACHINE_ARCH}', '
37PACKAGE_ARCH_emenlow := "${PACKAGE_ARCH}" 36PACKAGE_ARCH_emenlow := "${PACKAGE_ARCH}"
38 37
39do_install_append() { 38do_install_append() {
40 install -d ${D}/etc/default/volatiles
41 install -m 0644 ${WORKDIR}/99_hal ${D}/etc/default/volatiles
42 install -d ${D}/etc/dbus-1/event.d 39 install -d ${D}/etc/dbus-1/event.d
43 install -m 0755 ${WORKDIR}/20hal ${D}/etc/dbus-1/event.d 40 install -m 0755 ${WORKDIR}/20hal ${D}/etc/dbus-1/event.d
44} 41}
@@ -53,6 +50,9 @@ pkg_postinst_hal () {
53 grep haldaemon /etc/group || addgroup haldaemon 50 grep haldaemon /etc/group || addgroup haldaemon
54 grep haldaemon /etc/passwd || adduser --disabled-password --system --home /var/run/hald --no-create-home haldaemon --ingroup haldaemon -g HAL 51 grep haldaemon /etc/passwd || adduser --disabled-password --system --home /var/run/hald --no-create-home haldaemon --ingroup haldaemon -g HAL
55 52
53 # add volatile after new user/grp are created
54 echo "d root root 0700 /var/run/hald none" > /etc/default/volatiles/99_hal
55 echo "d haldaemon haldaemon 0755 /var/cache/hald none" >> /etc/default/volatiles/99_hal
56 /etc/init.d/populate-volatile.sh update 56 /etc/init.d/populate-volatile.sh update
57 57
58 DBUSPID=`pidof dbus-daemon` 58 DBUSPID=`pidof dbus-daemon`
diff --git a/meta/packages/hal/hal_0.5.14.bb b/meta/packages/hal/hal_0.5.14.bb
index 470934a43e..a12be729cb 100644
--- a/meta/packages/hal/hal_0.5.14.bb
+++ b/meta/packages/hal/hal_0.5.14.bb
@@ -1,6 +1,6 @@
1require hal.inc 1require hal.inc
2 2
3PR = "r1" 3PR = "r2"
4 4
5EXTRA_OECONF += "--with-linux-input-header=${STAGING_INCDIR}/linux/input.h" 5EXTRA_OECONF += "--with-linux-input-header=${STAGING_INCDIR}/linux/input.h"
6EXTRA_OEMAKE += "-e 'udevrulesdir=$(sysconfdir)/udev/rules.d'" 6EXTRA_OEMAKE += "-e 'udevrulesdir=$(sysconfdir)/udev/rules.d'"
diff --git a/meta/packages/hal/hal_git.bb b/meta/packages/hal/hal_git.bb
index d9205ec945..baed472375 100644
--- a/meta/packages/hal/hal_git.bb
+++ b/meta/packages/hal/hal_git.bb
@@ -1,7 +1,7 @@
1require hal.inc 1require hal.inc
2 2
3PV = "0.5.9.1+git${SRCDATE}" 3PV = "0.5.9.1+git${SRCDATE}"
4PR = "r6" 4PR = "r7"
5 5
6SRC_URI = "git://anongit.freedesktop.org/hal/;protocol=git \ 6SRC_URI = "git://anongit.freedesktop.org/hal/;protocol=git \
7 file://20hal \ 7 file://20hal \