summaryrefslogtreecommitdiffstats
path: root/meta/packages/hal
diff options
context:
space:
mode:
authorRoss Burton <ross@openedhand.com>2007-04-03 09:29:02 +0000
committerRoss Burton <ross@openedhand.com>2007-04-03 09:29:02 +0000
commit064c7e9fe958d600b4ef009224b11550574c07f8 (patch)
tree8e8939284016746c2a1938d135eaae043acc9d49 /meta/packages/hal
parent086817036ce1346dceb4586ddca2435a226764b2 (diff)
downloadpoky-064c7e9fe958d600b4ef009224b11550574c07f8.tar.gz
Remove hal 0.5.8.1
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1424 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/hal')
-rw-r--r--meta/packages/hal/hal_0.5.8.1.bb83
1 files changed, 0 insertions, 83 deletions
diff --git a/meta/packages/hal/hal_0.5.8.1.bb b/meta/packages/hal/hal_0.5.8.1.bb
deleted file mode 100644
index 3a6aee8d09..0000000000
--- a/meta/packages/hal/hal_0.5.8.1.bb
+++ /dev/null
@@ -1,83 +0,0 @@
1DESCRIPTION = "Hardware Abstraction Layer"
2HOMEPAGE = "http://freedesktop.org/Software/hal"
3SECTION = "unknown"
4LICENSE = "GPL LGPL AFL"
5
6DEPENDS = "dbus-glib udev intltool expat libusb"
7RDEPENDS += "udev"
8#RDEPENDS_hal-device-manager = "python hal python-pygnome"
9RRECOMMENDS = "udev-utils"
10
11PR = "r2"
12
13SRC_URI = "http://freedesktop.org/~david/dist/hal-${PV}.tar.gz \
14 file://99_hal"
15
16S = "${WORKDIR}/hal-${PV}"
17
18inherit autotools pkgconfig
19
20EXTRA_OECONF = "--with-hwdata=${datadir}/hwdata \
21 --with-expat=${STAGING_LIBDIR}/.. \
22 --with-dbus-sys=${sysconfdir}/dbus-1/system.d \
23 --with-hotplug=${sysconfdir}/hotplug.d \
24 --disable-docbook-docs \
25 --disable-policy-kit \
26 "
27
28do_install_append() {
29 install -d ${D}/etc/default/volatiles
30 install -m 0644 ${WORKDIR}/99_hal ${D}/etc/default/volatiles
31}
32
33do_stage() {
34 autotools_stage_all
35 install -d ${STAGING_LIBDIR}
36 install -m 755 libhal/.libs/libhal.so.1.0.0 ${STAGING_LIBDIR}/libhal.so
37 install -m 755 libhal-storage/.libs/libhal-storage.so.1.0.0 ${STAGING_LIBDIR}/libhal-storage.so
38}
39
40# At the time the postinst runs, dbus might not be setup so only restart if running
41pkg_postinst_hal () {
42 # can't do this offline
43 if [ "x$D" != "x" ]; then
44 exit 1
45 fi
46
47 /etc/init.d/populate-volatile.sh update
48
49 grep haldaemon /etc/group || addgroup haldaemon
50 grep haldaemon /etc/passwd || adduser --disabled-password --system --home /var/run/hald --no-create-home haldaemon --ingroup haldaemon -g HAL
51
52 DBUSPID=`pidof dbus-daemon`
53
54 if [ "x$DBUSPID" != "x" ]; then
55 /etc/init.d/dbus-1 force-reload
56 fi
57}
58
59pkg_postrm_hal () {
60 deluser haldaemon || true
61 delgroup haldaemon || true
62}
63
64#PACKAGES += "hal-device-manager"
65
66#FILES_hal-device-manager = " \
67# ${datadir}/hal/device-manager/ \
68# ${bindir}/hal-device-manager"
69
70FILES_${PN} = "${sysconfdir} \
71 ${bindir}/lshal \
72 ${bindir}/hal-find-by-capability \
73 ${bindir}/hal-find-by-property \
74 ${bindir}/hal-device \
75 ${bindir}/hal-get-property \
76 ${bindir}/hal-set-property \
77 ${sbindir} \
78 ${libdir}/libhal.so.* \
79 ${libdir}/libhal-storage.so.* \
80 ${libdir}/hal \
81 ${libexecdir} \
82 ${datadir}/hal/fdi \
83 ${datadir}/hal/scripts"