summaryrefslogtreecommitdiffstats
path: root/meta/packages/grub
diff options
context:
space:
mode:
authorSamuel Ortiz <sameo@openedhand.com>2008-10-08 08:16:38 +0000
committerSamuel Ortiz <sameo@openedhand.com>2008-10-08 08:16:38 +0000
commitbfeacba18bad42aebaa6efbbf174be73a0b8ed72 (patch)
tree967156595aab0a853f90a03be6f291097851599b /meta/packages/grub
parentba9e4edf4972f4a114cbd682407bca4c8b7b30c3 (diff)
downloadpoky-bfeacba18bad42aebaa6efbbf174be73a0b8ed72.tar.gz
grub: Initial commit
We need grub for building netbook installation images git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5442 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/grub')
-rw-r--r--meta/packages/grub/grub-0.97/autohell.patch19
-rw-r--r--meta/packages/grub/grub_0.97.bb26
2 files changed, 45 insertions, 0 deletions
diff --git a/meta/packages/grub/grub-0.97/autohell.patch b/meta/packages/grub/grub-0.97/autohell.patch
new file mode 100644
index 0000000000..279c529bb4
--- /dev/null
+++ b/meta/packages/grub/grub-0.97/autohell.patch
@@ -0,0 +1,19 @@
1---
2 configure.ac | 4 ++--
3 1 file changed, 2 insertions(+), 2 deletions(-)
4
5Index: grub-0.97/configure.ac
6===================================================================
7--- grub-0.97.orig/configure.ac 2008-09-12 17:39:52.000000000 +0200
8+++ grub-0.97/configure.ac 2008-09-12 17:40:21.000000000 +0200
9@@ -60,8 +60,8 @@ AC_PROG_CC
10 _AM_DEPENDENCIES(CC)
11
12 dnl Because recent automake complains about AS, set it here.
13-CCAS="$CC"
14-AC_SUBST(CCAS)
15+AM_PROG_AS
16+AC_SUBST(AS)
17
18 AC_ARG_WITH(binutils,
19 [ --with-binutils=DIR search the directory DIR to find binutils])
diff --git a/meta/packages/grub/grub_0.97.bb b/meta/packages/grub/grub_0.97.bb
new file mode 100644
index 0000000000..e93e4deb1c
--- /dev/null
+++ b/meta/packages/grub/grub_0.97.bb
@@ -0,0 +1,26 @@
1DESCRIPTION = "GRUB is the GRand Unified Bootloader"
2HOMEPAGE = "http://www.gnu.org/software/grub"
3SECTION = "bootloaders"
4PRIORITY = "optional"
5RDEPENDS = "diffutils"
6PR = "r2"
7
8SRC_URI = "ftp://alpha.gnu.org/gnu/grub/grub-${PV}.tar.gz; \
9 file://autohell.patch;patch=1 "
10
11inherit autotools
12
13python __anonymous () {
14 import re
15 host = bb.data.getVar('HOST_SYS', d, 1)
16 if not re.match('i.86.*-linux', host):
17 raise bb.parse.SkipPackage("incompatible with host %s" % host)
18}
19
20do_install_append_vmware() {
21 mkdir -p ${D}/boot/
22 ln -sf ../usr/lib/grub/{$TARGET_ARCH}{$TARGET_VENDOR}/ ${D}/boot/grub
23}
24
25FILES_${PN}-doc = "${datadir}"
26FILES_${PN} = "/boot /usr"