summaryrefslogtreecommitdiffstats
path: root/meta/packages/gnome
diff options
context:
space:
mode:
authorRobert Bragg <bob@openedhand.com>2008-09-26 15:16:32 +0000
committerRobert Bragg <bob@openedhand.com>2008-09-26 15:16:32 +0000
commitc4e9ad655ca02e39f57b8ccb7bf5f34b1feeb3bc (patch)
tree435045091d55f4f2dd32d8384b69827dc8db09e8 /meta/packages/gnome
parent52734d2374d3ac4eaee206537a7708fefb46c4cc (diff)
downloadpoky-c4e9ad655ca02e39f57b8ccb7bf5f34b1feeb3bc.tar.gz
Fixes the metacity-clutter revision; packages the plugins; and adds a post
install section to use gconftool-2 to enable the "simple" plugin by default. git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5299 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/gnome')
-rw-r--r--meta/packages/gnome/metacity-clutter_git.bb18
1 files changed, 15 insertions, 3 deletions
diff --git a/meta/packages/gnome/metacity-clutter_git.bb b/meta/packages/gnome/metacity-clutter_git.bb
index d32927147c..831ba507ea 100644
--- a/meta/packages/gnome/metacity-clutter_git.bb
+++ b/meta/packages/gnome/metacity-clutter_git.bb
@@ -2,8 +2,8 @@ SECTION = "x11/wm"
2DESCRIPTION = "Metacity is the boring window manager for the adult in you." 2DESCRIPTION = "Metacity is the boring window manager for the adult in you."
3LICENSE = "GPL" 3LICENSE = "GPL"
4DEPENDS = "startup-notification gtk+ gconf clutter gdk-pixbuf-csource-native" 4DEPENDS = "startup-notification gtk+ gconf clutter gdk-pixbuf-csource-native"
5PR = "r0" 5PR = "r2"
6PV = "2.25.1+gitr${SRCREV}" 6PV = "2.25.1+git${SRCREV}"
7inherit gnome update-alternatives 7inherit gnome update-alternatives
8 8
9SRC_URI = "git://git.o-hand.com/metacity-clutter.git;protocol=git;branch=clutter" 9SRC_URI = "git://git.o-hand.com/metacity-clutter.git;protocol=git;branch=clutter"
@@ -18,9 +18,21 @@ EXTRA_OECONF += "--disable-verbose \
18 --disable-xinerama \ 18 --disable-xinerama \
19 --with-clutter" 19 --with-clutter"
20 20
21FILES_${PN} += "${datadir}/themes" 21FILES_${PN} += "${datadir}/themes ${libdir}/metacity/plugins/clutter/*.so"
22FILES_${PN}-dbg += "${libdir}/metacity/plugins/clutter/.debug/*"
22 23
23do_stage () { 24do_stage () {
24 autotools_stage_all 25 autotools_stage_all
25} 26}
26 27
28pkg_postinst_${PN} () {
29#!/bin/sh -e
30if [ "x$D" != "x" ]; then
31 exit 1
32fi
33
34. ${sysconfdir}/init.d/functions
35
36gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type list --list-type string --set /apps/metacity/general/clutter_plugins '[simple]'
37}
38