summaryrefslogtreecommitdiffstats
path: root/meta/packages/gnome
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-05-14 15:08:33 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2009-05-14 15:08:33 +0100
commit90208115c07a0e8c4cbffce0a846db920619c7c2 (patch)
tree2aadf31dbf5997d5c0b3883d1528d5016519a6d6 /meta/packages/gnome
parent29fb246f5e098f5630d7be5ca27cc05591e032ef (diff)
downloadpoky-90208115c07a0e8c4cbffce0a846db920619c7c2.tar.gz
gobject-introspection: Add an initial version, not functional yet
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/gnome')
-rw-r--r--meta/packages/gnome/gobject-introspection/pathfix.patch53
-rw-r--r--meta/packages/gnome/gobject-introspection_git.bb20
2 files changed, 73 insertions, 0 deletions
diff --git a/meta/packages/gnome/gobject-introspection/pathfix.patch b/meta/packages/gnome/gobject-introspection/pathfix.patch
new file mode 100644
index 0000000000..d640ddba17
--- /dev/null
+++ b/meta/packages/gnome/gobject-introspection/pathfix.patch
@@ -0,0 +1,53 @@
1Index: git/gir/Makefile.am
2===================================================================
3--- git.orig/gir/Makefile.am 2009-05-12 14:37:40.000000000 +0100
4+++ git/gir/Makefile.am 2009-05-12 14:37:40.000000000 +0100
5@@ -40,7 +40,7 @@
6 -I$(GLIB_LIBDIR)/glib-2.0/include \
7 -DGETTEXT_PACKAGE=Dummy \
8 -D__G_I18N_LIB_H__ \
9- $(GLIB_LIBDIR)/glib-2.0/include/glibconfig.h \
10+ $(GLIB_INCLUDEDIR)/glibconfig.h \
11 $(srcdir)/glib-2.0.c \
12 $(GLIB_INCLUDEDIR)/glib/*.h
13 $(SCANNER) $(SCANNER_ARGS) \
14Index: git/giscanner/dumper.py
15===================================================================
16--- git.orig/giscanner/dumper.py 2009-05-12 14:37:40.000000000 +0100
17+++ git/giscanner/dumper.py 2009-05-12 14:37:40.000000000 +0100
18@@ -79,7 +79,7 @@
19 self._tmpdir = tempfile.mkdtemp('', 'tmp-introspect')
20
21 self._compiler_cmd = os.environ.get('CC', 'gcc')
22- self._linker_cmd = os.environ.get('LD', self._compiler_cmd)
23+ self._linker_cmd = os.environ.get('CCLD', self._compiler_cmd)
24 self._pkgconfig_cmd = os.environ.get('PKG_CONFIG', 'pkg-config')
25
26 self._uninst_srcdir = os.environ.get(
27Index: git/giscanner/scannermain.py
28===================================================================
29--- git.orig/giscanner/scannermain.py 2009-05-12 14:37:40.000000000 +0100
30+++ git/giscanner/scannermain.py 2009-05-12 14:37:40.000000000 +0100
31@@ -282,6 +282,7 @@
32 shown_include_warning = False
33 for include in options.includes:
34 if os.sep in include:
35+ continue
36 raise ValueError("Invalid include path %r" % (include, ))
37 include_obj = Include.from_string(include)
38 transformer.register_include(include_obj)
39Index: git/configure.ac
40===================================================================
41--- git.orig/configure.ac 2009-05-12 14:37:40.000000000 +0100
42+++ git/configure.ac 2009-05-12 14:38:01.000000000 +0100
43@@ -191,7 +191,9 @@
44 esac
45 AM_CHECK_PYTHON_HEADERS(,AC_MSG_ERROR([Python headers not found]))
46
47-SHAVE_INIT([scripts])
48+SHAVE_SAVED_LIBTOOL=$LIBTOOL
49+AC_SUBST(SHAVE_SAVED_LIBTOOL)
50+
51 AC_CONFIG_FILES([
52 Makefile
53 gir/Makefile
diff --git a/meta/packages/gnome/gobject-introspection_git.bb b/meta/packages/gnome/gobject-introspection_git.bb
new file mode 100644
index 0000000000..e098044ec4
--- /dev/null
+++ b/meta/packages/gnome/gobject-introspection_git.bb
@@ -0,0 +1,20 @@
1SRC_URI = "git://git.gnome.org/gobject-introspection;protocol=git \
2 file://pathfix.patch;patch=1"
3
4PV = "0.0+git${SRCREV}"
5PR = "r1"
6
7S = "${WORKDIR}/git"
8
9DEPENDS = "libffi python-native gobject-introspection-native"
10DEPENDS_virtclass-native = "libffi-native python-native"
11
12inherit autotools_stage
13
14TARGET_CFLAGS += "-I${STAGING_INCDIR_NATIVE}/python2.5"
15
16do_configure_prepend () {
17 echo "EXTRA_DIST = " > ${S}/gtk-doc.make
18}
19
20BBCLASSEXTEND = "native" \ No newline at end of file