summaryrefslogtreecommitdiffstats
path: root/meta/packages/gdb/gdb-cross_6.4.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2006-10-12 16:01:51 +0000
committerRichard Purdie <richard@openedhand.com>2006-10-12 16:01:51 +0000
commit605f62044e8066494bc0c92f842d57a1754e0eaf (patch)
tree179c9eea06307c6a41cb18c284bf4d86ba41db9e /meta/packages/gdb/gdb-cross_6.4.bb
parentac8a12ba0c6975f1817ed8c8f94606e0839b43db (diff)
downloadpoky-605f62044e8066494bc0c92f842d57a1754e0eaf.tar.gz
gdb: 6.3 -> 6.4
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@798 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/gdb/gdb-cross_6.4.bb')
-rw-r--r--meta/packages/gdb/gdb-cross_6.4.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta/packages/gdb/gdb-cross_6.4.bb b/meta/packages/gdb/gdb-cross_6.4.bb
new file mode 100644
index 0000000000..32076b529e
--- /dev/null
+++ b/meta/packages/gdb/gdb-cross_6.4.bb
@@ -0,0 +1,35 @@
1LICENSE = "GPL"
2DESCRIPTION = "gdb - GNU debugger"
3SECTION = "base"
4PRIORITY = "optional"
5DEPENDS = "ncurses-native"
6
7inherit autotools sdk
8
9S = "${WORKDIR}/gdb-${PV}"
10SRC_URI = "${GNU_MIRROR}/gdb/gdb-${PV}.tar.gz \
11 file://sim-install.patch;patch=1"
12
13FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/gdb-${PV}"
14
15export CC_FOR_BUILD = "${BUILD_CC}"
16export CXX_FOR_BUILD = "${BUILD_CXX}"
17export CPP_FOR_BUILD = "${BUILD_CPP}"
18export CFLAGS_FOR_BUILD = "${BUILD_CFLAGS}"
19export CXXFLAGS_FOR_BUILD = "${BUILD_CXXFLAGS}"
20export CPPFLAGS_FOR_BUILD = "${BUILD_CPPFLAGS}"
21
22EXTRA_OEMAKE = "'SUBDIRS=intl mmalloc libiberty opcodes bfd sim gdb etc utils' LDFLAGS='${BUILD_LDFLAGS}'"
23
24EXTRA_OECONF = "--with-curses --with-readline"
25
26do_configure () {
27# override this function to avoid the autoconf/automake/aclocal/autoheader
28# calls for now
29 gnu-configize
30 oe_runconf
31}
32
33do_stage() {
34 :
35}