summaryrefslogtreecommitdiffstats
path: root/meta/packages/gcc
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2008-01-15 09:52:24 +0000
committerRichard Purdie <richard@openedhand.com>2008-01-15 09:52:24 +0000
commit875c1786751b90bca8749a8aaa6fdbcb26701637 (patch)
tree4477537ea2fa5710424cd3c420cca239ba865cf6 /meta/packages/gcc
parent90d3853872298e0b2a997e9a4fc8fb7b549f90d5 (diff)
downloadpoky-875c1786751b90bca8749a8aaa6fdbcb26701637.tar.gz
Add gcc-native
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3487 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/gcc')
-rw-r--r--meta/packages/gcc/gcc-native.inc28
-rw-r--r--meta/packages/gcc/gcc-native_3.4.4.bb2
2 files changed, 30 insertions, 0 deletions
diff --git a/meta/packages/gcc/gcc-native.inc b/meta/packages/gcc/gcc-native.inc
new file mode 100644
index 0000000000..3cf20a4589
--- /dev/null
+++ b/meta/packages/gcc/gcc-native.inc
@@ -0,0 +1,28 @@
1DEPENDS = ""
2PACKAGES = ""
3PROVIDES = "gcc-native-${PV}"
4
5inherit native
6
7FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/gcc-${PV}"
8
9# This is intended to be a -very- basic config
10EXTRA_OECONF = "--with-local-prefix=${STAGING_DIR_TARGET}${layout_prefix} \
11 --with-newlib \
12 --disable-shared \
13 --disable-threads \
14 --disable-multilib \
15 --disable-__cxa_atexit \
16 --enable-languages=c \
17 --enable-target-optspace \
18 --program-prefix=${TARGET_PREFIX}"
19
20do_install () {
21 :
22}
23
24do_stage () {
25 cd gcc
26 oe_runmake install-common install-headers install-libgcc
27 install -m 0755 xgcc ${STAGING_BINDIR}/gcc-${PV}
28}
diff --git a/meta/packages/gcc/gcc-native_3.4.4.bb b/meta/packages/gcc/gcc-native_3.4.4.bb
new file mode 100644
index 0000000000..2e5d3ac263
--- /dev/null
+++ b/meta/packages/gcc/gcc-native_3.4.4.bb
@@ -0,0 +1,2 @@
1require gcc_${PV}.bb
2require gcc-native.inc