summaryrefslogtreecommitdiffstats
path: root/meta/packages/gcc/gcc_4.1.2.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2007-05-27 21:11:04 +0000
committerRichard Purdie <richard@openedhand.com>2007-05-27 21:11:04 +0000
commit3a11c9d58f56fed153c79521fb052fe3474e02ad (patch)
treed0d85b9276c74ab23b869da66cdd046df9ad6da4 /meta/packages/gcc/gcc_4.1.2.bb
parent32275ea450a65e31c10c84b76142d92e15d64ee7 (diff)
downloadpoky-3a11c9d58f56fed153c79521fb052fe3474e02ad.tar.gz
gcc: Sync 4.1.1, add 4.1.2 (from OE)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1787 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/gcc/gcc_4.1.2.bb')
-rw-r--r--meta/packages/gcc/gcc_4.1.2.bb51
1 files changed, 51 insertions, 0 deletions
diff --git a/meta/packages/gcc/gcc_4.1.2.bb b/meta/packages/gcc/gcc_4.1.2.bb
new file mode 100644
index 0000000000..417909eb1b
--- /dev/null
+++ b/meta/packages/gcc/gcc_4.1.2.bb
@@ -0,0 +1,51 @@
1PR = "r3"
2DESCRIPTION = "The GNU cc and gcc C compilers."
3HOMEPAGE = "http://www.gnu.org/software/gcc/"
4SECTION = "devel"
5LICENSE = "GPL"
6
7inherit autotools gettext
8
9require gcc-package.inc
10
11SRC_URI = "ftp://ftp.gnu.org/pub/gnu/gcc/gcc-4.1.2/gcc-4.1.2.tar.bz2 \
12 file://100-uclibc-conf.patch;patch=1 \
13 file://110-arm-eabi.patch;patch=1 \
14 file://200-uclibc-locale.patch;patch=1 \
15 file://300-libstdc++-pic.patch;patch=1 \
16 file://301-missing-execinfo_h.patch;patch=1 \
17 file://302-c99-snprintf.patch;patch=1 \
18 file://303-c99-complex-ugly-hack.patch;patch=1 \
19 file://304-index_macro.patch;patch=1 \
20 file://602-sdk-libstdc++-includes.patch;patch=1 \
21 file://740-sh-pr24836.patch;patch=1 \
22 file://800-arm-bigendian.patch;patch=1 \
23 file://arm-nolibfloat.patch;patch=1 \
24 file://arm-softfloat.patch;patch=1 \
25 file://gcc41-configure.in.patch;patch=1 \
26 file://arm-thumb.patch;patch=1 \
27 file://arm-thumb-cache.patch;patch=1 \
28 file://ldflags.patch;patch=1 \
29 file://zecke-xgcc-cpp.patch;patch=1 \
30 file://unbreak-armv4t.patch;patch=1 \
31 file://fix-ICE-in-arm_unwind_emit_set.diff;patch=1 \
32 "
33
34SRC_URI_append_sh3 = " file://sh3-installfix-fixheaders.patch;patch=1 "
35
36#Set the fortran bits
37# 'fortran' or '', not 'f77' like gcc3 had
38FORTRAN = ""
39HAS_GFORTRAN = "no"
40HAS_G2C = "no"
41
42#Set the java bits
43JAVA_arm = ""
44JAVA = ""
45
46LANGUAGES = "c,c++${FORTRAN}${JAVA}"
47require gcc3-build.inc
48
49
50EXTRA_OECONF += " --disable-libssp "
51