summaryrefslogtreecommitdiffstats
path: root/meta/packages/flac
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-06-12 23:26:45 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2009-06-12 23:26:45 +0100
commit19592cf696d73e23beef34533958596ea4419696 (patch)
tree8e8cbca411104dff52118bc0af3ea0c0b71cc1f1 /meta/packages/flac
parent826ed806376be744436a85b9af03f031ca6106c4 (diff)
downloadpoky-19592cf696d73e23beef34533958596ea4419696.tar.gz
flac: Convert to autotools_stafe
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/flac')
-rw-r--r--meta/packages/flac/flac_1.1.2.bb50
1 files changed, 2 insertions, 48 deletions
diff --git a/meta/packages/flac/flac_1.1.2.bb b/meta/packages/flac/flac_1.1.2.bb
index 85ffc9beb9..3d0211f750 100644
--- a/meta/packages/flac/flac_1.1.2.bb
+++ b/meta/packages/flac/flac_1.1.2.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "FLAC is a Free Lossless Audio Codec."
2LICENSE = "BSD GPL" 2LICENSE = "BSD GPL"
3SECTION = "libs" 3SECTION = "libs"
4DEPENDS = "libogg" 4DEPENDS = "libogg"
5PR = "r5" 5PR = "r6"
6 6
7SRC_URI = "${SOURCEFORGE_MIRROR}/flac/flac-${PV}.tar.gz \ 7SRC_URI = "${SOURCEFORGE_MIRROR}/flac/flac-${PV}.tar.gz \
8 file://disable-xmms-plugin.patch;patch=1 \ 8 file://disable-xmms-plugin.patch;patch=1 \
@@ -10,7 +10,7 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/flac/flac-${PV}.tar.gz \
10 10
11S = "${WORKDIR}/flac-${PV}" 11S = "${WORKDIR}/flac-${PV}"
12 12
13inherit autotools 13inherit autotools_stage
14 14
15EXTRA_OECONF = "--disable-oggtest --disable-id3libtest \ 15EXTRA_OECONF = "--disable-oggtest --disable-id3libtest \
16 --with-ogg-libraries=${STAGING_LIBDIR} \ 16 --with-ogg-libraries=${STAGING_LIBDIR} \
@@ -36,49 +36,3 @@ do_configure () {
36 sed -i 's/-Wl,-read_only_relocs,warning//g' src/libFLAC/Makefile 36 sed -i 's/-Wl,-read_only_relocs,warning//g' src/libFLAC/Makefile
37} 37}
38 38
39do_stage () {
40 install -d ${STAGING_DATADIR}/aclocal
41
42 oe_libinstall -a -so -C src/libOggFLAC libOggFLAC ${STAGING_LIBDIR}/
43 install -d ${STAGING_INCDIR}/OggFLAC
44 install -m 0644 ${S}/include/OggFLAC/export.h ${STAGING_INCDIR}/OggFLAC/export.h
45
46 install -m 0644 ${S}/include/OggFLAC/all.h ${STAGING_INCDIR}/OggFLAC/all.h
47 install -m 0644 ${S}/include/OggFLAC/stream_encoder.h ${STAGING_INCDIR}/OggFLAC/stream_encoder.h
48 install -m 0644 ${S}/include/OggFLAC/stream_decoder.h ${STAGING_INCDIR}/OggFLAC/stream_decoder.h
49 install -m 0644 ${S}/src/libOggFLAC/libOggFLAC.m4 ${STAGING_DATADIR}/aclocal/
50
51 oe_libinstall -a -so -C src/libFLAC libFLAC ${STAGING_LIBDIR}/
52 install -d ${STAGING_INCDIR}/FLAC
53 install -m 0644 ${S}/include/FLAC/export.h ${STAGING_INCDIR}/FLAC/export.h
54 install -m 0644 ${S}/include/FLAC/metadata.h ${STAGING_INCDIR}/FLAC/metadata.h
55 install -m 0644 ${S}/include/FLAC/all.h ${STAGING_INCDIR}/FLAC/all.h
56 install -m 0644 ${S}/include/FLAC/format.h ${STAGING_INCDIR}/FLAC/format.h
57 install -m 0644 ${S}/include/FLAC/stream_encoder.h ${STAGING_INCDIR}/FLAC/stream_encoder.h
58 install -m 0644 ${S}/include/FLAC/stream_decoder.h ${STAGING_INCDIR}/FLAC/stream_decoder.h
59 install -m 0644 ${S}/include/FLAC/ordinals.h ${STAGING_INCDIR}/FLAC/ordinals.h
60 install -m 0644 ${S}/include/FLAC/seekable_stream_encoder.h ${STAGING_INCDIR}/FLAC/seekable_stream_encoder.h
61 install -m 0644 ${S}/include/FLAC/file_encoder.h ${STAGING_INCDIR}/FLAC/file_encoder.h
62 install -m 0644 ${S}/include/FLAC/seekable_stream_decoder.h ${STAGING_INCDIR}/FLAC/seekable_stream_decoder.h
63 install -m 0644 ${S}/include/FLAC/file_decoder.h ${STAGING_INCDIR}/FLAC/file_decoder.h
64 install -m 0644 ${S}/include/FLAC/assert.h ${STAGING_INCDIR}/FLAC/assert.h
65 install -m 0644 ${S}/include/FLAC/callback.h ${STAGING_INCDIR}/FLAC/callback.h
66 install -m 0644 ${S}/src/libFLAC/libFLAC.m4 ${STAGING_DATADIR}/aclocal/
67
68 oe_libinstall -a -so -C src/libFLAC++ libFLAC++ ${STAGING_LIBDIR}/
69 install -d ${STAGING_INCDIR}/FLAC++
70 install -m 0644 ${S}/include/FLAC++/export.h ${STAGING_INCDIR}/FLAC++/export.h
71 install -m 0644 ${S}/include/FLAC++/metadata.h ${STAGING_INCDIR}/FLAC++/metadata.h
72 install -m 0644 ${S}/include/FLAC++/all.h ${STAGING_INCDIR}/FLAC++/all.h
73 install -m 0644 ${S}/include/FLAC++/encoder.h ${STAGING_INCDIR}/FLAC++/encoder.h
74 install -m 0644 ${S}/include/FLAC++/decoder.h ${STAGING_INCDIR}/FLAC++/decoder.h
75 install -m 0644 ${S}/src/libFLAC++/libFLAC++.m4 ${STAGING_DATADIR}/aclocal/
76
77 oe_libinstall -a -so -C src/libOggFLAC++ libOggFLAC++ ${STAGING_LIBDIR}/
78 install -d ${STAGING_INCDIR}/OggFLAC++
79 install -m 0644 ${S}/include/OggFLAC++/export.h ${STAGING_INCDIR}/OggFLAC++/export.h
80 install -m 0644 ${S}/include/OggFLAC++/all.h ${STAGING_INCDIR}/OggFLAC++/all.h
81 install -m 0644 ${S}/include/OggFLAC++/encoder.h ${STAGING_INCDIR}/OggFLAC++/encoder.h
82 install -m 0644 ${S}/include/OggFLAC++/decoder.h ${STAGING_INCDIR}/OggFLAC++/decoder.h
83 install -m 0644 ${S}/src/libOggFLAC++/libOggFLAC++.m4 ${STAGING_DATADIR}/aclocal/
84}