summaryrefslogtreecommitdiffstats
path: root/meta/packages/db/db_4.3.29.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2006-07-21 10:10:31 +0000
committerRichard Purdie <richard@openedhand.com>2006-07-21 10:10:31 +0000
commitb2f192faabe412adce79534e22efe9fb69ee40e2 (patch)
tree7076c49d4286f8a1733650bd8fbc7161af200d57 /meta/packages/db/db_4.3.29.bb
parent2cf0eadf9f730027833af802d7e6c90b44248f80 (diff)
downloadpoky-b2f192faabe412adce79534e22efe9fb69ee40e2.tar.gz
Rename /openembedded/ -> /meta/
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@530 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/db/db_4.3.29.bb')
-rw-r--r--meta/packages/db/db_4.3.29.bb100
1 files changed, 100 insertions, 0 deletions
diff --git a/meta/packages/db/db_4.3.29.bb b/meta/packages/db/db_4.3.29.bb
new file mode 100644
index 0000000000..a4059aac60
--- /dev/null
+++ b/meta/packages/db/db_4.3.29.bb
@@ -0,0 +1,100 @@
1# Has issues with eds
2DEFAULT_PREFERENCE = "-1"
3
4# Version 4 of the Berkeley DB from Sleepycat
5#
6# At present this package only installs the DB code
7# itself (shared libraries, .a in the dev package),
8# documentation and headers.
9#
10# The headers have the same names as those as v3
11# of the DB, only one version can be used *for dev*
12# at once - DB3 and DB4 can both be installed on the
13# same system at the same time if really necessary.
14SECTION = "libs"
15DESCRIPTION = "Berkeley DB v4."
16HOMEPAGE = "http://www.sleepycat.com"
17LICENSE = "BSD Sleepycat"
18VIRTUAL_NAME ?= "virtual/db"
19CONFLICTS = "db3"
20PR = "r3"
21
22SRC_URI = "http://downloads.sleepycat.com/db-${PV}.tar.gz"
23#SRC_URI_MD5 = "http://downloads.sleepycat.com/db-${PV}.tar.gz.md5"
24SRC_URI += "file://arm-thumb-mutex.patch;patch=1"
25
26inherit autotools
27
28# Put virtual/db in any appropriate provider of a
29# relational database, use it as a dependency in
30# place of a specific db and use:
31#
32# PREFERRED_PROVIDER_virtual/db
33#
34# to select the correct db in the build (distro) .conf
35PROVIDES += "${VIRTUAL_NAME}"
36
37# bitbake isn't quite clever enough to deal with sleepycat,
38# the distribution sits in the expected directory, but all
39# the builds must occur from a sub-directory. The following
40# persuades bitbake to go to the right place
41S = "${WORKDIR}/db-${PV}/dist"
42B = "${WORKDIR}/db-${PV}/build_unix"
43
44# The executables go in a separate package - typically there
45# is no need to install these unless doing real database
46# management on the system.
47PACKAGES += " ${PN}-bin"
48
49# Package contents
50FILES_${PN} = "${libdir}/libdb-4*so*"
51FILES_${PN}-bin = "${bindir}"
52# The dev package has the .so link (as in db3) and the .a's -
53# it is therefore incompatible (cannot be installed at the
54# same time) as the db3 package
55FILES_${PN}-dev = "${includedir} ${libdir}"
56
57#configuration - set in local.conf to override
58DB4_CONFIG ?= "--enable-o_direct --enable-smallbuild --enable-compat185"
59EXTRA_OECONF = "${DB4_CONFIG}"
60
61# Override the MUTEX setting here, the POSIX library is
62# the default - "POSIX/pthreads/library".
63# Don't ignore the nice SWP instruction on the ARM:
64# These enable the ARM assembler mutex code, this won't
65# work with thumb compilation...
66ARM_MUTEX = "--with-mutex=ARM/gcc-assembly"
67MUTEX = ""
68MUTEX_arm = "${ARM_MUTEX}"
69MUTEX_armeb = "${ARM_MUTEX}"
70EXTRA_OECONF += "${MUTEX}"
71
72# Cancel the site stuff - it's set for db3 and destroys the
73# configure.
74CONFIG_SITE = ""
75do_configure() {
76 oe_runconf
77}
78
79do_stage() {
80 # The .h files get installed read-only, the autostage
81 # function just uses cp -pPR, so do this by hand
82 rm -rf ${STAGE_TEMP}
83 mkdir -p ${STAGE_TEMP}
84 oe_runmake DESTDIR="${STAGE_TEMP}" install_include
85 cp -pPRf ${STAGE_TEMP}/${includedir}/* ${STAGING_INCDIR}/.
86 rm -rf ${STAGE_TEMP}
87 oe_libinstall -so -C .libs libdb-4.3 ${STAGING_LIBDIR}
88 ln -sf libdb-4.3.so ${STAGING_LIBDIR}/libdb.so
89 ln -sf libdb-4.3.a ${STAGING_LIBDIR}/libdb.a
90}
91
92do_install_append() {
93 # The docs end up in /usr/docs - not right.
94 if test -d "${D}/${prefix}/docs"
95 then
96 mkdir -p "${D}/${datadir}"
97 test ! -d "${D}/${docdir}" || rmdir "${D}/${docdir}"
98 mv "${D}/${prefix}/docs" "${D}/${docdir}"
99 fi
100}