summaryrefslogtreecommitdiffstats
path: root/meta/packages/db/db_4.1.25.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2008-06-16 10:53:30 +0000
committerRichard Purdie <richard@openedhand.com>2008-06-16 10:53:30 +0000
commit9c0b1afe54ecd2471514e421c4911d5982b8c9d9 (patch)
treee563fe56bd623f3a0c1fab8372299830b15d4db7 /meta/packages/db/db_4.1.25.bb
parent59ac2af3c929f31e3516a2749da72448d9ffc2ff (diff)
downloadpoky-9c0b1afe54ecd2471514e421c4911d5982b8c9d9.tar.gz
db: Drop 4.1.25
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4665 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/db/db_4.1.25.bb')
-rw-r--r--meta/packages/db/db_4.1.25.bb87
1 files changed, 0 insertions, 87 deletions
diff --git a/meta/packages/db/db_4.1.25.bb b/meta/packages/db/db_4.1.25.bb
deleted file mode 100644
index fe15a0ceaa..0000000000
--- a/meta/packages/db/db_4.1.25.bb
+++ /dev/null
@@ -1,87 +0,0 @@
1# Version 4 of the Berkeley DB from Sleepycat
2#
3# At present this package only installs the DB code
4# itself (shared libraries, .a in the dev package),
5# documentation and headers.
6#
7# The headers have the same names as those as v3
8# of the DB, only one version can be used *for dev*
9# at once - DB3 and DB4 can both be installed on the
10# same system at the same time if really necessary.
11SECTION = "libs"
12DESCRIPTION = "Berkeley DB v4."
13HOMEPAGE = "http://www.oracle.com/technology/products/berkeley-db/db/index.html"
14LICENSE = "BSD Sleepycat"
15PR = "r3"
16
17SRC_URI = "http://download.oracle.com/berkeley-db/${P}.tar.gz"
18
19inherit autotools
20
21# At present virtual/db is only in the db4 file, but it
22# should probably be in the other candidates (db3, gdbm)
23# because it doesn't make any sense to have multiple
24# relational databases on an embedded machine...
25PROVIDES += " db4 virtual/db"
26
27# bitbake isn't quite clever enough to deal with sleepycat,
28# the distribution sits in the expected directory, but all
29# the builds must occur from a sub-directory. The following
30# persuades bitbake to go to the right place
31S = "${WORKDIR}/${P}/build_unix"
32
33# The executables go in a separate package - typically there
34# is no need to install these unless doing real database
35# management on the system.
36PACKAGES += " ${PN}-bin"
37
38# Package contents
39FILES_${PN} = "${libdir}/libdb*so*"
40FILES_${PN}-bin = "${bindir}/*"
41# The dev package has the .so link (as in db3) and the .a's -
42# it is therefore incompatible (cannot be installed at the
43# same time) as the db3 package
44FILES_${PN}-dev = "${includedir} ${libdir}/*"
45
46#configuration - set in local.conf to override
47DB4_CONFIG ?= "--enable-o_direct --enable-smallbuild"
48# Override the MUTEX setting here, the POSIX library is
49# the default - "POSIX/pthreads/library".
50# Don't ignore the nice SWP instruction on the ARM:
51EXTRA_OECONF = "${DB4_CONFIG}"
52# These enable the ARM assembler mutex code, this won't
53# work with thumb compilation...
54ARM_MUTEX = "--with-mutex=ARM/gcc-assembly"
55ARM_MUTEX_thumb = ""
56# NOTE: only tested on nslu2, should probably be _armeb
57EXTRA_OECONF_nslu2 = "${DB4_CONFIG} ${ARM_MUTEX}"
58
59# Cancel the site stuff - it's set for db3 and destroys the
60# configure.
61CONFIG_SITE = ""
62do_configure() {
63 echo '#!/bin/sh' >${S}/configure
64 echo 'rm ${S}/configure' >>${S}/configure
65 echo 'exec ../dist/configure "$@"' >>${S}/configure
66 chmod a+x ${S}/configure
67 oe_runconf
68}
69
70do_stage() {
71 oe_runmake DESTDIR="${STAGING_DIR}/${BUILD_SYS}" includedir="${STAGING_INCDIR}" install_include
72 oe_libinstall -so -C .libs libdb-4.1 ${STAGING_LIBDIR}
73 ln -s ${STAGING_LIBDIR}/libdb-4.1.so ${STAGING_LIBDIR}/libdb-4.so
74 ln -s ${STAGING_LIBDIR}/libdb-4.so ${STAGING_LIBDIR}/libdb.so
75}
76
77do_install() {
78 oe_runmake includedir="${D}${includedir}" libdir="${D}${libdir}" bindir="${D}${bindir}" docdir="${D}${docdir}" install
79
80 # The docs end up in /usr/docs - not right.
81 if test -d "${D}/${prefix}/docs"
82 then
83 mkdir -p "${D}/${datadir}"
84 test ! -d "${D}/${docdir}" || rmdir "${D}/${docdir}"
85 mv "${D}/${prefix}/docs" "${D}/${docdir}"
86 fi
87}