summaryrefslogtreecommitdiffstats
path: root/meta/packages/coreutils
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2007-04-25 13:23:09 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2007-04-25 13:23:09 +0000
commit2445bb8a765ecdcc2386a60c9c8e876cff727ad2 (patch)
treec58182e36d07fbbb65dec7cda4e634006b6a8ea6 /meta/packages/coreutils
parentad2237b813cd10b2168422373cc4799e041c5885 (diff)
downloadpoky-2445bb8a765ecdcc2386a60c9c8e876cff727ad2.tar.gz
coreutils: add forgotten patches for 5.3.0
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1558 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/coreutils')
-rw-r--r--meta/packages/coreutils/coreutils-5.3.0/install-cross.patch27
-rw-r--r--meta/packages/coreutils/coreutils-5.3.0/man.patch42
-rw-r--r--meta/packages/coreutils/coreutils-5.3.0/rename-tee-for-glibc2.5.patch33
-rw-r--r--meta/packages/coreutils/coreutils-5.3.0/uptime-pow-lib.patch11
4 files changed, 113 insertions, 0 deletions
diff --git a/meta/packages/coreutils/coreutils-5.3.0/install-cross.patch b/meta/packages/coreutils/coreutils-5.3.0/install-cross.patch
new file mode 100644
index 0000000000..98ba3d916c
--- /dev/null
+++ b/meta/packages/coreutils/coreutils-5.3.0/install-cross.patch
@@ -0,0 +1,27 @@
1--- src/install.c~ 2003-08-09 18:46:45.000000000 +0100
2+++ src/install.c 2004-03-27 18:38:45.000000000 +0000
3@@ -516,7 +516,14 @@
4 strip (const char *path)
5 {
6 int status;
7- pid_t pid = fork ();
8+ pid_t pid;
9+ char *strip_name;
10+
11+ strip_name = getenv ("STRIP");
12+ if (strip_name == NULL)
13+ strip_name = "strip";
14+
15+ pid = fork ();
16
17 switch (pid)
18 {
19@@ -524,7 +531,7 @@
20 error (EXIT_FAILURE, errno, _("fork system call failed"));
21 break;
22 case 0: /* Child. */
23- execlp ("strip", "strip", path, NULL);
24+ execlp (strip_name, "strip", path, NULL);
25 error (EXIT_FAILURE, errno, _("cannot run strip"));
26 break;
27 default: /* Parent. */
diff --git a/meta/packages/coreutils/coreutils-5.3.0/man.patch b/meta/packages/coreutils/coreutils-5.3.0/man.patch
new file mode 100644
index 0000000000..5060e4fdff
--- /dev/null
+++ b/meta/packages/coreutils/coreutils-5.3.0/man.patch
@@ -0,0 +1,42 @@
1
2#
3# Patch managed by http://www.holgerschurig.de/patcher.html
4#
5
6--- coreutils-5.3.0/configure.ac~man
7+++ coreutils-5.3.0/configure.ac
8@@ -237,6 +237,20 @@
9 AM_GNU_GETTEXT([external], [need-ngettext])
10 AM_GNU_GETTEXT_VERSION(0.13.1)
11
12+AC_MSG_CHECKING([whether to build man pages])
13+AC_ARG_WITH(manpages,
14+ AS_HELP_STRING([--with-manpages],
15+ [Enable building of manpages (default=yes)]),
16+ [cu_cv_build_manpages=$enableval],
17+ [cu_cv_build_manpages=yes])
18+# help2man doesn't work when crosscompiling, as it needs to run the
19+# binary that was built.
20+if test x"$cross_compiling" = x"yes"; then
21+ cu_cv_build_manpages=no
22+fi
23+AC_MSG_RESULT($cu_cv_build_manpages)
24+AM_CONDITIONAL(ENABLE_MANPAGES, test x"$cu_cv_build_manpages" = x"yes")
25+
26 AC_CONFIG_FILES(
27 Makefile
28 doc/Makefile
29--- coreutils-5.3.0/Makefile.am~man
30+++ coreutils-5.3.0/Makefile.am
31@@ -1,6 +1,11 @@
32 ## Process this file with automake to produce Makefile.in -*-Makefile-*-
33
34+if ENABLE_MANPAGES
35 SUBDIRS = lib src doc man po tests
36+else
37+SUBDIRS = lib src doc po tests
38+endif
39+
40 EXTRA_DIST = Makefile.cfg Makefile.maint GNUmakefile \
41 .kludge-stamp .prev-version THANKS-to-translators THANKStt.in \
42 .x-sc_space_tab .x-sc_sun_os_names \
diff --git a/meta/packages/coreutils/coreutils-5.3.0/rename-tee-for-glibc2.5.patch b/meta/packages/coreutils/coreutils-5.3.0/rename-tee-for-glibc2.5.patch
new file mode 100644
index 0000000000..148a5f4f8f
--- /dev/null
+++ b/meta/packages/coreutils/coreutils-5.3.0/rename-tee-for-glibc2.5.patch
@@ -0,0 +1,33 @@
1Glibc 2.5 has a function called tee which conflicts with the same function
2in coreutils. This patch renames the function to tee_files (as is done in
3the newer coreutils versions.)
4
5--- coreutils-5.3.0/src/tee.c 2006/10/23 07:35:00 1.1
6+++ coreutils-5.3.0/src/tee.c 2006/10/23 07:35:16
7@@ -31,7 +31,7 @@
8
9 #define AUTHORS "Mike Parker", "Richard M. Stallman", "David MacKenzie"
10
11-static bool tee (int nfiles, const char **files);
12+static bool tee_files (int nfiles, const char **files);
13
14 /* If true, append to output files rather than truncating them. */
15 static bool append;
16@@ -121,7 +121,7 @@
17 /* Do *not* warn if tee is given no file arguments.
18 POSIX requires that it work when given no arguments. */
19
20- ok = tee (argc - optind, (const char **) &argv[optind]);
21+ ok = tee_files (argc - optind, (const char **) &argv[optind]);
22 if (close (STDIN_FILENO) != 0)
23 error (EXIT_FAILURE, errno, _("standard input"));
24
25@@ -133,7 +133,7 @@
26 Return true if successful. */
27
28 static bool
29-tee (int nfiles, const char **files)
30+tee_files (int nfiles, const char **files)
31 {
32 FILE **descriptors;
33 char buffer[BUFSIZ];
diff --git a/meta/packages/coreutils/coreutils-5.3.0/uptime-pow-lib.patch b/meta/packages/coreutils/coreutils-5.3.0/uptime-pow-lib.patch
new file mode 100644
index 0000000000..5eb3fca676
--- /dev/null
+++ b/meta/packages/coreutils/coreutils-5.3.0/uptime-pow-lib.patch
@@ -0,0 +1,11 @@
1--- coreutils-5.3.0/src/Makefile.am.orig 2005-09-27 22:34:35.659272058 -0700
2+++ coreutils-5.3.0/src/Makefile.am 2005-09-27 22:34:39.403507668 -0700
3@@ -74,7 +74,7 @@
4 sleep_LDADD = $(nanosec_libs)
5 tail_LDADD = $(nanosec_libs)
6
7-uptime_LDADD = $(LDADD) $(GETLOADAVG_LIBS)
8+uptime_LDADD = $(LDADD) $(POW_LIB) $(GETLOADAVG_LIBS)
9
10 su_LDADD = $(LDADD) $(LIB_CRYPT)
11