summaryrefslogtreecommitdiffstats
path: root/meta/packages/clutter
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-11-30 17:44:00 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2009-11-30 17:44:00 +0000
commit5bc023564072e5cf485de2d40cc8c3f6e04cb7b0 (patch)
tree0d830eda768fc0dc602530f7ccc0142980b75cfd /meta/packages/clutter
parent6661806a5e2d0c30237097b8686e6d8da9ed42ff (diff)
downloadpoky-5bc023564072e5cf485de2d40cc8c3f6e04cb7b0.tar.gz
clutter-git: Update patch
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/clutter')
-rw-r--r--meta/packages/clutter/clutter/enable_tests.patch28
1 files changed, 14 insertions, 14 deletions
diff --git a/meta/packages/clutter/clutter/enable_tests.patch b/meta/packages/clutter/clutter/enable_tests.patch
index 953edf6bbc..f4af7c94f6 100644
--- a/meta/packages/clutter/clutter/enable_tests.patch
+++ b/meta/packages/clutter/clutter/enable_tests.patch
@@ -6,27 +6,27 @@
6 6
7Index: git/tests/interactive/Makefile.am 7Index: git/tests/interactive/Makefile.am
8=================================================================== 8===================================================================
9--- git.orig/tests/interactive/Makefile.am 2009-03-12 11:01:36.000000000 +0000 9--- git.orig/tests/interactive/Makefile.am 2009-11-30 17:39:46.000000000 +0000
10+++ git/tests/interactive/Makefile.am 2009-03-12 11:04:12.000000000 +0000 10+++ git/tests/interactive/Makefile.am 2009-11-30 17:42:30.000000000 +0000
11@@ -77,7 +77,7 @@ 11@@ -88,7 +88,7 @@
12 AM_CFLAGS = $(CLUTTER_CFLAGS) $(MAINTAINER_CFLAGS) 12
13 AM_LDFLAGS = $(CLUTTER_LIBS) 13 common_ldadd = $(top_builddir)/clutter/libclutter-@CLUTTER_WINSYS@-@CLUTTER_API_VERSION@.la
14 14
15-noinst_PROGRAMS = test-interactive 15-noinst_PROGRAMS = test-interactive
16+bin_PROGRAMS = test-interactive 16+bin_PROGRAMS = test-interactive
17 17
18 test_interactive_SOURCES = \ 18 test_interactive_SOURCES = test-main.c $(UNIT_TESTS)
19 test-main.c \ 19 test_interactive_CFLAGS = $(CLUTTER_CFLAGS) $(MAINTAINER_CFLAGS)
20Index: git/tests/interactive/test-actors.c 20Index: git/tests/interactive/test-actors.c
21=================================================================== 21===================================================================
22--- git.orig/tests/interactive/test-actors.c 2009-03-12 11:01:36.000000000 +0000 22--- git.orig/tests/interactive/test-actors.c 2009-11-30 17:39:46.000000000 +0000
23+++ git/tests/interactive/test-actors.c 2009-03-12 11:06:32.000000000 +0000 23+++ git/tests/interactive/test-actors.c 2009-11-30 17:43:03.000000000 +0000
24@@ -182,7 +182,7 @@ 24@@ -178,7 +178,7 @@
25 oh->scaler_1 = clutter_behaviour_scale_new (alpha, 0.5, 0.5, 1.0, 1.0); 25 oh->scaler_1 = clutter_behaviour_scale_new (alpha, 0.5, 0.5, 1.0, 1.0);
26 oh->scaler_2 = clutter_behaviour_scale_new (alpha, 1.0, 1.0, 0.5, 0.5); 26 oh->scaler_2 = clutter_behaviour_scale_new (alpha, 1.0, 1.0, 0.5, 0.5);
27 27
28- real_hand = clutter_texture_new_from_file ("redhand.png", &error); 28- file = g_build_filename (TESTS_DATADIR, "redhand.png", NULL);
29+ real_hand = clutter_texture_new_from_file ("/usr/share/clutter/redhand.png", &error); 29+ file = g_build_filename (TESTS_DATADIR, "/usr/share/clutter/redhand.png", NULL);
30 real_hand = clutter_texture_new_from_file (file, &error);
30 if (real_hand == NULL) 31 if (real_hand == NULL)
31 { 32 g_error ("image load failed: %s", error->message);
32 g_error ("image load failed: %s", error->message);