diff options
author | Richard Purdie <rpurdie@linux.intel.com> | 2010-08-27 15:14:24 +0100 |
---|---|---|
committer | Richard Purdie <rpurdie@linux.intel.com> | 2010-08-27 15:29:45 +0100 |
commit | 29d6678fd546377459ef75cf54abeef5b969b5cf (patch) | |
tree | 8edd65790e37a00d01c3f203f773fe4b5012db18 /meta/packages/clipboard-manager/files | |
parent | da49de6885ee1bc424e70bc02f21f6ab920efb55 (diff) | |
download | poky-29d6678fd546377459ef75cf54abeef5b969b5cf.tar.gz |
Major layout change to the packages directory
Having one monolithic packages directory makes it hard to find things
and is generally overwhelming. This commit splits it into several
logical sections roughly based on function, recipes.txt gives more
information about the classifications used.
The opportunity is also used to switch from "packages" to "recipes"
as used in OpenEmbedded as the term "packages" can be confusing to
people and has many different meanings.
Not all recipes have been classified yet, this is just a first pass
at separating things out. Some packages are moved to meta-extras as
they're no longer actively used or maintained.
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/clipboard-manager/files')
-rw-r--r-- | meta/packages/clipboard-manager/files/daemonize.patch | 44 | ||||
-rw-r--r-- | meta/packages/clipboard-manager/files/makefile.patch | 18 | ||||
-rw-r--r-- | meta/packages/clipboard-manager/files/script.patch | 39 |
3 files changed, 0 insertions, 101 deletions
diff --git a/meta/packages/clipboard-manager/files/daemonize.patch b/meta/packages/clipboard-manager/files/daemonize.patch deleted file mode 100644 index 51ce4781a5..0000000000 --- a/meta/packages/clipboard-manager/files/daemonize.patch +++ /dev/null | |||
@@ -1,44 +0,0 @@ | |||
1 | Index: 0.6.4/manager.c | ||
2 | =================================================================== | ||
3 | --- 0.6.4.orig/manager.c 2007-06-28 12:23:37.000000000 +0100 | ||
4 | +++ 0.6.4/manager.c 2007-06-28 12:36:14.000000000 +0100 | ||
5 | @@ -68,7 +68,8 @@ | ||
6 | ClipboardManager *manager; | ||
7 | int terminated = False; | ||
8 | Display *display; | ||
9 | - | ||
10 | + pid_t pid; | ||
11 | + | ||
12 | display = XOpenDisplay (NULL); | ||
13 | |||
14 | if (!display) | ||
15 | @@ -83,6 +84,29 @@ | ||
16 | exit (1); | ||
17 | } | ||
18 | |||
19 | + /* deamonize */ | ||
20 | + pid = fork(); | ||
21 | + switch (pid) | ||
22 | + { | ||
23 | + case -1: fprintf (stderr, "Fork failed.\n"); | ||
24 | + /* Fall through */ | ||
25 | + default: exit(0); break; | ||
26 | + case 0: break; | ||
27 | + } | ||
28 | + | ||
29 | + chdir ("/"); | ||
30 | + setsid (); | ||
31 | + umask (0); | ||
32 | + | ||
33 | + pid = fork(); | ||
34 | + switch (pid) | ||
35 | + { | ||
36 | + case -1: fprintf (stderr, "Fork failed.\n"); | ||
37 | + /* Fall through */ | ||
38 | + default: exit(0); break; | ||
39 | + case 0: break; | ||
40 | + } | ||
41 | + | ||
42 | XSetErrorHandler (x_error); | ||
43 | manager = clipboard_manager_new (display, | ||
44 | error_trap_push, error_trap_pop, | ||
diff --git a/meta/packages/clipboard-manager/files/makefile.patch b/meta/packages/clipboard-manager/files/makefile.patch deleted file mode 100644 index 6e48da004c..0000000000 --- a/meta/packages/clipboard-manager/files/makefile.patch +++ /dev/null | |||
@@ -1,18 +0,0 @@ | |||
1 | Index: 0.6.4/Makefile.am | ||
2 | =================================================================== | ||
3 | --- 0.6.4.orig/Makefile.am 2007-06-28 12:23:37.000000000 +0100 | ||
4 | +++ 0.6.4/Makefile.am 2007-06-28 14:21:23.000000000 +0100 | ||
5 | @@ -1,5 +1,3 @@ | ||
6 | -SUBDIRS = debian | ||
7 | - | ||
8 | bin_PROGRAMS = clipboard-manager | ||
9 | |||
10 | INCLUDES = \ | ||
11 | @@ -21,6 +19,6 @@ | ||
12 | clipboard.txt \ | ||
13 | clipboard.sh | ||
14 | |||
15 | -servicedir = $(sysconfdir)/osso-af-init | ||
16 | +servicedir = $(sysconfdir)/X11/Xsession.d | ||
17 | |||
18 | service_DATA = clipboard.sh | ||
diff --git a/meta/packages/clipboard-manager/files/script.patch b/meta/packages/clipboard-manager/files/script.patch deleted file mode 100644 index 09e68620d7..0000000000 --- a/meta/packages/clipboard-manager/files/script.patch +++ /dev/null | |||
@@ -1,39 +0,0 @@ | |||
1 | Index: 0.6.4/clipboard.sh | ||
2 | =================================================================== | ||
3 | --- 0.6.4.orig/clipboard.sh 2007-06-28 12:23:37.000000000 +0100 | ||
4 | +++ 0.6.4/clipboard.sh 2007-06-28 14:27:39.000000000 +0100 | ||
5 | @@ -1,33 +1,2 @@ | ||
6 | #!/bin/sh | ||
7 | -# Clipboard persistence manager startup script | ||
8 | - | ||
9 | -if [ "x$AF_PIDDIR" = "x" ]; then | ||
10 | - echo "$0: Error, AF_PIDDIR is not defined" | ||
11 | - exit 2 | ||
12 | -fi | ||
13 | -if [ "x$LAUNCHWRAPPER_NICE_TRYRESTART" = "x" ]; then | ||
14 | - echo "$0: Error, LAUNCHWRAPPER_NICE_TRYRESTART is not defined" | ||
15 | - exit 2 | ||
16 | -fi | ||
17 | -if [ ! -w $AF_PIDDIR ]; then | ||
18 | - echo "$0: Error, directory $AF_PIDDIR is not writable" | ||
19 | - exit 2 | ||
20 | -fi | ||
21 | -PROG=/usr/bin/clipboard-manager | ||
22 | -SVC="clipboard-manager" | ||
23 | - | ||
24 | -case "$1" in | ||
25 | -start) START=TRUE | ||
26 | - ;; | ||
27 | -stop) START=FALSE | ||
28 | - ;; | ||
29 | -*) echo "Usage: $0 {start|stop}" | ||
30 | - exit 1 | ||
31 | - ;; | ||
32 | -esac | ||
33 | - | ||
34 | -if [ $START = TRUE ]; then | ||
35 | - source $LAUNCHWRAPPER_NICE_TRYRESTART start "$SVC" $PROG | ||
36 | -else | ||
37 | - source $LAUNCHWRAPPER_NICE_TRYRESTART stop "$SVC" $PROG | ||
38 | -fi | ||
39 | +/usr/bin/clipboard-manager & | ||