summaryrefslogtreecommitdiffstats
path: root/meta/packages/bash
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2007-10-25 11:52:46 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2007-10-25 11:52:46 +0000
commit74beec7beb3c730818891818be1e7b525eb001b5 (patch)
tree2133c8ee4f7eede573c01e67a214133861da2d81 /meta/packages/bash
parent52b64ddf61a38940e5ae7675f9dfedc3253e39cc (diff)
downloadpoky-74beec7beb3c730818891818be1e7b525eb001b5.tar.gz
bash: sync with OE (no package changes)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2959 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/bash')
-rw-r--r--meta/packages/bash/bash.inc26
-rw-r--r--meta/packages/bash/bash_3.2.bb27
2 files changed, 28 insertions, 25 deletions
diff --git a/meta/packages/bash/bash.inc b/meta/packages/bash/bash.inc
new file mode 100644
index 0000000000..80aedfa1c8
--- /dev/null
+++ b/meta/packages/bash/bash.inc
@@ -0,0 +1,26 @@
1DESCRIPTION = "An sh-compatible command language interpreter."
2HOMEPAGE = "http://cnswww.cns.cwru.edu/~chet/bash/bashtop.html"
3DEPENDS = "ncurses"
4SECTION = "base/shell"
5LICENSE = "GPL"
6
7inherit autotools gettext
8
9PARALLEL_MAKE = ""
10
11bindir = "/bin"
12sbindir = "/sbin"
13
14EXTRA_OECONF = "--with-ncurses"
15export CC_FOR_BUILD = "${BUILD_CC}"
16
17do_configure () {
18 gnu-configize
19 oe_runconf
20}
21
22pkg_postinst () {
23 touch ${sysconfdir}/shells
24 grep -q "bin/bash" ${sysconfdir}/shells || echo /bin/bash >> ${sysconfdir}/shells
25 grep -q "bin/sh" ${sysconfdir}/shells || echo /bin/sh >> ${sysconfdir}/shells
26}
diff --git a/meta/packages/bash/bash_3.2.bb b/meta/packages/bash/bash_3.2.bb
index e3d6b0560c..8e0293e001 100644
--- a/meta/packages/bash/bash_3.2.bb
+++ b/meta/packages/bash/bash_3.2.bb
@@ -1,28 +1,5 @@
1DESCRIPTION = "An sh-compatible command language interpreter." 1require bash.inc
2HOMEPAGE = "http://cnswww.cns.cwru.edu/~chet/bash/bashtop.html" 2PR = "r1"
3DEPENDS = "ncurses"
4SECTION = "base/shell"
5LICENSE = "GPL"
6 3
7SRC_URI = "${GNU_MIRROR}/bash/bash-${PV}.tar.gz \ 4SRC_URI = "${GNU_MIRROR}/bash/bash-${PV}.tar.gz \
8 file://001-005.patch;patch=1" 5 file://001-005.patch;patch=1"
9
10inherit autotools gettext
11
12PARALLEL_MAKE = ""
13
14bindir = "/bin"
15sbindir = "/sbin"
16
17EXTRA_OECONF = "--with-ncurses"
18export CC_FOR_BUILD = "${BUILD_CC}"
19
20do_configure () {
21 gnu-configize
22 oe_runconf
23}
24
25pkg_postinst () {
26 grep -q "bin/bash" ${sysconfdir}/shells || echo /bin/bash >> ${sysconfdir}/shells
27 grep -q "bin/sh" ${sysconfdir}/shells || echo /bin/sh >> ${sysconfdir}/shells
28}