summaryrefslogtreecommitdiffstats
path: root/meta/packages/apt
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2007-04-27 14:22:14 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2007-04-27 14:22:14 +0000
commit4ae5c572802c02d3fed8e80e8599655cd9cc601e (patch)
tree26e1caaa53f983c966e8046f893bce0205a454ee /meta/packages/apt
parent16737be21fd96d63e8f9bc121536480355de487f (diff)
downloadpoky-4ae5c572802c02d3fed8e80e8599655cd9cc601e.tar.gz
apt: unbreak 0.6.46.2 build (based on OE)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1574 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/apt')
-rw-r--r--meta/packages/apt/apt-0.6.46.2/autofoo.patch84
-rw-r--r--meta/packages/apt/apt-0.6.46.2/noconfigure.patch35
-rw-r--r--meta/packages/apt/apt.inc16
-rw-r--r--meta/packages/apt/apt_0.6.46.2.bb4
-rw-r--r--meta/packages/apt/files/environment.patch13
5 files changed, 29 insertions, 123 deletions
diff --git a/meta/packages/apt/apt-0.6.46.2/autofoo.patch b/meta/packages/apt/apt-0.6.46.2/autofoo.patch
deleted file mode 100644
index 74d787cefd..0000000000
--- a/meta/packages/apt/apt-0.6.46.2/autofoo.patch
+++ /dev/null
@@ -1,84 +0,0 @@
1
2#
3# Patch managed by http://www.holgerschurig.de/patcher.html
4#
5
6---
7 configure.in | 20 ++++++++++----------
8 1 file changed, 10 insertions(+), 10 deletions(-)
9
10--- apt-0.6.45exp2.orig/configure.in
11+++ apt-0.6.45exp2/configure.in
12@@ -18,9 +18,9 @@ AC_CONFIG_AUX_DIR(buildlib)
13 AC_CONFIG_HEADER(include/config.h:buildlib/config.h.in include/apti18n.h:buildlib/apti18n.h.in)
14
15 dnl -- SET THIS TO THE RELEASE VERSION --
16-AC_DEFINE_UNQUOTED(VERSION,"0.6.45exp2")
17+AC_DEFINE_UNQUOTED(VERSION,"0.6.45exp2",[package version])
18 PACKAGE="apt"
19-AC_DEFINE_UNQUOTED(PACKAGE,"$PACKAGE")
20+AC_DEFINE_UNQUOTED(PACKAGE,"$PACKAGE",[package name])
21 AC_SUBST(PACKAGE)
22
23 dnl Check the archs, we want the target type.
24@@ -47,7 +47,7 @@ AC_SUBST(SOCKETLIBS)
25 LIBS="$SAVE_LIBS"
26
27 dnl Checks for pthread -- disabled due to glibc bugs jgg
28-dnl AC_CHECK_LIB(pthread, pthread_create,[AC_DEFINE(HAVE_PTHREAD) PTHREADLIB="-lpthread"])
29+dnl AC_CHECK_LIB(pthread, pthread_create,[AC_DEFINE(HAVE_PTHREAD, 1, [define if we have pthreads]) PTHREADLIB="-lpthread"])
30 AC_SUBST(PTHREADLIB)
31 dnl if test "$PTHREADLIB" != "-lpthread"; then
32 dnl AC_MSG_ERROR(failed: I need posix threads, pthread)
33@@ -84,14 +84,14 @@ if test "x$archset" = "x"; then
34 AC_MSG_ERROR(failed: use --host= or check buildlib/archtable)
35 fi
36 AC_MSG_RESULT($archset)
37-AC_DEFINE_UNQUOTED(COMMON_CPU,"$archset")
38+AC_DEFINE_UNQUOTED(COMMON_CPU,"$archset",[define to the system architecture])
39
40 dnl Get a common name for the host OS - this is primarily only for HURD and is
41 dnl non fatal if it fails
42 AC_MSG_CHECKING(system OS)
43 osset="`awk \" ! /^#|^\\\$/ {if (match(\\\"$target_vendor-$target_os\\\",\\\$1)) {print \\\$2; exit}}\" $srcdir/buildlib/ostable`"
44 AC_MSG_RESULT($osset)
45-AC_DEFINE_UNQUOTED(COMMON_OS,"$osset")
46+AC_DEFINE_UNQUOTED(COMMON_OS,"$osset",[define to the system OS])
47
48 dnl We use C99 types if at all possible
49 AC_CACHE_CHECK([for C99 integer types],c9x_ints,[
50@@ -105,13 +105,13 @@ AC_SUBST(HAVE_STATVFS)
51
52 dnl Arg, linux and bsd put their statfs function in different places
53 if test x"$HAVE_STATVFS" != x"yes"; then
54- AC_EGREP_HEADER(statfs,sys/vfs.h,[AC_DEFINE(HAVE_VFS_H)],[
55- AC_EGREP_HEADER(statfs,sys/mount.h,[AC_DEFINE(HAVE_MOUNT_H)],[AC_MSG_ERROR(failed: Need statvfs)])
56+ AC_EGREP_HEADER(statfs,sys/vfs.h,[AC_DEFINE(HAVE_VFS_H, 1, [define if statfs is in sys/vfs.h])],[
57+ AC_EGREP_HEADER(statfs,sys/mount.h,[AC_DEFINE(HAVE_MOUNT_H, 1, [define if statfs is in sys/mount.h])],[AC_MSG_ERROR(failed: Need statvfs)])
58 ])
59 fi
60
61 dnl We should use the real timegm function if we have it.
62-AC_CHECK_FUNC(timegm,AC_DEFINE(HAVE_TIMEGM))
63+AC_CHECK_FUNC(timegm,AC_DEFINE(HAVE_TIMEGM, 1, [define if we have timegm]))
64 AC_SUBST(HAVE_TIMEGM)
65
66 dnl Check the sizes etc. of the architecture
67@@ -157,7 +157,7 @@ fi
68 dnl HP-UX sux..
69 AC_MSG_CHECKING(for missing socklen_t)
70 AC_EGREP_HEADER(socklen_t, sys/socket.h,[AC_MSG_RESULT(no)],[
71- AC_DEFINE(NEED_SOCKLEN_T_DEFINE)
72+ AC_DEFINE(NEED_SOCKLEN_T_DEFINE, 1, [define if we need to define socklen_t])
73 NEED_SOCKLEN_T_DEFINE=yes
74 AC_MSG_RESULT(missing.)])
75 AC_SUBST(NEED_SOCKLEN_T_DEFINE)
76@@ -204,7 +204,7 @@ dnl gettext approved makefiles, so this
77 ALL_LINGUAS="bg bs ca cs cy da de dz el en_GB es eu fi fr gl hu it ja ko nb nl nn pl pt_BR pt ro ru sk sl sv tl vi zn_CN zh_TW"
78 AM_GNU_GETTEXT(external)
79 if test x"$USE_NLS" = "xyes"; then
80- AC_DEFINE(USE_NLS)
81+ AC_DEFINE(USE_NLS, 1, [define if we have native language support])
82 fi
83 AC_SUBST(USE_NLS)
84 AC_PATH_PROG(BASH, bash)
diff --git a/meta/packages/apt/apt-0.6.46.2/noconfigure.patch b/meta/packages/apt/apt-0.6.46.2/noconfigure.patch
deleted file mode 100644
index 682a96da24..0000000000
--- a/meta/packages/apt/apt-0.6.46.2/noconfigure.patch
+++ /dev/null
@@ -1,35 +0,0 @@
1---
2 apt-pkg/packagemanager.cc | 4 ++++
3 1 file changed, 4 insertions(+)
4
5--- apt-0.6.45exp2.orig/apt-pkg/packagemanager.cc
6+++ apt-0.6.45exp2/apt-pkg/packagemanager.cc
7@@ -534,10 +534,12 @@ bool pkgPackageManager::SmartUnPack(PkgI
8
9 List->Flag(Pkg,pkgOrderList::UnPacked,pkgOrderList::States);
10
11+#if 0
12 // Perform immedate configuration of the package.
13 if (List->IsFlag(Pkg,pkgOrderList::Immediate) == true)
14 if (SmartConfigure(Pkg) == false)
15 return _error->Error("Internal Error, Could not perform immediate configuration (2) on %s",Pkg.Name());
16+#endif
17
18 return true;
19 }
20@@ -609,6 +611,7 @@ pkgPackageManager::OrderResult pkgPackag
21 DoneSomething = true;
22 }
23
24+#if 0
25 // Final run through the configure phase
26 if (ConfigureAll() == false)
27 return Failed;
28@@ -623,6 +626,7 @@ pkgPackageManager::OrderResult pkgPackag
29 return Failed;
30 }
31 }
32+#endif
33
34 return Completed;
35 }
diff --git a/meta/packages/apt/apt.inc b/meta/packages/apt/apt.inc
index 0cd23c029d..972828c6d9 100644
--- a/meta/packages/apt/apt.inc
+++ b/meta/packages/apt/apt.inc
@@ -1,11 +1,23 @@
1DESCRIPTION = "Advanced front-end for dpkg." 1DESCRIPTION = "Advanced front-end for dpkg."
2LICENSE = "GPL" 2LICENSE = "GPL"
3SECTION = "base" 3SECTION = "base"
4PR = "r1"
5 4
6SRC_URI = "${DEBIAN_MIRROR}/main/a/apt/apt_${PV}.tar.gz" 5SRC_URI = "${DEBIAN_MIRROR}/main/a/apt/apt_${PV}.tar.gz \
6 file://environment.patch;patch=1"
7S = "${WORKDIR}/apt-${PV}" 7S = "${WORKDIR}/apt-${PV}"
8 8
9inherit autotools gettext 9inherit autotools gettext
10 10
11EXTRA_AUTORECONF = "--exclude=autopoint,autoheader" 11EXTRA_AUTORECONF = "--exclude=autopoint,autoheader"
12
13# Apt wants to know the glibc version by running a binary file, which will
14# fail, so we have to tell configure which version to use Since I don't know
15# the impliations of setting a wrong value I only provide one for angstrom,
16# which uses glibc 2.5 (which claims to be 2.4)
17# Koen - 20070327
18EXTRA_OECONF_append_angstrom = " ac_cv_glibc_ver=libc6.4"
19
20# under Debian it is set to libc6.3 as they use glibc 2.3
21# They also provide glibc 2.5 in 'experimental' and it works with APT built
22# for 2.3 so we set it in same way
23EXTRA_OECONF_append = " ac_cv_glibc_ver=libc6.3"
diff --git a/meta/packages/apt/apt_0.6.46.2.bb b/meta/packages/apt/apt_0.6.46.2.bb
index 1cd8eb270e..2a7f963d2f 100644
--- a/meta/packages/apt/apt_0.6.46.2.bb
+++ b/meta/packages/apt/apt_0.6.46.2.bb
@@ -1,7 +1,7 @@
1require apt.inc 1require apt.inc
2PR = "r2"
2 3
3SRC_URI += "file://autofoo.patch;patch=1 \ 4SRC_URI += "file://nodoc.patch;patch=1"
4 file://nodoc.patch;patch=1"
5 5
6require apt-package.inc 6require apt-package.inc
7 7
diff --git a/meta/packages/apt/files/environment.patch b/meta/packages/apt/files/environment.patch
new file mode 100644
index 0000000000..5bea1a0130
--- /dev/null
+++ b/meta/packages/apt/files/environment.patch
@@ -0,0 +1,13 @@
1Index: apt-0.6.46.2/buildlib/environment.mak.in
2===================================================================
3--- apt-0.6.46.2.orig/buildlib/environment.mak.in 2007-03-29 11:38:58.000000000 +0100
4+++ apt-0.6.46.2/buildlib/environment.mak.in 2007-03-29 11:39:12.000000000 +0100
5@@ -62,7 +62,7 @@
6
7 # Shared library things
8 HOST_OS = @host_os@
9-ifneq ($(words $(filter linux-gnu gnu% %gnu,$(HOST_OS))),0)
10+ifneq ($(words $(filter linux-gnu linux-gnueabi gnu% %gnu,$(HOST_OS))),0)
11 SONAME_MAGIC=-Wl,-soname -Wl,
12 LFLAGS_SO=
13 else