summaryrefslogtreecommitdiffstats
path: root/meta/packages/apr
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-01-12 17:34:52 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2009-01-12 17:34:52 +0000
commitf51973f5afb4775252bdf26827ba44663e1dda2d (patch)
tree9f8754f9259a0ffbdc3994f44259d36eaaf917be /meta/packages/apr
parenta43863b7f126b4e4e9eae64c11b657ef9530e50a (diff)
downloadpoky-f51973f5afb4775252bdf26827ba44663e1dda2d.tar.gz
apr/apr-util: Fix some other config path gremlins breaking builds
Diffstat (limited to 'meta/packages/apr')
-rw-r--r--meta/packages/apr/apr-util/configfix.patch49
-rw-r--r--meta/packages/apr/apr-util_1.3.4.bb3
-rw-r--r--meta/packages/apr/apr/configfix.patch2
-rw-r--r--meta/packages/apr/apr_1.3.3.bb2
4 files changed, 53 insertions, 3 deletions
diff --git a/meta/packages/apr/apr-util/configfix.patch b/meta/packages/apr/apr-util/configfix.patch
new file mode 100644
index 0000000000..a8953e5244
--- /dev/null
+++ b/meta/packages/apr/apr-util/configfix.patch
@@ -0,0 +1,49 @@
1Index: apr-util-1.3.4/apu-config.in
2===================================================================
3--- apr-util-1.3.4.orig/apu-config.in 2009-01-12 17:08:06.000000000 +0000
4+++ apr-util-1.3.4/apu-config.in 2009-01-12 17:09:00.000000000 +0000
5@@ -134,14 +134,7 @@
6 exit 0
7 ;;
8 --includes)
9- if test "$location" = "installed"; then
10 flags="$flags -I$includedir $INCLUDES"
11- elif test "$location" = "source"; then
12- flags="$flags -I$APU_SOURCE_DIR/include $INCLUDES"
13- else
14- # this is for VPATH builds
15- flags="$flags -I$APU_BUILD_DIR/include -I$APU_SOURCE_DIR/include $INCLUDES"
16- fi
17 ;;
18 --ldflags)
19 flags="$flags $LDFLAGS"
20@@ -155,28 +148,10 @@
21 exit 0
22 ;;
23 --link-ld)
24- if test "$location" = "installed"; then
25- ### avoid using -L if libdir is a "standard" location like /usr/lib
26 flags="$flags -L$libdir -l$APRUTIL_LIBNAME"
27- else
28- flags="$flags -L$APU_BUILD_DIR -l$APRUTIL_LIBNAME"
29- fi
30 ;;
31 --link-libtool)
32- # If the LA_FILE exists where we think it should be, use it. If we're
33- # installed and the LA_FILE does not exist, assume to use -L/-l
34- # (the LA_FILE may not have been installed). If we're building ourselves,
35- # we'll assume that at some point the .la file be created.
36- if test -f "$LA_FILE"; then
37- flags="$flags $LA_FILE"
38- elif test "$location" = "installed"; then
39- ### avoid using -L if libdir is a "standard" location like /usr/lib
40- # Since the user is specifying they are linking with libtool, we
41- # *know* that -R will be recognized by libtool.
42- flags="$flags -L$libdir -R$libdir -l$APRUTIL_LIBNAME"
43- else
44- flags="$flags $LA_FILE"
45- fi
46+ flags="$flags -l$APRUTIL_LIBNAME"
47 ;;
48 --apu-la-file)
49 if test -f "$LA_FILE"; then
diff --git a/meta/packages/apr/apr-util_1.3.4.bb b/meta/packages/apr/apr-util_1.3.4.bb
index 2c9432a157..f2d5470977 100644
--- a/meta/packages/apr/apr-util_1.3.4.bb
+++ b/meta/packages/apr/apr-util_1.3.4.bb
@@ -3,9 +3,10 @@ SECTION = "libs"
3DEPENDS = "apr expat gdbm" 3DEPENDS = "apr expat gdbm"
4LICENSE = "Apache License, Version 2.0" 4LICENSE = "Apache License, Version 2.0"
5 5
6PR = "r3" 6PR = "r5"
7 7
8SRC_URI = "${APACHE_MIRROR}/apr/${P}.tar.gz \ 8SRC_URI = "${APACHE_MIRROR}/apr/${P}.tar.gz \
9 file://configfix.patch;patch=1 \
9 file://configure_fixes.patch;patch=1" 10 file://configure_fixes.patch;patch=1"
10 11
11EXTRA_OECONF = "--with-apr=${STAGING_BINDIR_CROSS}/apr-1-config \ 12EXTRA_OECONF = "--with-apr=${STAGING_BINDIR_CROSS}/apr-1-config \
diff --git a/meta/packages/apr/apr/configfix.patch b/meta/packages/apr/apr/configfix.patch
index ec46172c6d..995555e8ba 100644
--- a/meta/packages/apr/apr/configfix.patch
+++ b/meta/packages/apr/apr/configfix.patch
@@ -45,7 +45,7 @@ Index: apr-1.3.3/apr-config.in
45- else 45- else
46- flags="$flags $LA_FILE" 46- flags="$flags $LA_FILE"
47- fi 47- fi
48+ flags="$flags ll${APR_LIBNAME}" 48+ flags="$flags -l${APR_LIBNAME}"
49 ;; 49 ;;
50 --shlib-path-var) 50 --shlib-path-var)
51 echo "$SHLIBPATH_VAR" 51 echo "$SHLIBPATH_VAR"
diff --git a/meta/packages/apr/apr_1.3.3.bb b/meta/packages/apr/apr_1.3.3.bb
index ac25246bee..4b4ce1118d 100644
--- a/meta/packages/apr/apr_1.3.3.bb
+++ b/meta/packages/apr/apr_1.3.3.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Apache Portable Runtime (APR) library"
2SECTION = "libs" 2SECTION = "libs"
3LICENSE = "Apache License, Version 2.0" 3LICENSE = "Apache License, Version 2.0"
4 4
5PR = "r2" 5PR = "r3"
6 6
7SRC_URI = "${APACHE_MIRROR}/apr/${P}.tar.bz2 \ 7SRC_URI = "${APACHE_MIRROR}/apr/${P}.tar.bz2 \
8 file://configure_fixes.patch;patch=1 \ 8 file://configure_fixes.patch;patch=1 \