diff options
author | Richard Purdie <rpurdie@linux.intel.com> | 2010-09-01 19:09:11 +0100 |
---|---|---|
committer | Richard Purdie <rpurdie@linux.intel.com> | 2010-09-01 19:09:57 +0100 |
commit | d62ee7eaf2ba025c3f64b2d4e10dc7cec4637612 (patch) | |
tree | f36fe3008f36ff75cbdd31b630f8f13f1f205ebb /meta/packages/apr | |
parent | caab7fc509bf27706ff3248689f6afd04225cfda (diff) | |
download | poky-d62ee7eaf2ba025c3f64b2d4e10dc7cec4637612.tar.gz |
packages: Separate out most of the remaining packages into recipes
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/apr')
-rw-r--r-- | meta/packages/apr/apr-util/configfix.patch | 49 | ||||
-rw-r--r-- | meta/packages/apr/apr-util/configure_fixes.patch | 27 | ||||
-rw-r--r-- | meta/packages/apr/apr-util/configure_fixes.patch.old | 25 | ||||
-rw-r--r-- | meta/packages/apr/apr-util_1.3.4.bb | 27 | ||||
-rw-r--r-- | meta/packages/apr/apr/cleanup.patch | 42 | ||||
-rw-r--r-- | meta/packages/apr/apr/configfix.patch | 51 | ||||
-rw-r--r-- | meta/packages/apr/apr/configure_fixes.patch | 66 | ||||
-rw-r--r-- | meta/packages/apr/apr_1.3.3.bb | 34 |
8 files changed, 0 insertions, 321 deletions
diff --git a/meta/packages/apr/apr-util/configfix.patch b/meta/packages/apr/apr-util/configfix.patch deleted file mode 100644 index a8953e5244..0000000000 --- a/meta/packages/apr/apr-util/configfix.patch +++ /dev/null | |||
@@ -1,49 +0,0 @@ | |||
1 | Index: apr-util-1.3.4/apu-config.in | ||
2 | =================================================================== | ||
3 | --- apr-util-1.3.4.orig/apu-config.in 2009-01-12 17:08:06.000000000 +0000 | ||
4 | +++ apr-util-1.3.4/apu-config.in 2009-01-12 17:09:00.000000000 +0000 | ||
5 | @@ -134,14 +134,7 @@ | ||
6 | exit 0 | ||
7 | ;; | ||
8 | --includes) | ||
9 | - if test "$location" = "installed"; then | ||
10 | flags="$flags -I$includedir $INCLUDES" | ||
11 | - elif test "$location" = "source"; then | ||
12 | - flags="$flags -I$APU_SOURCE_DIR/include $INCLUDES" | ||
13 | - else | ||
14 | - # this is for VPATH builds | ||
15 | - flags="$flags -I$APU_BUILD_DIR/include -I$APU_SOURCE_DIR/include $INCLUDES" | ||
16 | - fi | ||
17 | ;; | ||
18 | --ldflags) | ||
19 | flags="$flags $LDFLAGS" | ||
20 | @@ -155,28 +148,10 @@ | ||
21 | exit 0 | ||
22 | ;; | ||
23 | --link-ld) | ||
24 | - if test "$location" = "installed"; then | ||
25 | - ### avoid using -L if libdir is a "standard" location like /usr/lib | ||
26 | flags="$flags -L$libdir -l$APRUTIL_LIBNAME" | ||
27 | - else | ||
28 | - flags="$flags -L$APU_BUILD_DIR -l$APRUTIL_LIBNAME" | ||
29 | - fi | ||
30 | ;; | ||
31 | --link-libtool) | ||
32 | - # If the LA_FILE exists where we think it should be, use it. If we're | ||
33 | - # installed and the LA_FILE does not exist, assume to use -L/-l | ||
34 | - # (the LA_FILE may not have been installed). If we're building ourselves, | ||
35 | - # we'll assume that at some point the .la file be created. | ||
36 | - if test -f "$LA_FILE"; then | ||
37 | - flags="$flags $LA_FILE" | ||
38 | - elif test "$location" = "installed"; then | ||
39 | - ### avoid using -L if libdir is a "standard" location like /usr/lib | ||
40 | - # Since the user is specifying they are linking with libtool, we | ||
41 | - # *know* that -R will be recognized by libtool. | ||
42 | - flags="$flags -L$libdir -R$libdir -l$APRUTIL_LIBNAME" | ||
43 | - else | ||
44 | - flags="$flags $LA_FILE" | ||
45 | - fi | ||
46 | + flags="$flags -l$APRUTIL_LIBNAME" | ||
47 | ;; | ||
48 | --apu-la-file) | ||
49 | if test -f "$LA_FILE"; then | ||
diff --git a/meta/packages/apr/apr-util/configure_fixes.patch b/meta/packages/apr/apr-util/configure_fixes.patch deleted file mode 100644 index 0b2a0903e1..0000000000 --- a/meta/packages/apr/apr-util/configure_fixes.patch +++ /dev/null | |||
@@ -1,27 +0,0 @@ | |||
1 | Index: apr-util-1.3.4/configure.in | ||
2 | =================================================================== | ||
3 | --- apr-util-1.3.4.orig/configure.in | ||
4 | +++ apr-util-1.3.4/configure.in | ||
5 | @@ -8,14 +8,14 @@ AC_INIT(export_vars.sh.in) | ||
6 | AC_CONFIG_HEADER(include/private/apu_config.h) | ||
7 | AC_CONFIG_AUX_DIR(build) | ||
8 | |||
9 | -sinclude(build/apu-conf.m4) | ||
10 | -sinclude(build/apu-iconv.m4) | ||
11 | -sinclude(build/apu-hints.m4) | ||
12 | -sinclude(build/apr_common.m4) | ||
13 | -sinclude(build/find_apr.m4) | ||
14 | -sinclude(build/dbm.m4) | ||
15 | -sinclude(build/dbd.m4) | ||
16 | -sinclude(build/dso.m4) | ||
17 | +#sinclude(build/apu-conf.m4) | ||
18 | +#sinclude(build/apu-iconv.m4) | ||
19 | +#sinclude(build/apu-hints.m4) | ||
20 | +#sinclude(build/apr_common.m4) | ||
21 | +#sinclude(build/find_apr.m4) | ||
22 | +#sinclude(build/dbm.m4) | ||
23 | +#sinclude(build/dbd.m4) | ||
24 | +#sinclude(build/dso.m4) | ||
25 | |||
26 | dnl Generate ./config.nice for reproducing runs of configure | ||
27 | dnl | ||
diff --git a/meta/packages/apr/apr-util/configure_fixes.patch.old b/meta/packages/apr/apr-util/configure_fixes.patch.old deleted file mode 100644 index 16f88b3bba..0000000000 --- a/meta/packages/apr/apr-util/configure_fixes.patch.old +++ /dev/null | |||
@@ -1,25 +0,0 @@ | |||
1 | Index: apr-util-1.2.12/configure.in | ||
2 | =================================================================== | ||
3 | --- apr-util-1.2.12.orig/configure.in 2008-03-08 19:15:00.000000000 +0000 | ||
4 | +++ apr-util-1.2.12/configure.in 2008-03-08 19:15:13.000000000 +0000 | ||
5 | @@ -8,13 +8,13 @@ | ||
6 | AC_CONFIG_HEADER(include/private/apu_config.h) | ||
7 | AC_CONFIG_AUX_DIR(build) | ||
8 | |||
9 | -sinclude(build/apu-conf.m4) | ||
10 | -sinclude(build/apu-iconv.m4) | ||
11 | -sinclude(build/apu-hints.m4) | ||
12 | -sinclude(build/apr_common.m4) | ||
13 | -sinclude(build/find_apr.m4) | ||
14 | -sinclude(build/dbm.m4) | ||
15 | -sinclude(build/dbd.m4) | ||
16 | +#sinclude(build/apu-conf.m4) | ||
17 | +#sinclude(build/apu-iconv.m4) | ||
18 | +#sinclude(build/apu-hints.m4) | ||
19 | +#sinclude(build/apr_common.m4) | ||
20 | +#sinclude(build/find_apr.m4) | ||
21 | +#sinclude(build/dbm.m4) | ||
22 | +#sinclude(build/dbd.m4) | ||
23 | |||
24 | dnl Generate ./config.nice for reproducing runs of configure | ||
25 | dnl | ||
diff --git a/meta/packages/apr/apr-util_1.3.4.bb b/meta/packages/apr/apr-util_1.3.4.bb deleted file mode 100644 index 2e608e8a5c..0000000000 --- a/meta/packages/apr/apr-util_1.3.4.bb +++ /dev/null | |||
@@ -1,27 +0,0 @@ | |||
1 | DESCRIPTION = "Apache Portable Runtime (APR) companion library" | ||
2 | SECTION = "libs" | ||
3 | DEPENDS = "apr expat gdbm" | ||
4 | LICENSE = "Apache License, Version 2.0" | ||
5 | |||
6 | PR = "r5" | ||
7 | |||
8 | SRC_URI = "${APACHE_MIRROR}/apr/${P}.tar.gz \ | ||
9 | file://configfix.patch;patch=1 \ | ||
10 | file://configure_fixes.patch;patch=1" | ||
11 | |||
12 | EXTRA_OECONF = "--with-apr=${STAGING_BINDIR_CROSS}/apr-1-config \ | ||
13 | --with-dbm=gdbm \ | ||
14 | --with-gdbm=${STAGING_DIR_HOST}${prefix} \ | ||
15 | --without-sqlite2 \ | ||
16 | --without-sqlite3 \ | ||
17 | --with-expat=${STAGING_DIR_HOST}${prefix}" | ||
18 | |||
19 | |||
20 | inherit autotools lib_package binconfig | ||
21 | |||
22 | OE_BINCONFIG_EXTRA_MANGLE = " -e 's:location=source:location=installed:'" | ||
23 | |||
24 | do_configure_prepend() { | ||
25 | cp ${STAGING_DATADIR}/apr/apr_rules.mk ${S}/build/rules.mk | ||
26 | } | ||
27 | |||
diff --git a/meta/packages/apr/apr/cleanup.patch b/meta/packages/apr/apr/cleanup.patch deleted file mode 100644 index fd74826480..0000000000 --- a/meta/packages/apr/apr/cleanup.patch +++ /dev/null | |||
@@ -1,42 +0,0 @@ | |||
1 | Index: apr-1.3.3/build/buildcheck.sh | ||
2 | =================================================================== | ||
3 | --- apr-1.3.3.orig/build/buildcheck.sh 2009-01-15 13:32:33.000000000 +0000 | ||
4 | +++ apr-1.3.3/build/buildcheck.sh 2009-01-15 13:33:06.000000000 +0000 | ||
5 | @@ -32,35 +32,4 @@ | ||
6 | echo "buildconf: autoconf version $ac_version (ok)" | ||
7 | fi | ||
8 | |||
9 | -# Sample libtool --version outputs: | ||
10 | -# ltmain.sh (GNU libtool) 1.3.3 (1.385.2.181 1999/07/02 15:49:11) | ||
11 | -# ltmain.sh (GNU libtool 1.1361 2004/01/02 23:10:52) 1.5a | ||
12 | -# output is multiline from 1.5 onwards | ||
13 | - | ||
14 | -# Require libtool 1.4 or newer | ||
15 | -libtool=`build/PrintPath glibtool libtool libtool15 libtool14` | ||
16 | -lt_pversion=`$libtool --version 2>/dev/null|sed -e 's/([^)]*)//g;s/^[^0-9]*//;s/[- ].*//g;q'` | ||
17 | -if test -z "$lt_pversion"; then | ||
18 | -echo "buildconf: libtool not found." | ||
19 | -echo " You need libtool version 1.4 or newer installed" | ||
20 | -echo " to build APR from SVN." | ||
21 | -exit 1 | ||
22 | -fi | ||
23 | -lt_version=`echo $lt_pversion|sed -e 's/\([a-z]*\)$/.\1/'` | ||
24 | -IFS=.; set $lt_version; IFS=' ' | ||
25 | -lt_status="good" | ||
26 | -if test "$1" = "1"; then | ||
27 | - if test "$2" -lt "4"; then | ||
28 | - lt_status="bad" | ||
29 | - fi | ||
30 | -fi | ||
31 | -if test $lt_status = "good"; then | ||
32 | - echo "buildconf: libtool version $lt_pversion (ok)" | ||
33 | - exit 0 | ||
34 | -fi | ||
35 | - | ||
36 | -echo "buildconf: libtool version $lt_pversion found." | ||
37 | -echo " You need libtool version 1.4 or newer installed" | ||
38 | -echo " to build APR from SVN." | ||
39 | - | ||
40 | -exit 1 | ||
41 | +exit 0 | ||
42 | \ No newline at end of file | ||
diff --git a/meta/packages/apr/apr/configfix.patch b/meta/packages/apr/apr/configfix.patch deleted file mode 100644 index 995555e8ba..0000000000 --- a/meta/packages/apr/apr/configfix.patch +++ /dev/null | |||
@@ -1,51 +0,0 @@ | |||
1 | Index: apr-1.3.3/apr-config.in | ||
2 | =================================================================== | ||
3 | --- apr-1.3.3.orig/apr-config.in 2009-01-12 15:16:31.000000000 +0000 | ||
4 | +++ apr-1.3.3/apr-config.in 2009-01-12 15:19:25.000000000 +0000 | ||
5 | @@ -152,14 +152,7 @@ | ||
6 | flags="$flags $LDFLAGS" | ||
7 | ;; | ||
8 | --includes) | ||
9 | - if test "$location" = "installed"; then | ||
10 | flags="$flags -I$includedir $EXTRA_INCLUDES" | ||
11 | - elif test "$location" = "source"; then | ||
12 | - flags="$flags -I$APR_SOURCE_DIR/include $EXTRA_INCLUDES" | ||
13 | - else | ||
14 | - # this is for VPATH builds | ||
15 | - flags="$flags -I$APR_BUILD_DIR/include -I$APR_SOURCE_DIR/include $EXTRA_INCLUDES" | ||
16 | - fi | ||
17 | ;; | ||
18 | --srcdir) | ||
19 | echo $APR_SOURCE_DIR | ||
20 | @@ -181,29 +167,14 @@ | ||
21 | exit 0 | ||
22 | ;; | ||
23 | --link-ld) | ||
24 | - if test "$location" = "installed"; then | ||
25 | - ### avoid using -L if libdir is a "standard" location like /usr/lib | ||
26 | - flags="$flags -L$libdir -l${APR_LIBNAME}" | ||
27 | - else | ||
28 | - ### this surely can't work since the library is in .libs? | ||
29 | - flags="$flags -L$APR_BUILD_DIR -l${APR_LIBNAME}" | ||
30 | - fi | ||
31 | + flags="$flags -l${APR_LIBNAME}" | ||
32 | ;; | ||
33 | --link-libtool) | ||
34 | # If the LA_FILE exists where we think it should be, use it. If we're | ||
35 | # installed and the LA_FILE does not exist, assume to use -L/-l | ||
36 | # (the LA_FILE may not have been installed). If we're building ourselves, | ||
37 | # we'll assume that at some point the .la file be created. | ||
38 | - if test -f "$LA_FILE"; then | ||
39 | - flags="$flags $LA_FILE" | ||
40 | - elif test "$location" = "installed"; then | ||
41 | - ### avoid using -L if libdir is a "standard" location like /usr/lib | ||
42 | - # Since the user is specifying they are linking with libtool, we | ||
43 | - # *know* that -R will be recognized by libtool. | ||
44 | - flags="$flags -L$libdir -R$libdir -l${APR_LIBNAME}" | ||
45 | - else | ||
46 | - flags="$flags $LA_FILE" | ||
47 | - fi | ||
48 | + flags="$flags -l${APR_LIBNAME}" | ||
49 | ;; | ||
50 | --shlib-path-var) | ||
51 | echo "$SHLIBPATH_VAR" | ||
diff --git a/meta/packages/apr/apr/configure_fixes.patch b/meta/packages/apr/apr/configure_fixes.patch deleted file mode 100644 index 86ceb8cf08..0000000000 --- a/meta/packages/apr/apr/configure_fixes.patch +++ /dev/null | |||
@@ -1,66 +0,0 @@ | |||
1 | Index: apr-1.3.3/configure.in | ||
2 | =================================================================== | ||
3 | --- apr-1.3.3.orig/configure.in | ||
4 | +++ apr-1.3.3/configure.in | ||
5 | @@ -794,39 +794,6 @@ AC_CHECK_FUNCS([mmap munmap shm_open shm | ||
6 | create_area]) | ||
7 | |||
8 | APR_CHECK_DEFINE(MAP_ANON, sys/mman.h) | ||
9 | -AC_CHECK_FILE(/dev/zero) | ||
10 | - | ||
11 | -# Not all systems can mmap /dev/zero (such as HP-UX). Check for that. | ||
12 | -if test "$ac_cv_func_mmap" = "yes" && | ||
13 | - test "$ac_cv_file__dev_zero" = "yes"; then | ||
14 | - AC_MSG_CHECKING(for mmap that can map /dev/zero) | ||
15 | - AC_TRY_RUN([ | ||
16 | -#include <sys/types.h> | ||
17 | -#include <sys/stat.h> | ||
18 | -#include <fcntl.h> | ||
19 | -#ifdef HAVE_SYS_MMAN_H | ||
20 | -#include <sys/mman.h> | ||
21 | -#endif | ||
22 | - int main() | ||
23 | - { | ||
24 | - int fd; | ||
25 | - void *m; | ||
26 | - fd = open("/dev/zero", O_RDWR); | ||
27 | - if (fd < 0) { | ||
28 | - return 1; | ||
29 | - } | ||
30 | - m = mmap(0, sizeof(void*), PROT_READ|PROT_WRITE, MAP_SHARED, fd, 0); | ||
31 | - if (m == (void *)-1) { /* aka MAP_FAILED */ | ||
32 | - return 2; | ||
33 | - } | ||
34 | - if (munmap(m, sizeof(void*)) < 0) { | ||
35 | - return 3; | ||
36 | - } | ||
37 | - return 0; | ||
38 | - }], [], [ac_cv_file__dev_zero=no], [ac_cv_file__dev_zero=no]) | ||
39 | - | ||
40 | - AC_MSG_RESULT($ac_cv_file__dev_zero) | ||
41 | -fi | ||
42 | |||
43 | # Now we determine which one is our anonymous shmem preference. | ||
44 | haveshmgetanon="0" | ||
45 | @@ -1518,13 +1485,14 @@ else | ||
46 | bigendian=0 | ||
47 | fi | ||
48 | |||
49 | -APR_CHECK_SIZEOF_EXTENDED([#include <sys/types.h> | ||
50 | -#include <sys/uio.h>],struct iovec,0) | ||
51 | -if test "$ac_cv_sizeof_struct_iovec" = "0"; then | ||
52 | - have_iovec=0 | ||
53 | -else | ||
54 | - have_iovec=1 | ||
55 | -fi | ||
56 | +#APR_CHECK_SIZEOF_EXTENDED([#include <sys/types.h> | ||
57 | +##include <sys/uio.h>],struct iovec,0) | ||
58 | +#if test "$ac_cv_sizeof_struct_iovec" = "0"; then | ||
59 | +# have_iovec=0 | ||
60 | +#else | ||
61 | +# have_iovec=1 | ||
62 | +#fi | ||
63 | +have_iovec=1 | ||
64 | |||
65 | AC_SUBST(voidp_size) | ||
66 | AC_SUBST(short_value) | ||
diff --git a/meta/packages/apr/apr_1.3.3.bb b/meta/packages/apr/apr_1.3.3.bb deleted file mode 100644 index a193a18a2e..0000000000 --- a/meta/packages/apr/apr_1.3.3.bb +++ /dev/null | |||
@@ -1,34 +0,0 @@ | |||
1 | DESCRIPTION = "Apache Portable Runtime (APR) library" | ||
2 | SECTION = "libs" | ||
3 | LICENSE = "Apache License, Version 2.0" | ||
4 | |||
5 | PR = "r5" | ||
6 | |||
7 | SRC_URI = "${APACHE_MIRROR}/apr/${P}.tar.bz2 \ | ||
8 | file://configure_fixes.patch;patch=1 \ | ||
9 | file://cleanup.patch;patch=1 \ | ||
10 | file://configfix.patch;patch=1" | ||
11 | |||
12 | inherit autotools lib_package binconfig | ||
13 | |||
14 | OE_BINCONFIG_EXTRA_MANGLE = " -e 's:location=source:location=installed:'" | ||
15 | |||
16 | do_configure_prepend() { | ||
17 | cd ${S} | ||
18 | ./buildconf | ||
19 | } | ||
20 | |||
21 | SYSROOT_PREPROCESS_FUNCS += "apr_sysroot_preprocess" | ||
22 | |||
23 | apr_sysroot_preprocess () { | ||
24 | d=${SYSROOT_DESTDIR}${STAGING_DIR_TARGET}${datadir}/apr | ||
25 | install -d $d/ | ||
26 | cp ${S}/build/apr_rules.mk $d/ | ||
27 | sed -i s,apr_builddir=.*,apr_builddir=,g $d/apr_rules.mk | ||
28 | sed -i s,apr_builders=.*,apr_builders=,g $d/apr_rules.mk | ||
29 | sed -i s,LIBTOOL=.*,LIBTOOL=\$\(SHELL\)\ ${TARGET_PREFIX}libtool,g $d/apr_rules.mk | ||
30 | sed -i s,\$\(apr_builders\),${STAGING_DATADIR}/apr/,g $d/apr_rules.mk | ||
31 | cp ${S}/build/mkdir.sh $d/ | ||
32 | cp ${S}/build/make_exports.awk $d/ | ||
33 | cp ${S}/build/make_var_export.awk $d/ | ||
34 | } | ||