summaryrefslogtreecommitdiffstats
path: root/meta/packages/apr
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-01-15 13:36:08 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2009-01-15 13:36:08 +0000
commit932fc6a37ddba80d6e52b55db4442df437d1cb61 (patch)
tree9ee2884c79676652070de04e392641ac1445e574 /meta/packages/apr
parent123b0991ee2f5a8ddb598b89271d6e27a29ea32b (diff)
downloadpoky-932fc6a37ddba80d6e52b55db4442df437d1cb61.tar.gz
apr: Disable checks for a system libtool, we don't need that
Diffstat (limited to 'meta/packages/apr')
-rw-r--r--meta/packages/apr/apr/cleanup.patch42
-rw-r--r--meta/packages/apr/apr_1.3.3.bb3
2 files changed, 44 insertions, 1 deletions
diff --git a/meta/packages/apr/apr/cleanup.patch b/meta/packages/apr/apr/cleanup.patch
new file mode 100644
index 0000000000..fd74826480
--- /dev/null
+++ b/meta/packages/apr/apr/cleanup.patch
@@ -0,0 +1,42 @@
1Index: apr-1.3.3/build/buildcheck.sh
2===================================================================
3--- apr-1.3.3.orig/build/buildcheck.sh 2009-01-15 13:32:33.000000000 +0000
4+++ apr-1.3.3/build/buildcheck.sh 2009-01-15 13:33:06.000000000 +0000
5@@ -32,35 +32,4 @@
6 echo "buildconf: autoconf version $ac_version (ok)"
7 fi
8
9-# Sample libtool --version outputs:
10-# ltmain.sh (GNU libtool) 1.3.3 (1.385.2.181 1999/07/02 15:49:11)
11-# ltmain.sh (GNU libtool 1.1361 2004/01/02 23:10:52) 1.5a
12-# output is multiline from 1.5 onwards
13-
14-# Require libtool 1.4 or newer
15-libtool=`build/PrintPath glibtool libtool libtool15 libtool14`
16-lt_pversion=`$libtool --version 2>/dev/null|sed -e 's/([^)]*)//g;s/^[^0-9]*//;s/[- ].*//g;q'`
17-if test -z "$lt_pversion"; then
18-echo "buildconf: libtool not found."
19-echo " You need libtool version 1.4 or newer installed"
20-echo " to build APR from SVN."
21-exit 1
22-fi
23-lt_version=`echo $lt_pversion|sed -e 's/\([a-z]*\)$/.\1/'`
24-IFS=.; set $lt_version; IFS=' '
25-lt_status="good"
26-if test "$1" = "1"; then
27- if test "$2" -lt "4"; then
28- lt_status="bad"
29- fi
30-fi
31-if test $lt_status = "good"; then
32- echo "buildconf: libtool version $lt_pversion (ok)"
33- exit 0
34-fi
35-
36-echo "buildconf: libtool version $lt_pversion found."
37-echo " You need libtool version 1.4 or newer installed"
38-echo " to build APR from SVN."
39-
40-exit 1
41+exit 0
42\ No newline at end of file
diff --git a/meta/packages/apr/apr_1.3.3.bb b/meta/packages/apr/apr_1.3.3.bb
index 4b4ce1118d..0d0fd667c0 100644
--- a/meta/packages/apr/apr_1.3.3.bb
+++ b/meta/packages/apr/apr_1.3.3.bb
@@ -2,10 +2,11 @@ DESCRIPTION = "Apache Portable Runtime (APR) library"
2SECTION = "libs" 2SECTION = "libs"
3LICENSE = "Apache License, Version 2.0" 3LICENSE = "Apache License, Version 2.0"
4 4
5PR = "r3" 5PR = "r4"
6 6
7SRC_URI = "${APACHE_MIRROR}/apr/${P}.tar.bz2 \ 7SRC_URI = "${APACHE_MIRROR}/apr/${P}.tar.bz2 \
8 file://configure_fixes.patch;patch=1 \ 8 file://configure_fixes.patch;patch=1 \
9 file://cleanup.patch;patch=1 \
9 file://configfix.patch;patch=1" 10 file://configfix.patch;patch=1"
10 11
11inherit autotools lib_package binconfig 12inherit autotools lib_package binconfig