summaryrefslogtreecommitdiffstats
path: root/meta/lib/bblayers/templates/example.bb
diff options
context:
space:
mode:
authorLeonardo Sandoval <leonardo.sandoval.gonzalez@linux.intel.com>2017-07-25 15:37:17 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-08-09 09:24:16 +0100
commit884f74250d0ccaa6ebeaf2b3d1d17179b1dcc09b (patch)
tree8cf121f34e9465f25025a8dbe15657b8349365f1 /meta/lib/bblayers/templates/example.bb
parent1df5a58b12c5f6d0e1492e20ddea81af5ec2221e (diff)
downloadpoky-884f74250d0ccaa6ebeaf2b3d1d17179b1dcc09b.tar.gz
action: new bitbake-layer plugin to create a simple layer
Though the script bitbake-layers (from the bitbake project), this plugin creates a simple layer with a example recipe, the latter with a single task (do_build). Layer's license and priority is MIT and 6, respectively. Example recipe and layer's priority can be specified through the command line. [YOCTO #11567] (From OE-Core rev: 2bd1dc287b8b0f7edac8c6fee076a70ebf7adf43) Signed-off-by: Leonardo Sandoval <leonardo.sandoval.gonzalez@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/lib/bblayers/templates/example.bb')
-rw-r--r--meta/lib/bblayers/templates/example.bb11
1 files changed, 11 insertions, 0 deletions
diff --git a/meta/lib/bblayers/templates/example.bb b/meta/lib/bblayers/templates/example.bb
new file mode 100644
index 0000000000..c4b873d593
--- /dev/null
+++ b/meta/lib/bblayers/templates/example.bb
@@ -0,0 +1,11 @@
1SUMMARY = "bitbake-layers recipe"
2DESCRIPTION = "Recipe created by bitbake-layers"
3LICENSE = "MIT"
4
5python do_build() {
6 bb.plain("***********************************************");
7 bb.plain("* *");
8 bb.plain("* Example recipe created by bitbake-layers *");
9 bb.plain("* *");
10 bb.plain("***********************************************");
11}