summaryrefslogtreecommitdiffstats
path: root/meta/classes/setuptools3.bbclass
diff options
context:
space:
mode:
authorRoss Burton <ross@burtonini.com>2022-03-08 14:30:31 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-03-09 11:46:28 +0000
commitea6c0faba3b0b00916dd74d4232eb4c92a1f0ff8 (patch)
tree696534e12099a1ee0815661fcdde40f23c0ada03 /meta/classes/setuptools3.bbclass
parent0f25ab34816428f329e4927f7d251a458735b519 (diff)
downloadpoky-ea6c0faba3b0b00916dd74d4232eb4c92a1f0ff8.tar.gz
setuptools3: respect PIP_INSTALL_DIST_PATH
pip_install_wheel expects the wheels to be in PIP_INSTALL_DIST_PATH but this class was writing to the same directory through chance not design. Respect PIP_INSTALL_DIST_PATH as the output directory. (From OE-Core rev: 12857a77ad424c3c3cbc37275374a603e528d9f1) Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/setuptools3.bbclass')
-rw-r--r--meta/classes/setuptools3.bbclass4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/classes/setuptools3.bbclass b/meta/classes/setuptools3.bbclass
index 1b1a8aac76..dcf3561b8d 100644
--- a/meta/classes/setuptools3.bbclass
+++ b/meta/classes/setuptools3.bbclass
@@ -17,11 +17,11 @@ setuptools3_do_compile() {
17 STAGING_INCDIR=${STAGING_INCDIR} \ 17 STAGING_INCDIR=${STAGING_INCDIR} \
18 STAGING_LIBDIR=${STAGING_LIBDIR} \ 18 STAGING_LIBDIR=${STAGING_LIBDIR} \
19 ${STAGING_BINDIR_NATIVE}/${PYTHON_PN}-native/${PYTHON_PN} setup.py \ 19 ${STAGING_BINDIR_NATIVE}/${PYTHON_PN}-native/${PYTHON_PN} setup.py \
20 bdist_wheel --verbose ${SETUPTOOLS_BUILD_ARGS} || \ 20 bdist_wheel --verbose --dist-dir ${PIP_INSTALL_DIST_PATH} ${SETUPTOOLS_BUILD_ARGS} || \
21 bbfatal_log "'${PYTHON_PN} setup.py bdist_wheel ${SETUPTOOLS_BUILD_ARGS}' execution failed." 21 bbfatal_log "'${PYTHON_PN} setup.py bdist_wheel ${SETUPTOOLS_BUILD_ARGS}' execution failed."
22} 22}
23setuptools3_do_compile[vardepsexclude] = "MACHINE" 23setuptools3_do_compile[vardepsexclude] = "MACHINE"
24do_compile[cleandirs] += "${SETUPTOOLS_SETUP_PATH}/dist" 24do_compile[cleandirs] += "${PIP_INSTALL_DIST_PATH}"
25 25
26setuptools3_do_install() { 26setuptools3_do_install() {
27 pip_install_wheel_do_install 27 pip_install_wheel_do_install