summaryrefslogtreecommitdiffstats
path: root/meta/classes/setuptools3.bbclass
diff options
context:
space:
mode:
authorRoss Burton <ross@burtonini.com>2022-03-11 12:03:02 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-03-13 12:23:48 +0000
commita50bf48f900b4a67d622c9833c391b049a04d2da (patch)
tree765a69f48eb7a888bf9c2c3bf5eba20063c28973 /meta/classes/setuptools3.bbclass
parentb6a535068dadbc6540c6f5cf49cb9fba777fe727 (diff)
downloadpoky-a50bf48f900b4a67d622c9833c391b049a04d2da.tar.gz
meta: rename pip_install_wheel.bbclass to python_pep517.bbclass
pip_install_wheel shouldn't restricted to just using Pip to install wheels (the installer module is simplier and likely a better option), and in the future may be extended to also provide do_compile() using the build module. (From OE-Core rev: 3bdf64b97facce9706cc579bdbc9a80e0d48428f) Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/setuptools3.bbclass')
-rw-r--r--meta/classes/setuptools3.bbclass8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta/classes/setuptools3.bbclass b/meta/classes/setuptools3.bbclass
index dcf3561b8d..556bc801af 100644
--- a/meta/classes/setuptools3.bbclass
+++ b/meta/classes/setuptools3.bbclass
@@ -1,4 +1,4 @@
1inherit setuptools3-base pip_install_wheel 1inherit setuptools3-base python_pep517
2 2
3# bdist_wheel builds in ./dist 3# bdist_wheel builds in ./dist
4#B = "${WORKDIR}/build" 4#B = "${WORKDIR}/build"
@@ -17,14 +17,14 @@ setuptools3_do_compile() {
17 STAGING_INCDIR=${STAGING_INCDIR} \ 17 STAGING_INCDIR=${STAGING_INCDIR} \
18 STAGING_LIBDIR=${STAGING_LIBDIR} \ 18 STAGING_LIBDIR=${STAGING_LIBDIR} \
19 ${STAGING_BINDIR_NATIVE}/${PYTHON_PN}-native/${PYTHON_PN} setup.py \ 19 ${STAGING_BINDIR_NATIVE}/${PYTHON_PN}-native/${PYTHON_PN} setup.py \
20 bdist_wheel --verbose --dist-dir ${PIP_INSTALL_DIST_PATH} ${SETUPTOOLS_BUILD_ARGS} || \ 20 bdist_wheel --verbose --dist-dir ${PEP517_WHEEL_PATH} ${SETUPTOOLS_BUILD_ARGS} || \
21 bbfatal_log "'${PYTHON_PN} setup.py bdist_wheel ${SETUPTOOLS_BUILD_ARGS}' execution failed." 21 bbfatal_log "'${PYTHON_PN} setup.py bdist_wheel ${SETUPTOOLS_BUILD_ARGS}' execution failed."
22} 22}
23setuptools3_do_compile[vardepsexclude] = "MACHINE" 23setuptools3_do_compile[vardepsexclude] = "MACHINE"
24do_compile[cleandirs] += "${PIP_INSTALL_DIST_PATH}" 24do_compile[cleandirs] += "${PEP517_WHEEL_PATH}"
25 25
26setuptools3_do_install() { 26setuptools3_do_install() {
27 pip_install_wheel_do_install 27 python_pep517_do_install
28} 28}
29 29
30EXPORT_FUNCTIONS do_configure do_compile do_install 30EXPORT_FUNCTIONS do_configure do_compile do_install