summaryrefslogtreecommitdiffstats
path: root/meta/classes/setuptools3.bbclass
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2022-01-11 11:01:11 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-01-12 21:09:01 +0000
commit458f37948928da5ca752f8f8beff4e95e919d06f (patch)
treebfb61a723d385333d85f6967320eda85913b259f /meta/classes/setuptools3.bbclass
parent5e36659ee314fdde2a357fa40a2109a9ebc7530d (diff)
downloadpoky-458f37948928da5ca752f8f8beff4e95e919d06f.tar.gz
setuptools3: refactor for no distutils bbclasses
Add setuptools3-base.bbclass as a re-usable starting point similar to what used to be distutils-common-base.bbclass and disutils3-base.bbclass. We no longer need to support python2, so no need for a setuptools-common-base.bbclass. Refactor setuptools3.bbclass to use setuptools3-base.bbclass instead of the distulis*.bbclasses. (From OE-Core rev: ca73393a36c4144662ea8570f904154188e9815a) Signed-off-by: Tim Orling <tim.orling@konsulko.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/setuptools3.bbclass')
-rw-r--r--meta/classes/setuptools3.bbclass66
1 files changed, 65 insertions, 1 deletions
diff --git a/meta/classes/setuptools3.bbclass b/meta/classes/setuptools3.bbclass
index 8ca66ee708..fd8499d26c 100644
--- a/meta/classes/setuptools3.bbclass
+++ b/meta/classes/setuptools3.bbclass
@@ -1,4 +1,68 @@
1inherit distutils3 1inherit setuptools3-base
2 2
3B = "${WORKDIR}/build"
4
5SETUPTOOLS_BUILD_ARGS ?= ""
6SETUPTOOLS_INSTALL_ARGS ?= "--root=${D} \
7 --prefix=${prefix} \
8 --install-lib=${PYTHON_SITEPACKAGES_DIR} \
9 --install-data=${datadir}"
10
11SETUPTOOLS_PYTHON = "python3"
12SETUPTOOLS_PYTHON:class-native = "nativepython3"
13
14SETUPTOOLS_SETUP_PATH ?= "${S}"
15
16setuptools3_do_configure() {
17 :
18}
19
20setuptools3_do_compile() {
21 cd ${SETUPTOOLS_SETUP_PATH}
22 NO_FETCH_BUILD=1 \
23 STAGING_INCDIR=${STAGING_INCDIR} \
24 STAGING_LIBDIR=${STAGING_LIBDIR} \
25 ${STAGING_BINDIR_NATIVE}/${PYTHON_PN}-native/${PYTHON_PN} setup.py \
26 build --build-base=${B} ${SETUPTOOLS_BUILD_ARGS} || \
27 bbfatal_log "'${PYTHON_PN} setup.py build ${SETUPTOOLS_BUILD_ARGS}' execution failed."
28}
29setuptools3_do_compile[vardepsexclude] = "MACHINE"
30
31setuptools3_do_install() {
32 cd ${SETUPTOOLS_SETUP_PATH}
33 install -d ${D}${PYTHON_SITEPACKAGES_DIR}
34 STAGING_INCDIR=${STAGING_INCDIR} \
35 STAGING_LIBDIR=${STAGING_LIBDIR} \
36 PYTHONPATH=${D}${PYTHON_SITEPACKAGES_DIR} \
37 ${STAGING_BINDIR_NATIVE}/${PYTHON_PN}-native/${PYTHON_PN} setup.py \
38 build --build-base=${B} install --skip-build ${SETUPTOOLS_INSTALL_ARGS} || \
39 bbfatal_log "'${PYTHON_PN} setup.py install ${SETUPTOOLS_INSTALL_ARGS}' execution failed."
40
41 # support filenames with *spaces*
42 find ${D} -name "*.py" -exec grep -q ${D} {} \; \
43 -exec sed -i -e s:${D}::g {} \;
44
45 for i in ${D}${bindir}/* ${D}${sbindir}/*; do
46 if [ -f "$i" ]; then
47 sed -i -e s:${PYTHON}:${USRBINPATH}/env\ ${SETUPTOOLS_PYTHON}:g $i
48 sed -i -e s:${STAGING_BINDIR_NATIVE}:${bindir}:g $i
49 fi
50 done
51
52 rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/easy-install.pth
53
54 #
55 # FIXME: Bandaid against wrong datadir computation
56 #
57 if [ -e ${D}${datadir}/share ]; then
58 mv -f ${D}${datadir}/share/* ${D}${datadir}/
59 rmdir ${D}${datadir}/share
60 fi
61}
62setuptools3_do_install[vardepsexclude] = "MACHINE"
63
64EXPORT_FUNCTIONS do_configure do_compile do_install
65
66export LDSHARED="${CCLD} -shared"
3DEPENDS += "python3-setuptools-native" 67DEPENDS += "python3-setuptools-native"
4 68