summaryrefslogtreecommitdiffstats
path: root/meta/classes/package_ipk.bbclass
diff options
context:
space:
mode:
authorLeonardo Sandoval <leonardo.sandoval.gonzalez@linux.intel.com>2017-09-04 14:35:47 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-09-11 17:30:28 +0100
commita8ab6d5c829d02107a968e5925c96f78bc98522a (patch)
treeb1ddfeacfa94e2d0e352b2a9a16b27abac214b15 /meta/classes/package_ipk.bbclass
parent9bf6b1127ad96cb197ba4c226c01f059fd6ec6ec (diff)
downloadpoky-a8ab6d5c829d02107a968e5925c96f78bc98522a.tar.gz
package_deb, ipk: improve subprocess output on package manager command
Redirecting stderr to stdout helps debugging issues, i.e instead of just getting the return code, get also the error log from the pkg manger This commit is in the way to figure out the root cause of [YOCTO #12012], where dpkg-deb fails with a 2 return code and according to the man page, there are multiple issues leading to the same code. (From OE-Core rev: 9ff023fb26f5f0ce19e757beda00ccc32c009b21) Signed-off-by: Leonardo Sandoval <leonardo.sandoval.gonzalez@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/package_ipk.bbclass')
-rw-r--r--meta/classes/package_ipk.bbclass4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta/classes/package_ipk.bbclass b/meta/classes/package_ipk.bbclass
index d58b824d3a..ec90996184 100644
--- a/meta/classes/package_ipk.bbclass
+++ b/meta/classes/package_ipk.bbclass
@@ -244,7 +244,9 @@ def ipk_write_pkg(pkg, d):
244 244
245 os.chdir(basedir) 245 os.chdir(basedir)
246 subprocess.check_output("PATH=\"%s\" %s %s %s" % (localdata.getVar("PATH"), 246 subprocess.check_output("PATH=\"%s\" %s %s %s" % (localdata.getVar("PATH"),
247 d.getVar("OPKGBUILDCMD"), pkg, pkgoutdir), shell=True) 247 d.getVar("OPKGBUILDCMD"), pkg, pkgoutdir),
248 stderr=subprocess.STDOUT,
249 shell=True)
248 250
249 if d.getVar('IPK_SIGN_PACKAGES') == '1': 251 if d.getVar('IPK_SIGN_PACKAGES') == '1':
250 ipkver = "%s-%s" % (d.getVar('PKGV'), d.getVar('PKGR')) 252 ipkver = "%s-%s" % (d.getVar('PKGV'), d.getVar('PKGR'))