summaryrefslogtreecommitdiffstats
path: root/meta/classes/libc-package.bbclass
diff options
context:
space:
mode:
authorDongxiao Xu <dongxiao.xu@intel.com>2011-06-28 14:58:15 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-06-28 13:44:41 +0100
commit8fa9d64f1d5128f304a0d36dbf55f49ccaf784b1 (patch)
treead031554642f4b160ec5b9bd044577c03ef0c5a6 /meta/classes/libc-package.bbclass
parent671e580111c3f37f3c7835956db17e0425f9f937 (diff)
downloadpoky-8fa9d64f1d5128f304a0d36dbf55f49ccaf784b1.tar.gz
libc-locale: split locale handling from libc recipe.
*libc's do_package will cost a lot of time due to the locale handing, which may delay the other recipe's do_package task and affect the build performance. This commit moves locale handling into a separate recipe *libc-locale. [RP: Add fixup with recent eglibc commit conflict for FILES_pn-dbg and PACKAGES] (From OE-Core rev: c6d3242f7642f537b02870bb4eb650f0e2094b85) Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/libc-package.bbclass')
-rw-r--r--meta/classes/libc-package.bbclass24
1 files changed, 0 insertions, 24 deletions
diff --git a/meta/classes/libc-package.bbclass b/meta/classes/libc-package.bbclass
index 55e3d48532..5737af4dfc 100644
--- a/meta/classes/libc-package.bbclass
+++ b/meta/classes/libc-package.bbclass
@@ -37,11 +37,6 @@ python __anonymous () {
37 break 37 break
38} 38}
39 39
40def get_libc_fpu_setting(bb, d):
41 if bb.data.getVar('TARGET_FPU', d, 1) in [ 'soft' ]:
42 return "--without-fp"
43 return ""
44
45OVERRIDES_append = ":${TARGET_ARCH}-${TARGET_OS}" 40OVERRIDES_append = ":${TARGET_ARCH}-${TARGET_OS}"
46 41
47do_configure_prepend() { 42do_configure_prepend() {
@@ -84,25 +79,6 @@ rm -rf ${TMP_LOCALE}
84} 79}
85 80
86 81
87do_install() {
88 oe_runmake install_root=${D} install
89 for r in ${rpcsvc}; do
90 h=`echo $r|sed -e's,\.x$,.h,'`
91 install -m 0644 ${S}/sunrpc/rpcsvc/$h ${D}/${includedir}/rpcsvc/
92 done
93 install -m 0644 ${WORKDIR}/etc/ld.so.conf ${D}/${sysconfdir}/
94 install -d ${D}${libdir}/locale
95 make -f ${WORKDIR}/generate-supported.mk IN="${S}/localedata/SUPPORTED" OUT="${WORKDIR}/SUPPORTED"
96 # get rid of some broken files...
97 for i in ${GLIBC_BROKEN_LOCALES}; do
98 grep -v $i ${WORKDIR}/SUPPORTED > ${WORKDIR}/SUPPORTED.tmp
99 mv ${WORKDIR}/SUPPORTED.tmp ${WORKDIR}/SUPPORTED
100 done
101 rm -f ${D}${sysconfdir}/rpc
102 rm -rf ${D}${datadir}/zoneinfo
103 rm -rf ${D}${libexecdir}/getconf
104}
105
106TMP_LOCALE="/tmp/locale${libdir}/locale" 82TMP_LOCALE="/tmp/locale${libdir}/locale"
107 83
108do_prep_locale_tree() { 84do_prep_locale_tree() {