summaryrefslogtreecommitdiffstats
path: root/meta/classes/libc-common.bbclass
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2020-01-29 21:13:46 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-02-02 16:57:21 +0000
commitad0b7366785e2b9d8edaa3496364a8c32f8c27b3 (patch)
tree66e3a8cbde822f6c606dadc7c24a31d3aa94bd14 /meta/classes/libc-common.bbclass
parent1c28cf571af169942c423e967b51913c5244d6c3 (diff)
downloadpoky-ad0b7366785e2b9d8edaa3496364a8c32f8c27b3.tar.gz
glibc: merge libc-common.bbclass into glibc.bb
There's only one user of libc-common now that we don't ship both glibc and eglibc, so copy the contents directly into the recipe. [ YOCTO #12135 ] (From OE-Core rev: a0bff0db1eeb128776757d5f3d0bc1ebdc135498) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/libc-common.bbclass')
-rw-r--r--meta/classes/libc-common.bbclass37
1 files changed, 0 insertions, 37 deletions
diff --git a/meta/classes/libc-common.bbclass b/meta/classes/libc-common.bbclass
deleted file mode 100644
index 0e351b6746..0000000000
--- a/meta/classes/libc-common.bbclass
+++ /dev/null
@@ -1,37 +0,0 @@
1do_install() {
2 oe_runmake install_root=${D} install
3 install -Dm 0644 ${WORKDIR}/etc/ld.so.conf ${D}/${sysconfdir}/ld.so.conf
4 install -d ${D}${localedir}
5 make -f ${WORKDIR}/generate-supported.mk IN="${S}/localedata/SUPPORTED" OUT="${WORKDIR}/SUPPORTED"
6 # get rid of some broken files...
7 for i in ${GLIBC_BROKEN_LOCALES}; do
8 sed -i "/$i/d" ${WORKDIR}/SUPPORTED
9 done
10 rm -f ${D}${sysconfdir}/rpc
11 rm -rf ${D}${datadir}/zoneinfo
12 rm -rf ${D}${libexecdir}/getconf
13}
14
15def get_libc_fpu_setting(bb, d):
16 if d.getVar('TARGET_FPU') in [ 'soft', 'ppc-efd' ]:
17 return "--without-fp"
18 return ""
19
20python populate_packages_prepend () {
21 if d.getVar('DEBIAN_NAMES'):
22 pkgs = d.getVar('PACKAGES').split()
23 bpn = d.getVar('BPN')
24 prefix = d.getVar('MLPREFIX') or ""
25 # Set the base package...
26 d.setVar('PKG_' + prefix + bpn, prefix + 'libc6')
27 libcprefix = prefix + bpn + '-'
28 for p in pkgs:
29 # And all the subpackages.
30 if p.startswith(libcprefix):
31 renamed = p.replace(bpn, 'libc6', 1)
32 d.setVar('PKG_' + p, renamed)
33 # For backward compatibility with old -dbg package
34 d.appendVar('RPROVIDES_' + libcprefix + 'dbg', ' ' + prefix + 'libc-dbg')
35 d.appendVar('RCONFLICTS_' + libcprefix + 'dbg', ' ' + prefix + 'libc-dbg')
36 d.appendVar('RREPLACES_' + libcprefix + 'dbg', ' ' + prefix + 'libc-dbg')
37}