summaryrefslogtreecommitdiffstats
path: root/meta/classes/libc-common.bbclass
diff options
context:
space:
mode:
authorDongxiao Xu <dongxiao.xu@intel.com>2011-06-28 14:58:15 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-06-28 13:44:41 +0100
commit8fa9d64f1d5128f304a0d36dbf55f49ccaf784b1 (patch)
treead031554642f4b160ec5b9bd044577c03ef0c5a6 /meta/classes/libc-common.bbclass
parent671e580111c3f37f3c7835956db17e0425f9f937 (diff)
downloadpoky-8fa9d64f1d5128f304a0d36dbf55f49ccaf784b1.tar.gz
libc-locale: split locale handling from libc recipe.
*libc's do_package will cost a lot of time due to the locale handing, which may delay the other recipe's do_package task and affect the build performance. This commit moves locale handling into a separate recipe *libc-locale. [RP: Add fixup with recent eglibc commit conflict for FILES_pn-dbg and PACKAGES] (From OE-Core rev: c6d3242f7642f537b02870bb4eb650f0e2094b85) Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/libc-common.bbclass')
-rw-r--r--meta/classes/libc-common.bbclass23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta/classes/libc-common.bbclass b/meta/classes/libc-common.bbclass
new file mode 100644
index 0000000000..bae0ace890
--- /dev/null
+++ b/meta/classes/libc-common.bbclass
@@ -0,0 +1,23 @@
1do_install() {
2 oe_runmake install_root=${D} install
3 for r in ${rpcsvc}; do
4 h=`echo $r|sed -e's,\.x$,.h,'`
5 install -m 0644 ${S}/sunrpc/rpcsvc/$h ${D}/${includedir}/rpcsvc/
6 done
7 install -m 0644 ${WORKDIR}/etc/ld.so.conf ${D}/${sysconfdir}/
8 install -d ${D}${libdir}/locale
9 make -f ${WORKDIR}/generate-supported.mk IN="${S}/localedata/SUPPORTED" OUT="${WORKDIR}/SUPPORTED"
10 # get rid of some broken files...
11 for i in ${GLIBC_BROKEN_LOCALES}; do
12 grep -v $i ${WORKDIR}/SUPPORTED > ${WORKDIR}/SUPPORTED.tmp
13 mv ${WORKDIR}/SUPPORTED.tmp ${WORKDIR}/SUPPORTED
14 done
15 rm -f ${D}{sysconfdir}/rpc
16 rm -rf ${D}${datadir}/zoneinfo
17 rm -rf ${D}${libexecdir}/getconf
18}
19
20def get_libc_fpu_setting(bb, d):
21 if bb.data.getVar('TARGET_FPU', d, 1) in [ 'soft' ]:
22 return "--without-fp"
23 return ""