summaryrefslogtreecommitdiffstats
path: root/meta/classes/libc-common.bbclass
diff options
context:
space:
mode:
authorChristopher Larson <chris_larson@mentor.com>2012-09-24 12:00:41 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-09-25 10:41:28 +0100
commit6ee9ebc42575d24bc5bcd5da175c81e4ea7ccb38 (patch)
treec9865126c092d3d78b3c800c2b80b19ce9b49499 /meta/classes/libc-common.bbclass
parentd02f02950ef4aff9ef9726cc364dd041e514fd3a (diff)
downloadpoky-6ee9ebc42575d24bc5bcd5da175c81e4ea7ccb38.tar.gz
Add and use 'localedir' variable
This avoids the hardcoding of ${libdir}/locale which is all over the place, and will facilitate use of ${exec_prefix}/lib/locale instead of ${libdir}/locale. This doesn't actually change any output at this time. Verified this with buildhistory against the packages produced from core-image-base. (From OE-Core rev: b744f4cc2912334b8493a89525fd02af8e9b8edf) Signed-off-by: Christopher Larson <chris_larson@mentor.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/libc-common.bbclass')
-rw-r--r--meta/classes/libc-common.bbclass2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/classes/libc-common.bbclass b/meta/classes/libc-common.bbclass
index 06d520164e..0f499366db 100644
--- a/meta/classes/libc-common.bbclass
+++ b/meta/classes/libc-common.bbclass
@@ -5,7 +5,7 @@ do_install() {
5 install -m 0644 ${S}/sunrpc/rpcsvc/$h ${D}/${includedir}/rpcsvc/ 5 install -m 0644 ${S}/sunrpc/rpcsvc/$h ${D}/${includedir}/rpcsvc/
6 done 6 done
7 install -m 0644 ${WORKDIR}/etc/ld.so.conf ${D}/${sysconfdir}/ 7 install -m 0644 ${WORKDIR}/etc/ld.so.conf ${D}/${sysconfdir}/
8 install -d ${D}${libdir}/locale 8 install -d ${D}${localedir}
9 make -f ${WORKDIR}/generate-supported.mk IN="${S}/localedata/SUPPORTED" OUT="${WORKDIR}/SUPPORTED" 9 make -f ${WORKDIR}/generate-supported.mk IN="${S}/localedata/SUPPORTED" OUT="${WORKDIR}/SUPPORTED"
10 # get rid of some broken files... 10 # get rid of some broken files...
11 for i in ${GLIBC_BROKEN_LOCALES}; do 11 for i in ${GLIBC_BROKEN_LOCALES}; do