summaryrefslogtreecommitdiffstats
path: root/meta/classes/kernel-uimage.bbclass
diff options
context:
space:
mode:
authorAlexey Brodkin <alexey.brodkin@synopsys.com>2018-11-23 01:58:20 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-11-23 23:35:19 +0000
commitc0f89c609d97f239b4acd263419a034dd3c5a03b (patch)
tree6734934baaa06dfc5713d2dbecf78184b5593cbf /meta/classes/kernel-uimage.bbclass
parent584c539eaad6673b5e3e2f055e8fccafd2984503 (diff)
downloadpoky-c0f89c609d97f239b4acd263419a034dd3c5a03b.tar.gz
u-boot: Add mkenvimage tool
This utility is used for creation of images containing usable in run-time U-Boot environment. As of today this utility is added per-board like here [1] for Intel Edison board. [1] http://git.yoctoproject.org/cgit/cgit.cgi/meta-intel-edison/tree/meta-intel-edison-bsp/recipes-bsp/u-boot/u-boot-tools_2014.04.bb Given there're quite some U-Boot tools that we may want to add later this recipe name switch from "u-boot-mkimage" to generic "u-boot-tools" still for compatibility we provide "u-boot-mkimage" with help of PROVIDES as well as proposed "u-boot-mkenvimage". (From OE-Core rev: 314885b16e5d26d27d46a4bfb0d581b27a03b8fe) Signed-off-by: Alexey Brodkin <abrodkin@synopsys.com> Cc: Richard Purdie <richard.purdie@linuxfoundation.org> Cc: Otavio Salvador <otavio@ossystems.com.br> Cc: Martin Jansa <martin.jansa@gmail.com> Cc: Ross Burton <ross.burton@intel.com> Cc: Marek Vasut <marex@denx.de> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/kernel-uimage.bbclass')
-rw-r--r--meta/classes/kernel-uimage.bbclass2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/classes/kernel-uimage.bbclass b/meta/classes/kernel-uimage.bbclass
index c2de6bb40d..cedb4fa070 100644
--- a/meta/classes/kernel-uimage.bbclass
+++ b/meta/classes/kernel-uimage.bbclass
@@ -3,7 +3,7 @@ inherit kernel-uboot
3python __anonymous () { 3python __anonymous () {
4 if "uImage" in d.getVar('KERNEL_IMAGETYPES'): 4 if "uImage" in d.getVar('KERNEL_IMAGETYPES'):
5 depends = d.getVar("DEPENDS") 5 depends = d.getVar("DEPENDS")
6 depends = "%s u-boot-mkimage-native" % depends 6 depends = "%s u-boot-tools-native" % depends
7 d.setVar("DEPENDS", depends) 7 d.setVar("DEPENDS", depends)
8 8
9 # Override KERNEL_IMAGETYPE_FOR_MAKE variable, which is internal 9 # Override KERNEL_IMAGETYPE_FOR_MAKE variable, which is internal