summaryrefslogtreecommitdiffstats
path: root/meta/classes/icecc.bbclass
diff options
context:
space:
mode:
authorUlrich Ölmann <u.oelmann@pengutronix.de>2022-09-07 12:57:50 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-09-07 21:28:41 +0100
commit35b3d0037fd7f3aec5a68ae8a22cbc032c7fa195 (patch)
treef1fd8c15aaecabcf811a4aad6a4a10a5d8762f61 /meta/classes/icecc.bbclass
parentae485d73add6c11eda2c21c33ae66aad8672abf6 (diff)
downloadpoky-35b3d0037fd7f3aec5a68ae8a22cbc032c7fa195.tar.gz
icecc.bbclass: fix typos
(From OE-Core rev: 7fd33565df5dfaa962bcafd842162a2f504c59e7) Signed-off-by: Ulrich Ölmann <u.oelmann@pengutronix.de> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/icecc.bbclass')
-rw-r--r--meta/classes/icecc.bbclass46
1 files changed, 23 insertions, 23 deletions
diff --git a/meta/classes/icecc.bbclass b/meta/classes/icecc.bbclass
index a11e781f00..8f06e9dd70 100644
--- a/meta/classes/icecc.bbclass
+++ b/meta/classes/icecc.bbclass
@@ -4,35 +4,35 @@
4# SPDX-License-Identifier: MIT 4# SPDX-License-Identifier: MIT
5# 5#
6 6
7# IceCream distributed compiling support 7# Icecream distributed compiling support
8# 8#
9# Stages directories with symlinks from gcc/g++ to icecc, for both 9# Stages directories with symlinks from gcc/g++ to icecc, for both
10# native and cross compilers. Depending on each configure or compile, 10# native and cross compilers. Depending on each configure or compile,
11# the directories are added at the head of the PATH list and ICECC_CXX 11# the directories are added at the head of the PATH list and ICECC_CXX
12# and ICEC_CC are set. 12# and ICECC_CC are set.
13# 13#
14# For the cross compiler, creates a tar.gz of our toolchain and sets 14# For the cross compiler, creates a tar.gz of our toolchain and sets
15# ICECC_VERSION accordingly. 15# ICECC_VERSION accordingly.
16# 16#
17# The class now handles all 3 different compile 'stages' (i.e native ,cross-kernel and target) creating the 17# The class now handles all 3 different compile 'stages' (i.e native ,cross-kernel and target) creating the
18# necessary environment tar.gz file to be used by the remote machines. 18# necessary environment tar.gz file to be used by the remote machines.
19# It also supports meta-toolchain generation 19# It also supports meta-toolchain generation.
20# 20#
21# If ICECC_PATH is not set in local.conf then the class will try to locate it using 'bb.utils.which' 21# If ICECC_PATH is not set in local.conf then the class will try to locate it using 'bb.utils.which'
22# but nothing is sure ;) 22# but nothing is sure. ;)
23# 23#
24# If ICECC_ENV_EXEC is set in local.conf, then it should point to the icecc-create-env script provided by the user 24# If ICECC_ENV_EXEC is set in local.conf, then it should point to the icecc-create-env script provided by the user
25# or the default one provided by icecc-create-env.bb will be used 25# or the default one provided by icecc-create-env_%.bb will be used.
26# (NOTE that this is a modified version of the script need it and *not the one that comes with icecc* 26# (NOTE that this is a modified version of the needed script and *not the one that comes with icecream*).
27# 27#
28# User can specify if specific recipes or recipes belonging to class should not use icecc to distribute 28# User can specify if specific recipes or recipes inheriting specific classes should not use icecc to distribute
29# compile jobs to remote machines, but handled locally, by defining ICECC_CLASS_DISABLE and ICECC_RECIPE_DISABLE 29# compile jobs to remote machines, but handle them locally by defining ICECC_CLASS_DISABLE and ICECC_RECIPE_DISABLE
30# with the appropriate values in local.conf. In addition the user can force to enable icecc for recipes 30# with the appropriate values in local.conf. In addition the user can force to enable icecc for recipes
31# which set an empty PARALLEL_MAKE variable by defining ICECC_RECIPE_ENABLE. 31# which set an empty PARALLEL_MAKE variable by defining ICECC_RECIPE_ENABLE.
32# 32#
33######################################################################################### 33#########################################################################################
34#Error checking is kept to minimum so double check any parameters you pass to the class 34# Error checking is kept to minimum so double check any parameters you pass to the class
35########################################################################################### 35#########################################################################################
36 36
37BB_BASEHASH_IGNORE_VARS += "ICECC_PARALLEL_MAKE ICECC_DISABLED ICECC_RECIPE_DISABLE \ 37BB_BASEHASH_IGNORE_VARS += "ICECC_PARALLEL_MAKE ICECC_DISABLED ICECC_RECIPE_DISABLE \
38 ICECC_CLASS_DISABLE ICECC_RECIPE_ENABLE ICECC_PATH ICECC_ENV_EXEC \ 38 ICECC_CLASS_DISABLE ICECC_RECIPE_ENABLE ICECC_PATH ICECC_ENV_EXEC \
@@ -50,7 +50,7 @@ HOSTTOOLS_NONFATAL += "icecc patchelf"
50# invalidate the version on the compile nodes. Changing it will cause a new 50# invalidate the version on the compile nodes. Changing it will cause a new
51# environment to be created. 51# environment to be created.
52# 52#
53# A useful thing to do for testing Icecream changes locally is to add a 53# A useful thing to do for testing icecream changes locally is to add a
54# subversion in local.conf: 54# subversion in local.conf:
55# ICECC_ENV_VERSION:append = "-my-ver-1" 55# ICECC_ENV_VERSION:append = "-my-ver-1"
56ICECC_ENV_VERSION = "2" 56ICECC_ENV_VERSION = "2"
@@ -72,16 +72,16 @@ CXXFLAGS += "${ICECC_CFLAGS}"
72ICECC_ENV_DEBUG ??= "" 72ICECC_ENV_DEBUG ??= ""
73 73
74# Disable recipe list contains a list of recipes that can not distribute 74# Disable recipe list contains a list of recipes that can not distribute
75# compile tasks for one reason or the other. When adding new entry, please 75# compile tasks for one reason or the other. When adding a new entry, please
76# document why (how it failed) so that we can re-evaluate it later e.g. when 76# document why (how it failed) so that we can re-evaluate it later e.g. when
77# there is new version 77# there is a new version.
78# 78#
79# libgcc-initial - fails with CPP sanity check error if host sysroot contains 79# libgcc-initial - fails with CPP sanity check error if host sysroot contains
80# cross gcc built for another target tune/variant 80# cross gcc built for another target tune/variant.
81# pixman - prng_state: TLS reference mismatches non-TLS reference, possibly due to 81# pixman - prng_state: TLS reference mismatches non-TLS reference, possibly due to
82# pragma omp threadprivate(prng_state) 82# pragma omp threadprivate(prng_state).
83# systemtap - _HelperSDT.c undefs macros and uses the identifiers in macros emitting 83# systemtap - _HelperSDT.c undefs macros and uses the identifiers in macros emitting
84# inline assembly 84# inline assembly.
85# target-sdk-provides-dummy - ${HOST_PREFIX} is empty which triggers the "NULL 85# target-sdk-provides-dummy - ${HOST_PREFIX} is empty which triggers the "NULL
86# prefix" error. 86# prefix" error.
87ICECC_RECIPE_DISABLE += "\ 87ICECC_RECIPE_DISABLE += "\
@@ -91,10 +91,10 @@ ICECC_RECIPE_DISABLE += "\
91 target-sdk-provides-dummy \ 91 target-sdk-provides-dummy \
92 " 92 "
93 93
94# Classes that should not use icecc. When adding new entry, please 94# Classes that should not use icecc. When adding a new entry, please
95# document why (how it failed) so that we can re-evaluate it later 95# document why (how it failed) so that we can re-evaluate it later.
96# 96#
97# image - Image aren't compiling, but the testing framework for images captures 97# image - images aren't compiling, but the testing framework for images captures
98# PARALLEL_MAKE as part of the test environment. Many tests won't use 98# PARALLEL_MAKE as part of the test environment. Many tests won't use
99# icecream, but leaving the high level of parallelism can cause them to 99# icecream, but leaving the high level of parallelism can cause them to
100# consume an unnecessary amount of resources. 100# consume an unnecessary amount of resources.
@@ -103,7 +103,7 @@ ICECC_CLASS_DISABLE += "\
103 " 103 "
104 104
105def get_icecc_dep(d): 105def get_icecc_dep(d):
106 # INHIBIT_DEFAULT_DEPS doesn't apply to the patch command. Whether or not 106 # INHIBIT_DEFAULT_DEPS doesn't apply to the patch command. Whether or not
107 # we need that built is the responsibility of the patch function / class, not 107 # we need that built is the responsibility of the patch function / class, not
108 # the application. 108 # the application.
109 if not d.getVar('INHIBIT_DEFAULT_DEPS'): 109 if not d.getVar('INHIBIT_DEFAULT_DEPS'):
@@ -259,7 +259,7 @@ def icecc_get_tool_link(tool, d):
259def icecc_get_path_tool(tool, d): 259def icecc_get_path_tool(tool, d):
260 # This is a little ugly, but we want to make sure we add an actual 260 # This is a little ugly, but we want to make sure we add an actual
261 # compiler to the toolchain, not ccache. Some distros (e.g. Fedora) 261 # compiler to the toolchain, not ccache. Some distros (e.g. Fedora)
262 # have ccache enabled by default using symlinks PATH, meaning ccache 262 # have ccache enabled by default using symlinks in PATH, meaning ccache
263 # would be found first when looking for the compiler. 263 # would be found first when looking for the compiler.
264 paths = os.getenv("PATH").split(':') 264 paths = os.getenv("PATH").split(':')
265 while True: 265 while True:
@@ -449,11 +449,11 @@ do_install:prepend() {
449 set_icecc_env 449 set_icecc_env
450} 450}
451 451
452# IceCream is not (currently) supported in the extensible SDK 452# Icecream is not (currently) supported in the extensible SDK
453ICECC_SDK_HOST_TASK = "nativesdk-icecc-toolchain" 453ICECC_SDK_HOST_TASK = "nativesdk-icecc-toolchain"
454ICECC_SDK_HOST_TASK:task-populate-sdk-ext = "" 454ICECC_SDK_HOST_TASK:task-populate-sdk-ext = ""
455 455
456# Don't include IceCream in uninative tarball 456# Don't include icecream in uninative tarball
457ICECC_SDK_HOST_TASK:pn-uninative-tarball = "" 457ICECC_SDK_HOST_TASK:pn-uninative-tarball = ""
458 458
459# Add the toolchain scripts to the SDK 459# Add the toolchain scripts to the SDK