summaryrefslogtreecommitdiffstats
path: root/meta/classes/gtk-doc.bbclass
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2021-07-28 23:28:15 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-08-02 15:44:10 +0100
commitbb6ddc3691ab04162ec5fd69a2d5e7876713fd15 (patch)
tree76e376b01253c3aace1a98a5021bcaad3c92e861 /meta/classes/gtk-doc.bbclass
parentfcc456ee4b8f619134abb4649db53c638074082c (diff)
downloadpoky-bb6ddc3691ab04162ec5fd69a2d5e7876713fd15.tar.gz
Convert to new override syntax
This is the result of automated script conversion: scripts/contrib/convert-overrides.py <oe-core directory> converting the metadata to use ":" as the override character instead of "_". (From OE-Core rev: 42344347be29f0997cc2f7636d9603b1fe1875ae) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/gtk-doc.bbclass')
-rw-r--r--meta/classes/gtk-doc.bbclass22
1 files changed, 11 insertions, 11 deletions
diff --git a/meta/classes/gtk-doc.bbclass b/meta/classes/gtk-doc.bbclass
index ef99e63faf..7149bc06c0 100644
--- a/meta/classes/gtk-doc.bbclass
+++ b/meta/classes/gtk-doc.bbclass
@@ -7,7 +7,7 @@
7# 7#
8# It should be used in recipes to determine whether gtk-doc based documentation should be built, 8# It should be used in recipes to determine whether gtk-doc based documentation should be built,
9# so that qemu use can be avoided when necessary. 9# so that qemu use can be avoided when necessary.
10GTKDOC_ENABLED_class-native = "False" 10GTKDOC_ENABLED:class-native = "False"
11GTKDOC_ENABLED ?= "${@bb.utils.contains('DISTRO_FEATURES', 'api-documentation', \ 11GTKDOC_ENABLED ?= "${@bb.utils.contains('DISTRO_FEATURES', 'api-documentation', \
12 bb.utils.contains('MACHINE_FEATURES', 'qemu-usermode', 'True', 'False', d), 'False', d)}" 12 bb.utils.contains('MACHINE_FEATURES', 'qemu-usermode', 'True', 'False', d), 'False', d)}"
13 13
@@ -19,20 +19,20 @@ GTKDOC_MESON_ENABLE_FLAG ?= 'true'
19GTKDOC_MESON_DISABLE_FLAG ?= 'false' 19GTKDOC_MESON_DISABLE_FLAG ?= 'false'
20 20
21# Auto enable/disable based on GTKDOC_ENABLED 21# Auto enable/disable based on GTKDOC_ENABLED
22EXTRA_OECONF_prepend_class-target = "${@bb.utils.contains('GTKDOC_ENABLED', 'True', '--enable-gtk-doc --enable-gtk-doc-html --disable-gtk-doc-pdf', \ 22EXTRA_OECONF:prepend:class-target = "${@bb.utils.contains('GTKDOC_ENABLED', 'True', '--enable-gtk-doc --enable-gtk-doc-html --disable-gtk-doc-pdf', \
23 '--disable-gtk-doc', d)} " 23 '--disable-gtk-doc', d)} "
24EXTRA_OEMESON_prepend_class-target = "-D${GTKDOC_MESON_OPTION}=${@bb.utils.contains('GTKDOC_ENABLED', 'True', '${GTKDOC_MESON_ENABLE_FLAG}', '${GTKDOC_MESON_DISABLE_FLAG}', d)} " 24EXTRA_OEMESON:prepend:class-target = "-D${GTKDOC_MESON_OPTION}=${@bb.utils.contains('GTKDOC_ENABLED', 'True', '${GTKDOC_MESON_ENABLE_FLAG}', '${GTKDOC_MESON_DISABLE_FLAG}', d)} "
25 25
26# When building native recipes, disable gtkdoc, as it is not necessary, 26# When building native recipes, disable gtkdoc, as it is not necessary,
27# pulls in additional dependencies, and makes build times longer 27# pulls in additional dependencies, and makes build times longer
28EXTRA_OECONF_prepend_class-native = "--disable-gtk-doc " 28EXTRA_OECONF:prepend:class-native = "--disable-gtk-doc "
29EXTRA_OECONF_prepend_class-nativesdk = "--disable-gtk-doc " 29EXTRA_OECONF:prepend:class-nativesdk = "--disable-gtk-doc "
30EXTRA_OEMESON_prepend_class-native = "-D${GTKDOC_MESON_OPTION}=${GTKDOC_MESON_DISABLE_FLAG} " 30EXTRA_OEMESON:prepend:class-native = "-D${GTKDOC_MESON_OPTION}=${GTKDOC_MESON_DISABLE_FLAG} "
31EXTRA_OEMESON_prepend_class-nativesdk = "-D${GTKDOC_MESON_OPTION}=${GTKDOC_MESON_DISABLE_FLAG} " 31EXTRA_OEMESON:prepend:class-nativesdk = "-D${GTKDOC_MESON_OPTION}=${GTKDOC_MESON_DISABLE_FLAG} "
32 32
33# Even though gtkdoc is disabled on -native, gtk-doc package is still 33# Even though gtkdoc is disabled on -native, gtk-doc package is still
34# needed for m4 macros. 34# needed for m4 macros.
35DEPENDS_append = " gtk-doc-native" 35DEPENDS:append = " gtk-doc-native"
36 36
37# The documentation directory, where the infrastructure will be copied. 37# The documentation directory, where the infrastructure will be copied.
38# gtkdocize has a default of "." so to handle out-of-tree builds set this to $S. 38# gtkdocize has a default of "." so to handle out-of-tree builds set this to $S.
@@ -41,15 +41,15 @@ GTKDOC_DOCDIR ?= "${S}"
41export STAGING_DIR_HOST 41export STAGING_DIR_HOST
42 42
43inherit python3native pkgconfig qemu 43inherit python3native pkgconfig qemu
44DEPENDS_append = "${@' qemu-native' if d.getVar('GTKDOC_ENABLED') == 'True' else ''}" 44DEPENDS:append = "${@' qemu-native' if d.getVar('GTKDOC_ENABLED') == 'True' else ''}"
45 45
46do_configure_prepend () { 46do_configure:prepend () {
47 # Need to use ||true as this is only needed if configure.ac both exists 47 # Need to use ||true as this is only needed if configure.ac both exists
48 # and uses GTK_DOC_CHECK. 48 # and uses GTK_DOC_CHECK.
49 gtkdocize --srcdir ${S} --docdir ${GTKDOC_DOCDIR} || true 49 gtkdocize --srcdir ${S} --docdir ${GTKDOC_DOCDIR} || true
50} 50}
51 51
52do_compile_prepend_class-target () { 52do_compile:prepend:class-target () {
53 if [ ${GTKDOC_ENABLED} = True ]; then 53 if [ ${GTKDOC_ENABLED} = True ]; then
54 # Write out a qemu wrapper that will be given to gtkdoc-scangobj so that it 54 # Write out a qemu wrapper that will be given to gtkdoc-scangobj so that it
55 # can run target helper binaries through that. 55 # can run target helper binaries through that.