summaryrefslogtreecommitdiffstats
path: root/meta/classes/fontcache.bbclass
diff options
context:
space:
mode:
authorMatthieu Crapet <Matthieu.Crapet@ingenico.com>2014-03-20 10:18:38 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-03-21 12:05:50 +0000
commitfe0287c81c95fa935b497829525d9fe5bbbe2079 (patch)
treed49693a880d7e5e9cbedb1e4ec694955162d6161 /meta/classes/fontcache.bbclass
parente2700768308c87db4bde04f6a1026d468489ddf4 (diff)
downloadpoky-fe0287c81c95fa935b497829525d9fe5bbbe2079.tar.gz
fontcache.bbclass: add fontconfig-utils runtime dependency
In an image recipe, you can get a warning, for example: WARNING: The postinstall intercept hook 'update_font_cache' failed (exit code: 1)! See log for details! WARNING: The postinstalls for the following packages will be postponed for first boot: ttf-dejavu-sans-mono (because /usr/bin/fc-cache is missing) In OE-core, rdepend is correctly done in each recipe: - ttf-fonts/liberation-fonts - ttf-fonts/ttf-bitstream-vera In meta-OE, rdepend is not done but packagegroup-fonts-truetype.bb includes fontconfig-utils: - ttf-fonts/ttf-arphic-uming - ttf-fonts/ttf-dejavu - ttf-fonts/ttf-droid - ttf-fonts/ttf-gentium - ttf-fonts/ttf-hunkyfonts - ttf-fonts/ttf-inconsolata - ttf-fonts/ttf-liberation - ttf-fonts/ttf-mplus - ttf-fonts/ttf-sazanami - ttf-fonts/ttf-ubuntu-font-family - ttf-fonts/ttf-wqy-zenhei (From OE-Core rev: 306335b13fedc18cf03da1c2a68e97c01eb59075) Signed-off-by: Matthieu Crapet <Matthieu.Crapet@ingenico.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/fontcache.bbclass')
-rw-r--r--meta/classes/fontcache.bbclass4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta/classes/fontcache.bbclass b/meta/classes/fontcache.bbclass
index 325bcae58f..afd3fd2252 100644
--- a/meta/classes/fontcache.bbclass
+++ b/meta/classes/fontcache.bbclass
@@ -7,6 +7,7 @@ DEPENDS += "qemu-native"
7inherit qemu 7inherit qemu
8 8
9FONT_PACKAGES ??= "${PN}" 9FONT_PACKAGES ??= "${PN}"
10FONT_EXTRA_RDEPENDS ?= "fontconfig-utils"
10 11
11fontcache_common() { 12fontcache_common() {
12if [ "x$D" != "x" ] ; then 13if [ "x$D" != "x" ] ; then
@@ -19,8 +20,11 @@ fi
19 20
20python populate_packages_append() { 21python populate_packages_append() {
21 font_pkgs = d.getVar('FONT_PACKAGES', True).split() 22 font_pkgs = d.getVar('FONT_PACKAGES', True).split()
23 deps = d.getVar("FONT_EXTRA_RDEPENDS", True)
22 24
23 for pkg in font_pkgs: 25 for pkg in font_pkgs:
26 if deps: d.appendVar('RDEPENDS_' + pkg, ' '+deps)
27
24 bb.note("adding fonts postinst and postrm scripts to %s" % pkg) 28 bb.note("adding fonts postinst and postrm scripts to %s" % pkg)
25 postinst = d.getVar('pkg_postinst_%s' % pkg, True) or d.getVar('pkg_postinst', True) 29 postinst = d.getVar('pkg_postinst_%s' % pkg, True) or d.getVar('pkg_postinst', True)
26 if not postinst: 30 if not postinst: