summaryrefslogtreecommitdiffstats
path: root/meta/classes/cve-check.bbclass
diff options
context:
space:
mode:
authorMichael Opdenacker <michael.opdenacker@bootlin.com>2021-08-05 17:51:01 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-08-06 06:34:58 +0100
commitfce14b90e302fed5f2b9276ae3f3efd0c9eecfd5 (patch)
tree0dfae829f0c7f49561cea1ead89c5106ae5f7c50 /meta/classes/cve-check.bbclass
parent45632b5366da88673715ba007be7c0c3739b09a9 (diff)
downloadpoky-fce14b90e302fed5f2b9276ae3f3efd0c9eecfd5.tar.gz
cve-check: fix comments
This implements various fixes in comments in cve-check.bbclass In particular, the "whitlisted" typo is important as the "whitelisted" word is going to be replaced in a near future. (From OE-Core rev: 5eecd2bf942254d08c252388594e5ec7ae330f45) Signed-off-by: Michael Opdenacker <michael.opdenacker@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/cve-check.bbclass')
-rw-r--r--meta/classes/cve-check.bbclass8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta/classes/cve-check.bbclass b/meta/classes/cve-check.bbclass
index a3fc9c2623..acdf005a72 100644
--- a/meta/classes/cve-check.bbclass
+++ b/meta/classes/cve-check.bbclass
@@ -20,7 +20,7 @@
20# the only method to check against CVEs. Running this tool 20# the only method to check against CVEs. Running this tool
21# doesn't guarantee your packages are free of CVEs. 21# doesn't guarantee your packages are free of CVEs.
22 22
23# The product name that the CVE database uses. Defaults to BPN, but may need to 23# The product name that the CVE database uses defaults to BPN, but may need to
24# be overriden per recipe (for example tiff.bb sets CVE_PRODUCT=libtiff). 24# be overriden per recipe (for example tiff.bb sets CVE_PRODUCT=libtiff).
25CVE_PRODUCT ??= "${BPN}" 25CVE_PRODUCT ??= "${BPN}"
26CVE_VERSION ??= "${PV}" 26CVE_VERSION ??= "${PV}"
@@ -56,11 +56,11 @@ CVE_CHECK_WHITELIST ?= ""
56# Layers to be excluded 56# Layers to be excluded
57CVE_CHECK_LAYER_EXCLUDELIST ??= "" 57CVE_CHECK_LAYER_EXCLUDELIST ??= ""
58 58
59# Layers to be included 59# Layers to be included
60CVE_CHECK_LAYER_INCLUDELIST ??= "" 60CVE_CHECK_LAYER_INCLUDELIST ??= ""
61 61
62 62
63# set to "alphabetical" for version using single alphabetical character as increament release 63# set to "alphabetical" for version using single alphabetical character as increment release
64CVE_VERSION_SUFFIX ??= "" 64CVE_VERSION_SUFFIX ??= ""
65 65
66python cve_save_summary_handler () { 66python cve_save_summary_handler () {
@@ -230,7 +230,7 @@ def check_cves(d, patched_cves):
230 return ([], [], []) 230 return ([], [], [])
231 pv = d.getVar("CVE_VERSION").split("+git")[0] 231 pv = d.getVar("CVE_VERSION").split("+git")[0]
232 232
233 # If the recipe has been whitlisted we return empty lists 233 # If the recipe has been whitelisted we return empty lists
234 if pn in d.getVar("CVE_CHECK_PN_WHITELIST").split(): 234 if pn in d.getVar("CVE_CHECK_PN_WHITELIST").split():
235 bb.note("Recipe has been whitelisted, skipping check") 235 bb.note("Recipe has been whitelisted, skipping check")
236 return ([], [], []) 236 return ([], [], [])