diff options
author | Matt Madison <matt@madison.systems> | 2021-09-25 04:00:38 -0700 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2021-09-26 14:36:48 +0100 |
commit | d6a0c61432746c139aaaf100c9500c410abb9e18 (patch) | |
tree | 016b776cb470af8fc1850bc7fe1e23a08ecc5692 /meta/classes/autotools.bbclass | |
parent | a6f6bcb9db22d4fd47f904c6e8ee3cd98294fcec (diff) | |
download | poky-d6a0c61432746c139aaaf100c9500c410abb9e18.tar.gz |
autotools.bbclass: use ordinary append for file-checksums update
Commit 29daffc2410f06f36b779d5bf1fd1ef6e900ca8f added an
anonymous python function to append the site file dependencies
for do_configure. This causes any recipe that inherits allarch
after autotools to end up with a different set of file checksums
for each machine, since the anonymous python would get processed
before the TARGET_ARCH changes in allarch.
Use an ordinary += assignment to fix this.
(From OE-Core rev: 60af398f520c938600205ef40e27f90e5342209c)
Signed-off-by: Matt Madison <matt@madison.systems>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/autotools.bbclass')
-rw-r--r-- | meta/classes/autotools.bbclass | 5 |
1 files changed, 1 insertions, 4 deletions
diff --git a/meta/classes/autotools.bbclass b/meta/classes/autotools.bbclass index bc0c2ea83e..4ab2460990 100644 --- a/meta/classes/autotools.bbclass +++ b/meta/classes/autotools.bbclass | |||
@@ -149,10 +149,7 @@ python autotools_aclocals () { | |||
149 | d.setVar("CONFIG_SITE", " ".join(sitefiles)) | 149 | d.setVar("CONFIG_SITE", " ".join(sitefiles)) |
150 | } | 150 | } |
151 | 151 | ||
152 | python () { | 152 | do_configure[file-checksums] += "${@' '.join(siteinfo_get_files(d, sysrootcache=False)[1])}" |
153 | sitefiles, searched = siteinfo_get_files(d, sysrootcache=False) | ||
154 | d.appendVarFlag("do_configure", "file-checksums", " " + " ".join(searched)) | ||
155 | } | ||
156 | 153 | ||
157 | CONFIGURE_FILES = "${S}/configure.in ${S}/configure.ac ${S}/config.h.in ${S}/acinclude.m4 Makefile.am" | 154 | CONFIGURE_FILES = "${S}/configure.in ${S}/configure.ac ${S}/config.h.in ${S}/acinclude.m4 Makefile.am" |
158 | 155 | ||