summaryrefslogtreecommitdiffstats
path: root/meta/classes/autotools.bbclass
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2012-10-18 15:58:25 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-10-19 13:35:16 +0100
commitd497fe9f965836bd6a148908a4fa155932d93681 (patch)
tree918e080718f609e6a4175b7cf295b292e52bf62c /meta/classes/autotools.bbclass
parente6e2b9bd66100c078c029ca7e34829cf1dfb5490 (diff)
downloadpoky-d497fe9f965836bd6a148908a4fa155932d93681.tar.gz
autotools: Use STAGING_DATADIR_NATIVE for config.rpath
For builds that don't use gettext, config.rpath may not exist in the target datadir. This change uses the native directory where it will always be present due to gettext-minimal-native (which allows us to autoreconf recipes using gettext even if we don't have gettext built). (From OE-Core rev: 0ea24447842e6b76ccfee0881f557e1a82e89ef1) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/autotools.bbclass')
-rw-r--r--meta/classes/autotools.bbclass4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/classes/autotools.bbclass b/meta/classes/autotools.bbclass
index 59c5bae8fa..b97d74b8d1 100644
--- a/meta/classes/autotools.bbclass
+++ b/meta/classes/autotools.bbclass
@@ -175,9 +175,9 @@ autotools_do_configure() {
175 fi 175 fi
176 else if grep "^[[:space:]]*AM_GNU_GETTEXT" $CONFIGURE_AC >/dev/null; then 176 else if grep "^[[:space:]]*AM_GNU_GETTEXT" $CONFIGURE_AC >/dev/null; then
177 # We'd call gettextize here if it wasn't so broken... 177 # We'd call gettextize here if it wasn't so broken...
178 cp ${STAGING_DATADIR}/gettext/config.rpath ${AUTOTOOLS_AUXDIR}/ 178 cp ${STAGING_DATADIR_NATIVE}/gettext/config.rpath ${AUTOTOOLS_AUXDIR}/
179 if [ -d ${S}/po/ ]; then 179 if [ -d ${S}/po/ ]; then
180 cp ${STAGING_DATADIR}/gettext/po/Makefile.in.in ${S}/po/ 180 cp ${STAGING_DATADIR_NATIVE}/gettext/po/Makefile.in.in ${S}/po/
181 fi 181 fi
182 for i in gettext.m4 iconv.m4 lib-ld.m4 lib-link.m4 lib-prefix.m4 nls.m4 po.m4 progtest.m4; do 182 for i in gettext.m4 iconv.m4 lib-ld.m4 lib-link.m4 lib-prefix.m4 nls.m4 po.m4 progtest.m4; do
183 for j in `find ${S} -name $i | grep -v aclocal-copy`; do 183 for j in `find ${S} -name $i | grep -v aclocal-copy`; do