summaryrefslogtreecommitdiffstats
path: root/meta/classes/autotools.bbclass
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2016-08-05 16:17:10 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-08-10 10:46:29 +0100
commit77e5a89df320fa4d6b6220dd8583a4e6f7964ccf (patch)
treeec9a1e470f4d1810e2c9f8b79f8c7bb86b1a56bd /meta/classes/autotools.bbclass
parent63cb0eec1f1ea29bb557b2e82caea233747b61b4 (diff)
downloadpoky-77e5a89df320fa4d6b6220dd8583a4e6f7964ccf.tar.gz
autotools.bbclass: remove intltool.m4 from ${S}
We need to ensure that builds use our intltool.m4 as there is a bug in upstream's macros when the host doesn't have XML::Parser installed. So generalise the m4 pruning logic that we already have from gettext and add intltool.m4. (From OE-Core rev: 342fa2b8407552a962e7c78d0e4de7b2d0b30041) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/autotools.bbclass')
-rw-r--r--meta/classes/autotools.bbclass13
1 files changed, 10 insertions, 3 deletions
diff --git a/meta/classes/autotools.bbclass b/meta/classes/autotools.bbclass
index 22359d3a0e..076899cce1 100644
--- a/meta/classes/autotools.bbclass
+++ b/meta/classes/autotools.bbclass
@@ -238,6 +238,9 @@ autotools_do_configure() {
238 # for a package whose autotools are old, on an x86_64 machine, which the old 238 # for a package whose autotools are old, on an x86_64 machine, which the old
239 # config.sub does not support. Work around this by installing them manually 239 # config.sub does not support. Work around this by installing them manually
240 # regardless. 240 # regardless.
241
242 PRUNE_M4=""
243
241 for ac in `find ${S} -ignore_readdir_race -name configure.in -o -name configure.ac`; do 244 for ac in `find ${S} -ignore_readdir_race -name configure.in -o -name configure.ac`; do
242 rm -f `dirname $ac`/configure 245 rm -f `dirname $ac`/configure
243 done 246 done
@@ -287,18 +290,22 @@ autotools_do_configure() {
287 cp ${STAGING_DATADIR_NATIVE}/gettext/po/remove-potcdate.sin ${S}/po/ 290 cp ${STAGING_DATADIR_NATIVE}/gettext/po/remove-potcdate.sin ${S}/po/
288 fi 291 fi
289 fi 292 fi
290 for i in gettext.m4 iconv.m4 lib-ld.m4 lib-link.m4 lib-prefix.m4 nls.m4 po.m4 progtest.m4; do 293 PRUNE_M4="$PRUNE_M4 gettext.m4 iconv.m4 lib-ld.m4 lib-link.m4 lib-prefix.m4 nls.m4 po.m4 progtest.m4"
291 find ${S} -ignore_readdir_race -name $i -delete
292 done
293 fi 294 fi
294 mkdir -p m4 295 mkdir -p m4
295 if grep "^[[:space:]]*[AI][CT]_PROG_INTLTOOL" $CONFIGURE_AC >/dev/null; then 296 if grep "^[[:space:]]*[AI][CT]_PROG_INTLTOOL" $CONFIGURE_AC >/dev/null; then
296 if ! echo "${DEPENDS}" | grep -q intltool-native; then 297 if ! echo "${DEPENDS}" | grep -q intltool-native; then
297 bbwarn "Missing DEPENDS on intltool-native" 298 bbwarn "Missing DEPENDS on intltool-native"
298 fi 299 fi
300 PRUNE_M4="$PRUNE_M4 intltool.m4"
299 bbnote Executing intltoolize --copy --force --automake 301 bbnote Executing intltoolize --copy --force --automake
300 intltoolize --copy --force --automake 302 intltoolize --copy --force --automake
301 fi 303 fi
304
305 for i in $PRUNE_M4; do
306 find ${S} -ignore_readdir_race -name $i -delete
307 done
308
302 bbnote Executing ACLOCAL=\"$ACLOCAL\" autoreconf --verbose --install --force ${EXTRA_AUTORECONF} $acpaths 309 bbnote Executing ACLOCAL=\"$ACLOCAL\" autoreconf --verbose --install --force ${EXTRA_AUTORECONF} $acpaths
303 ACLOCAL="$ACLOCAL" autoreconf -Wcross --verbose --install --force ${EXTRA_AUTORECONF} $acpaths || die "autoreconf execution failed." 310 ACLOCAL="$ACLOCAL" autoreconf -Wcross --verbose --install --force ${EXTRA_AUTORECONF} $acpaths || die "autoreconf execution failed."
304 cd $olddir 311 cd $olddir