summaryrefslogtreecommitdiffstats
path: root/meta/classes/autotools.bbclass
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2015-04-28 11:51:12 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-04-29 10:58:54 +0100
commit527b28c10955daf0387597020d69593ce24bcaa4 (patch)
tree6f33a41c127b7b90ff7de46dab9992d6aead5726 /meta/classes/autotools.bbclass
parente794d099248645ae8835ebdf46b071e3b3633eeb (diff)
downloadpoky-527b28c10955daf0387597020d69593ce24bcaa4.tar.gz
autotools: Fix find races on source directory
In a similar way to http://git.yoctoproject.org/cgit.cgi/poky/commit/?id=aa1438b56f30515f9c31b306decef7f562dda81f there are more find races in the autotools class. For recipes with PACKAGES_remove = "${PN}", the find which removes .la files can race against deletion of other directories in WORKDIR e.g.: find: '/home/autobuilder/yocto-autobuilder/yocto-worker/nightly-oe-selftest/build/build/tmp/work/qemux86_64-poky-linux/init-ifupdown/1.0-r7/sstate-build-populate_lic': No such file or directory | WARNING: /home/autobuilder/yocto-autobuilder/yocto-worker/nightly-oe-selftest/build/build/tmp/work/qemux86_64-poky-linux/init-ifupdown/1.0-r7/temp/run.do_configure.6558:1 exit 1 from | find /home/autobuilder/yocto-autobuilder/yocto-worker/nightly-oe-selftest/build/build/tmp/work/qemux86_64-poky-linux/init-ifupdown/1.0-r7 -name \*.la -delete Fix the remaining races in the same way. [YOCTO #7522] (From OE-Core rev: 79770ca14a0cc2f4112fb4d8dc2d8832701b6d5d) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/autotools.bbclass')
-rw-r--r--meta/classes/autotools.bbclass8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta/classes/autotools.bbclass b/meta/classes/autotools.bbclass
index bb129fb245..f213e893df 100644
--- a/meta/classes/autotools.bbclass
+++ b/meta/classes/autotools.bbclass
@@ -114,7 +114,7 @@ autotools_preconfigure() {
114 echo "Running \"${MAKE} clean\" in ${S}" 114 echo "Running \"${MAKE} clean\" in ${S}"
115 ${MAKE} clean 115 ${MAKE} clean
116 fi 116 fi
117 find ${S} -name \*.la -delete 117 find ${S} -ignore_readdir_race -name \*.la -delete
118 fi 118 fi
119 fi 119 fi
120 fi 120 fi
@@ -225,7 +225,7 @@ autotools_do_configure() {
225 # for a package whose autotools are old, on an x86_64 machine, which the old 225 # for a package whose autotools are old, on an x86_64 machine, which the old
226 # config.sub does not support. Work around this by installing them manually 226 # config.sub does not support. Work around this by installing them manually
227 # regardless. 227 # regardless.
228 ( for ac in `find ${S} -name configure.in -o -name configure.ac`; do 228 ( for ac in `find ${S} -ignore_readdir_race -name configure.in -o -name configure.ac`; do
229 rm -f `dirname $ac`/configure 229 rm -f `dirname $ac`/configure
230 done ) 230 done )
231 if [ -e ${S}/configure.in -o -e ${S}/configure.ac ]; then 231 if [ -e ${S}/configure.in -o -e ${S}/configure.ac ]; then
@@ -234,7 +234,7 @@ autotools_do_configure() {
234 ACLOCAL="aclocal --system-acdir=${ACLOCALDIR}/" 234 ACLOCAL="aclocal --system-acdir=${ACLOCALDIR}/"
235 if [ x"${acpaths}" = xdefault ]; then 235 if [ x"${acpaths}" = xdefault ]; then
236 acpaths= 236 acpaths=
237 for i in `find ${S} -maxdepth 2 -name \*.m4|grep -v 'aclocal.m4'| \ 237 for i in `find ${S} -ignore_readdir_race -maxdepth 2 -name \*.m4|grep -v 'aclocal.m4'| \
238 grep -v 'acinclude.m4' | grep -v 'aclocal-copy' | sed -e 's,\(.*/\).*$,\1,'|sort -u`; do 238 grep -v 'acinclude.m4' | grep -v 'aclocal-copy' | sed -e 's,\(.*/\).*$,\1,'|sort -u`; do
239 acpaths="$acpaths -I $i" 239 acpaths="$acpaths -I $i"
240 done 240 done
@@ -275,7 +275,7 @@ autotools_do_configure() {
275 fi 275 fi
276 fi 276 fi
277 for i in gettext.m4 iconv.m4 lib-ld.m4 lib-link.m4 lib-prefix.m4 nls.m4 po.m4 progtest.m4; do 277 for i in gettext.m4 iconv.m4 lib-ld.m4 lib-link.m4 lib-prefix.m4 nls.m4 po.m4 progtest.m4; do
278 for j in `find ${S} -name $i | grep -v aclocal-copy`; do 278 for j in `find ${S} -ignore_readdir_race -name $i | grep -v aclocal-copy`; do
279 rm $j 279 rm $j
280 done 280 done
281 done 281 done