summaryrefslogtreecommitdiffstats
path: root/meta/classes/autotools.bbclass
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2014-03-03 15:49:50 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-03-05 15:50:19 +0000
commit12d613f9a9566cc4bf2555970d4eae8ba3868c36 (patch)
treecf5f1ee842c21043509743982d7d4f9e5727cab7 /meta/classes/autotools.bbclass
parentb924b499ecd28bb433a12fb327f0e63d66db97b5 (diff)
downloadpoky-12d613f9a9566cc4bf2555970d4eae8ba3868c36.tar.gz
alsa-tools/autotools: Ensure that aclocal files can be present with AUTOTOOLS_COPYACLOCAL variable
Introduce a AUTOTOOLS_COPYACLOCAL variable which forces the copy of the aclocal files even when a configure.ac/.in file isn't present. Use this new feature in alsa-tools. (From OE-Core rev: 07db5222a970e40bff51c5df793f0021b0e2aba8) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/autotools.bbclass')
-rw-r--r--meta/classes/autotools.bbclass3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta/classes/autotools.bbclass b/meta/classes/autotools.bbclass
index 01e49c98bf..b645996136 100644
--- a/meta/classes/autotools.bbclass
+++ b/meta/classes/autotools.bbclass
@@ -138,7 +138,8 @@ ACLOCALDIR = "${B}/aclocal-copy"
138python autotools_copy_aclocals () { 138python autotools_copy_aclocals () {
139 s = d.getVar("S", True) 139 s = d.getVar("S", True)
140 if not os.path.exists(s + "/configure.in") and not os.path.exists(s + "/configure.ac"): 140 if not os.path.exists(s + "/configure.in") and not os.path.exists(s + "/configure.ac"):
141 return 141 if not d.getVar("AUTOTOOLS_COPYACLOCAL"):
142 return
142 143
143 taskdepdata = d.getVar("BB_TASKDEPDATA", False) 144 taskdepdata = d.getVar("BB_TASKDEPDATA", False)
144 pn = d.getVar("PN", True) 145 pn = d.getVar("PN", True)