summaryrefslogtreecommitdiffstats
path: root/meta/classes-recipe/setuptools3_legacy.bbclass
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2024-02-19 16:07:55 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-02-20 11:39:45 +0000
commit0b33104a973c9dee0a33254197e487e7fc6156b7 (patch)
tree7d3e938fcd8f6263a37a131df6ccde551db84471 /meta/classes-recipe/setuptools3_legacy.bbclass
parent4cfd0f7e4e2db19344677999572e5b71ae97dfc4 (diff)
downloadpoky-0b33104a973c9dee0a33254197e487e7fc6156b7.tar.gz
python: Drop ${PYTHON_PN}
python 2 is gone and we don't need the abstraction now, drop the remaining usage of this variable. The definition in python3-dir.bbclass is left for now for other layers. (From OE-Core rev: b566b1e32c7993d1ab7795562f648e52ce186a70) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes-recipe/setuptools3_legacy.bbclass')
-rw-r--r--meta/classes-recipe/setuptools3_legacy.bbclass8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta/classes-recipe/setuptools3_legacy.bbclass b/meta/classes-recipe/setuptools3_legacy.bbclass
index 57de956d0a..264b1f5cfb 100644
--- a/meta/classes-recipe/setuptools3_legacy.bbclass
+++ b/meta/classes-recipe/setuptools3_legacy.bbclass
@@ -38,9 +38,9 @@ setuptools3_legacy_do_compile() {
38 NO_FETCH_BUILD=1 \ 38 NO_FETCH_BUILD=1 \
39 STAGING_INCDIR=${STAGING_INCDIR} \ 39 STAGING_INCDIR=${STAGING_INCDIR} \
40 STAGING_LIBDIR=${STAGING_LIBDIR} \ 40 STAGING_LIBDIR=${STAGING_LIBDIR} \
41 ${STAGING_BINDIR_NATIVE}/${PYTHON_PN}-native/${PYTHON_PN} setup.py \ 41 ${STAGING_BINDIR_NATIVE}/python3-native/python3 setup.py \
42 build --build-base=${B} ${SETUPTOOLS_BUILD_ARGS} || \ 42 build --build-base=${B} ${SETUPTOOLS_BUILD_ARGS} || \
43 bbfatal_log "'${PYTHON_PN} setup.py build ${SETUPTOOLS_BUILD_ARGS}' execution failed." 43 bbfatal_log "'python3 setup.py build ${SETUPTOOLS_BUILD_ARGS}' execution failed."
44} 44}
45setuptools3_legacy_do_compile[vardepsexclude] = "MACHINE" 45setuptools3_legacy_do_compile[vardepsexclude] = "MACHINE"
46 46
@@ -50,9 +50,9 @@ setuptools3_legacy_do_install() {
50 STAGING_INCDIR=${STAGING_INCDIR} \ 50 STAGING_INCDIR=${STAGING_INCDIR} \
51 STAGING_LIBDIR=${STAGING_LIBDIR} \ 51 STAGING_LIBDIR=${STAGING_LIBDIR} \
52 PYTHONPATH=${D}${PYTHON_SITEPACKAGES_DIR}:$PYTHONPATH \ 52 PYTHONPATH=${D}${PYTHON_SITEPACKAGES_DIR}:$PYTHONPATH \
53 ${STAGING_BINDIR_NATIVE}/${PYTHON_PN}-native/${PYTHON_PN} setup.py \ 53 ${STAGING_BINDIR_NATIVE}/python3-native/python3 setup.py \
54 build --build-base=${B} install --skip-build ${SETUPTOOLS_INSTALL_ARGS} || \ 54 build --build-base=${B} install --skip-build ${SETUPTOOLS_INSTALL_ARGS} || \
55 bbfatal_log "'${PYTHON_PN} setup.py install ${SETUPTOOLS_INSTALL_ARGS}' execution failed." 55 bbfatal_log "'python3 setup.py install ${SETUPTOOLS_INSTALL_ARGS}' execution failed."
56 56
57 # support filenames with *spaces* 57 # support filenames with *spaces*
58 find ${D} -name "*.py" -exec grep -q ${D} {} \; \ 58 find ${D} -name "*.py" -exec grep -q ${D} {} \; \