summaryrefslogtreecommitdiffstats
path: root/meta/classes-recipe/meson.bbclass
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@arm.com>2023-08-10 17:24:43 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-08-16 07:54:38 +0100
commitd0cedc40397109ba018e71f9aa708a1a8cc8ccb5 (patch)
tree971aa420f0d84d9dd3aa2317c5079ca2b25a3a46 /meta/classes-recipe/meson.bbclass
parent64789f18f3cd983e8ce451c24e9709bab41bafa0 (diff)
downloadpoky-d0cedc40397109ba018e71f9aa708a1a8cc8ccb5.tar.gz
meson.bbclass: add MESON_TARGET
Add a variable to control what target gets built in do_compile. By default this value is unset so meson builds the default target, but by setting MESON_TARGET a specific target can be built. (From OE-Core rev: bd82ccc819ec90af08216fe780af6a66f1d347b3) Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes-recipe/meson.bbclass')
-rw-r--r--meta/classes-recipe/meson.bbclass5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta/classes-recipe/meson.bbclass b/meta/classes-recipe/meson.bbclass
index 7f5e9b1943..582b41a91b 100644
--- a/meta/classes-recipe/meson.bbclass
+++ b/meta/classes-recipe/meson.bbclass
@@ -20,6 +20,9 @@ do_configure[cleandirs] = "${B}"
20# Where the meson.build build configuration is 20# Where the meson.build build configuration is
21MESON_SOURCEPATH = "${S}" 21MESON_SOURCEPATH = "${S}"
22 22
23# The target to build in do_compile. If unset the default targets are built.
24MESON_TARGET ?= ""
25
23def noprefix(var, d): 26def noprefix(var, d):
24 return d.getVar(var).replace(d.getVar('prefix') + '/', '', 1) 27 return d.getVar(var).replace(d.getVar('prefix') + '/', '', 1)
25 28
@@ -170,7 +173,7 @@ do_configure[postfuncs] += "meson_do_qa_configure"
170 173
171do_compile[progress] = "outof:^\[(\d+)/(\d+)\]\s+" 174do_compile[progress] = "outof:^\[(\d+)/(\d+)\]\s+"
172meson_do_compile() { 175meson_do_compile() {
173 meson compile -v ${PARALLEL_MAKE} 176 meson compile -v ${PARALLEL_MAKE} ${MESON_TARGET}
174} 177}
175 178
176meson_do_install() { 179meson_do_install() {