summaryrefslogtreecommitdiffstats
path: root/meta/classes-recipe/gtk-doc.bbclass
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@arm.com>2024-01-10 13:07:28 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-01-12 11:54:05 +0000
commit2c8e3a3b83748cec6e7093dd649e79b69e911835 (patch)
tree7a58043a417ea82df2ad94197b98bff81c4a3d05 /meta/classes-recipe/gtk-doc.bbclass
parent97ef820a607f232275207dc9f1c8dadb41f836fa (diff)
downloadpoky-2c8e3a3b83748cec6e7093dd649e79b69e911835.tar.gz
gtk-doc: don't manually call gtkdocize
The autoreconf call will now call gtkdocize if needed, so we don't need to run it manually here. This obsoletes GTKDOC_DOCDIR. If this is needed then the replacement is to ensure that the configure.ac has a call to GTK_DOC_CHECK which passes --docdir. For example, this is the change required for kmod: -GTK_DOC_CHECK([1.14],[--flavour no-tmpl-flat]) +GTK_DOC_CHECK([1.14],[--flavour no-tmpl-flat --docdir libkmod/docs]) (From OE-Core rev: 57b0201bfccb4552893d72dc4d76eaa855618563) Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes-recipe/gtk-doc.bbclass')
-rw-r--r--meta/classes-recipe/gtk-doc.bbclass10
1 files changed, 0 insertions, 10 deletions
diff --git a/meta/classes-recipe/gtk-doc.bbclass b/meta/classes-recipe/gtk-doc.bbclass
index c980c6bb52..9d3911966b 100644
--- a/meta/classes-recipe/gtk-doc.bbclass
+++ b/meta/classes-recipe/gtk-doc.bbclass
@@ -33,21 +33,11 @@ EXTRA_OEMESON:prepend = "-D${GTKDOC_MESON_OPTION}=${@bb.utils.contains('GTKDOC_E
33# needed for m4 macros. 33# needed for m4 macros.
34DEPENDS:append = " gtk-doc-native" 34DEPENDS:append = " gtk-doc-native"
35 35
36# The documentation directory, where the infrastructure will be copied.
37# gtkdocize has a default of "." so to handle out-of-tree builds set this to $S.
38GTKDOC_DOCDIR ?= "${S}"
39
40export STAGING_DIR_HOST 36export STAGING_DIR_HOST
41 37
42inherit python3native pkgconfig qemu 38inherit python3native pkgconfig qemu
43DEPENDS:append = "${@' qemu-native' if d.getVar('GTKDOC_ENABLED') == 'True' else ''}" 39DEPENDS:append = "${@' qemu-native' if d.getVar('GTKDOC_ENABLED') == 'True' else ''}"
44 40
45do_configure:prepend () {
46 # Need to use ||true as this is only needed if configure.ac both exists
47 # and uses GTK_DOC_CHECK.
48 gtkdocize --srcdir ${S} --docdir ${GTKDOC_DOCDIR} || true
49}
50
51do_compile:prepend:class-target () { 41do_compile:prepend:class-target () {
52 if [ ${GTKDOC_ENABLED} = True ]; then 42 if [ ${GTKDOC_ENABLED} = True ]; then
53 # Write out a qemu wrapper that will be given to gtkdoc-scangobj so that it 43 # Write out a qemu wrapper that will be given to gtkdoc-scangobj so that it