diff options
author | Peter Marko <peter.marko@siemens.com> | 2024-06-25 21:36:45 +0200 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2024-06-27 13:03:34 +0100 |
commit | 7afa4f50b49dd3eed809b2e66ca18cc86835c534 (patch) | |
tree | ff5f3cabd25e1c782ad1cfcae40346da77d16287 /meta/classes-recipe/cargo_common.bbclass | |
parent | 918c66d8e6dfb605055a447efa82755a70a47b00 (diff) | |
download | poky-7afa4f50b49dd3eed809b2e66ca18cc86835c534.tar.gz |
cargo: remove True option to getVar calls
Layer cleanup similar to
https://git.openembedded.org/openembedded-core/commit/?id=26c74fd10614582e177437608908eb43688ab510
(From OE-Core rev: 9a2ed52473a3e4eb662509824ef8e59520ebdefb)
Signed-off-by: Peter Marko <peter.marko@siemens.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes-recipe/cargo_common.bbclass')
-rw-r--r-- | meta/classes-recipe/cargo_common.bbclass | 4 |
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/classes-recipe/cargo_common.bbclass b/meta/classes-recipe/cargo_common.bbclass index 78440c810b..2386cc3d77 100644 --- a/meta/classes-recipe/cargo_common.bbclass +++ b/meta/classes-recipe/cargo_common.bbclass | |||
@@ -41,7 +41,7 @@ CARGO_SRC_DIR ??= "" | |||
41 | CARGO_MANIFEST_PATH ??= "${S}/${CARGO_SRC_DIR}/Cargo.toml" | 41 | CARGO_MANIFEST_PATH ??= "${S}/${CARGO_SRC_DIR}/Cargo.toml" |
42 | 42 | ||
43 | # Path to Cargo.lock | 43 | # Path to Cargo.lock |
44 | CARGO_LOCK_PATH ??= "${@ os.path.join(os.path.dirname(d.getVar('CARGO_MANIFEST_PATH', True)), 'Cargo.lock')}" | 44 | CARGO_LOCK_PATH ??= "${@ os.path.join(os.path.dirname(d.getVar('CARGO_MANIFEST_PATH')), 'Cargo.lock')}" |
45 | 45 | ||
46 | CARGO_RUST_TARGET_CCLD ??= "${RUST_TARGET_CCLD}" | 46 | CARGO_RUST_TARGET_CCLD ??= "${RUST_TARGET_CCLD}" |
47 | cargo_common_do_configure () { | 47 | cargo_common_do_configure () { |
@@ -171,7 +171,7 @@ python cargo_common_do_patch_paths() { | |||
171 | # here is better than letting cargo tell (in case the file is missing) | 171 | # here is better than letting cargo tell (in case the file is missing) |
172 | # "Cargo.lock should be modified but --frozen was given" | 172 | # "Cargo.lock should be modified but --frozen was given" |
173 | 173 | ||
174 | lockfile = d.getVar("CARGO_LOCK_PATH", True) | 174 | lockfile = d.getVar("CARGO_LOCK_PATH") |
175 | if not os.path.exists(lockfile): | 175 | if not os.path.exists(lockfile): |
176 | bb.fatal(f"{lockfile} file doesn't exist") | 176 | bb.fatal(f"{lockfile} file doesn't exist") |
177 | 177 | ||