summaryrefslogtreecommitdiffstats
path: root/meta/classes-recipe/cargo.bbclass
diff options
context:
space:
mode:
authorAlex Kiernan <alex.kiernan@gmail.com>2023-12-07 13:39:11 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-12-08 16:58:34 +0000
commita8f959a8d315fe769b622139ba2e1b37c5bb7d00 (patch)
treeaf0cf0665b5468096e1094b07a544d6196af96f1 /meta/classes-recipe/cargo.bbclass
parent9a5c1456ba90bf986c91d8aa92b1dfb7ed3d7ab0 (diff)
downloadpoky-a8f959a8d315fe769b622139ba2e1b37c5bb7d00.tar.gz
cargo: Rename MANIFEST_PATH -> CARGO_MANIFEST_PATH
This variable is a piece of recipe configurable interface, scope it with the class name to make that clear. (From OE-Core rev: 0101de25832fbed3d08cd522512784133c628cad) Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes-recipe/cargo.bbclass')
-rw-r--r--meta/classes-recipe/cargo.bbclass4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/classes-recipe/cargo.bbclass b/meta/classes-recipe/cargo.bbclass
index 8c0b92df8d..96a74e2ef1 100644
--- a/meta/classes-recipe/cargo.bbclass
+++ b/meta/classes-recipe/cargo.bbclass
@@ -35,7 +35,7 @@ export RUST_BACKTRACE = "1"
35CARGO_SRC_DIR ??= "" 35CARGO_SRC_DIR ??= ""
36 36
37# The actual path to the Cargo.toml 37# The actual path to the Cargo.toml
38MANIFEST_PATH ??= "${S}/${CARGO_SRC_DIR}/Cargo.toml" 38CARGO_MANIFEST_PATH ??= "${S}/${CARGO_SRC_DIR}/Cargo.toml"
39 39
40RUSTFLAGS ??= "" 40RUSTFLAGS ??= ""
41BUILD_MODE = "${@['--release', ''][d.getVar('DEBUG_BUILD') == '1']}" 41BUILD_MODE = "${@['--release', ''][d.getVar('DEBUG_BUILD') == '1']}"
@@ -44,7 +44,7 @@ BUILD_MODE = "${@['--release', ''][d.getVar('DEBUG_BUILD') == '1']}"
44# and will require an up to date Cargo.lock file. 44# and will require an up to date Cargo.lock file.
45# This force the package being built to already ship a Cargo.lock, in the end 45# This force the package being built to already ship a Cargo.lock, in the end
46# this is what we want, at least, for reproducibility of the build. 46# this is what we want, at least, for reproducibility of the build.
47CARGO_BUILD_FLAGS = "-v --frozen --target ${RUST_HOST_SYS} ${BUILD_MODE} --manifest-path=${MANIFEST_PATH}" 47CARGO_BUILD_FLAGS = "-v --frozen --target ${RUST_HOST_SYS} ${BUILD_MODE} --manifest-path=${CARGO_MANIFEST_PATH}"
48 48
49# This is based on the content of CARGO_BUILD_FLAGS and generally will need to 49# This is based on the content of CARGO_BUILD_FLAGS and generally will need to
50# change if CARGO_BUILD_FLAGS changes. 50# change if CARGO_BUILD_FLAGS changes.