summaryrefslogtreecommitdiffstats
path: root/meta/classes-global/sstate.bbclass
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@amd.com>2024-05-01 15:26:33 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-05-02 15:11:06 +0100
commita73e9446b1c7cf6c526b4eef1e59744ae449de2b (patch)
treea7c1013e0a2ccc338080a7c1d5e8013f8e37803a /meta/classes-global/sstate.bbclass
parent6e8300da5be8dae75f6cee23ad4906fb645fdb03 (diff)
downloadpoky-a73e9446b1c7cf6c526b4eef1e59744ae449de2b.tar.gz
sstate.bbclass: Add _SSTATE_EXCLUDEDEPS_SYSROOT to vardepsexclude
When using tinfoil to control the build, multiple commands (serially) could trigger an error such as: When reparsing ....bb:do_package, the basehash value changed from ... to .... The metadata is not deterministic and this needs to be fixed. ERROR: The following commands may help: ERROR: $ bitbake esw-conf -cdo_package -Snone ERROR: Then: ERROR: $ bitbake esw-conf -cdo_package -Sprintdiff However following these commands it was not able to be reproduced. Forcing bitbake to dump the signatures and then running bitbake-diffsigs showed that the value of _SSTATE_EXCLUDEDEPS_SYSROOT was being set in one run, but was blank is a different version. Upon inspecting the code in sstate.bbclass, one usage (without the _) is already excludes, the leading _ version is used as a cache, only if set but is not actually required to be defined. So ignoring the value should work properly. (From OE-Core rev: 4ec704ed6a1cfaf0a6c20f2038e7192e361ef590) Signed-off-by: Mark Hatle <mark.hatle@amd.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes-global/sstate.bbclass')
-rw-r--r--meta/classes-global/sstate.bbclass2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/classes-global/sstate.bbclass b/meta/classes-global/sstate.bbclass
index 04539bbb99..76a7b59636 100644
--- a/meta/classes-global/sstate.bbclass
+++ b/meta/classes-global/sstate.bbclass
@@ -1115,7 +1115,7 @@ def sstate_checkhashes(sq_data, d, siginfo=False, currentcount=0, summary=True,
1115 bb.parse.siggen.checkhashes(sq_data, missed, found, d) 1115 bb.parse.siggen.checkhashes(sq_data, missed, found, d)
1116 1116
1117 return found 1117 return found
1118setscene_depvalid[vardepsexclude] = "SSTATE_EXCLUDEDEPS_SYSROOT" 1118setscene_depvalid[vardepsexclude] = "SSTATE_EXCLUDEDEPS_SYSROOT _SSTATE_EXCLUDEDEPS_SYSROOT"
1119 1119
1120BB_SETSCENE_DEPVALID = "setscene_depvalid" 1120BB_SETSCENE_DEPVALID = "setscene_depvalid"
1121 1121