summaryrefslogtreecommitdiffstats
path: root/meta-yocto-bsp
diff options
context:
space:
mode:
authorMichel Thebeau <michel.thebeau@windriver.com>2013-03-20 11:32:02 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-03-22 16:54:39 +0000
commit83716e40edacfd20dec8ef41f415ad5828d4643b (patch)
treeab27b693b3856c4d94fbad6b90a8a737987a9b6b /meta-yocto-bsp
parentdae3eecaaccbd832e5eddc7f0385e084e6816f8a (diff)
downloadpoky-83716e40edacfd20dec8ef41f415ad5828d4643b.tar.gz
routerstationpro: use KERNEL_IMAGE_MAXSIZE to test the image
routerstationpro is limited to 16mb flash size. Exceeding that size may not be noticed immediately, which we don't want. "The current latest kernel for the routerstationpro machine is far beyond the 16MB of it's flash size [0]. I think it would be good to [test if the size of the image is above that size]." Setting this variable will enable the do_sizecheck task and produce an error when the image is too large: "ERROR: This kernel (size=90230265 > 16777216) is too big for your device. Please reduce the size of the kernel by making more of it modular." [YOCTO #3514] (From meta-yocto rev: bb25e15c62cdde749f34050933d056a79dd2d3c5) Signed-off-by: Michel Thebeau <michel.thebeau@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-yocto-bsp')
-rw-r--r--meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.4.bbappend3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.4.bbappend b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.4.bbappend
index 3e80bf1450..40ebe15683 100644
--- a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.4.bbappend
+++ b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.4.bbappend
@@ -13,3 +13,6 @@ COMPATIBLE_MACHINE_mpc8315e-rdb = "mpc8315e-rdb"
13COMPATIBLE_MACHINE_routerstationpro = "routerstationpro" 13COMPATIBLE_MACHINE_routerstationpro = "routerstationpro"
14COMPATIBLE_MACHINE_beagleboard = "beagleboard" 14COMPATIBLE_MACHINE_beagleboard = "beagleboard"
15COMPATIBLE_MACHINE_atom-pc = "atom-pc" 15COMPATIBLE_MACHINE_atom-pc = "atom-pc"
16
17# routerstationpro has a flash size of 16mb
18KERNEL_IMAGE_MAXSIZE_append_routerstationpro = "16777216"