summaryrefslogtreecommitdiffstats
path: root/meta-yocto-bsp
diff options
context:
space:
mode:
authorKevin Hao <kexin.hao@windriver.com>2020-08-26 14:13:30 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-08-26 14:33:05 +0100
commit7ecdf7ac6384ccd6d09fb399bf3a781b05cfb865 (patch)
treea2ce39fadec342bdc36e76b6c95142ff702124f0 /meta-yocto-bsp
parent2c526ee6ef7a4395b88f479741333a0c76fd8303 (diff)
downloadpoky-7ecdf7ac6384ccd6d09fb399bf3a781b05cfb865.tar.gz
meta-yocto-bsp: Bump to the v5.8 kernel
Boot test for all the supported boards. There is a kernel config check warning for beaglebone-yocto, the fix [1] has been sent to kernel-meta for merging. [1] https://lists.yoctoproject.org/g/linux-yocto/message/8992 (From meta-yocto rev: ccc825335f257ca2259440c561eea02538edd762) Signed-off-by: Kevin Hao <kexin.hao@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-yocto-bsp')
-rw-r--r--meta-yocto-bsp/conf/machine/beaglebone-yocto.conf2
-rw-r--r--meta-yocto-bsp/conf/machine/edgerouter.conf2
-rw-r--r--meta-yocto-bsp/recipes-kernel/linux/linux-yocto_5.8.bbappend23
3 files changed, 25 insertions, 2 deletions
diff --git a/meta-yocto-bsp/conf/machine/beaglebone-yocto.conf b/meta-yocto-bsp/conf/machine/beaglebone-yocto.conf
index 5b481434bd..b7defb0d01 100644
--- a/meta-yocto-bsp/conf/machine/beaglebone-yocto.conf
+++ b/meta-yocto-bsp/conf/machine/beaglebone-yocto.conf
@@ -24,7 +24,7 @@ SERIAL_CONSOLES ?= "115200;ttyS0 115200;ttyO0 115200;ttyAMA0"
24SERIAL_CONSOLES_CHECK = "${SERIAL_CONSOLES}" 24SERIAL_CONSOLES_CHECK = "${SERIAL_CONSOLES}"
25 25
26PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto" 26PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto"
27PREFERRED_VERSION_linux-yocto ?= "5.4%" 27PREFERRED_VERSION_linux-yocto ?= "5.8%"
28 28
29KERNEL_IMAGETYPE = "zImage" 29KERNEL_IMAGETYPE = "zImage"
30KERNEL_DEVICETREE = "am335x-bone.dtb am335x-boneblack.dtb am335x-bonegreen.dtb" 30KERNEL_DEVICETREE = "am335x-bone.dtb am335x-boneblack.dtb am335x-bonegreen.dtb"
diff --git a/meta-yocto-bsp/conf/machine/edgerouter.conf b/meta-yocto-bsp/conf/machine/edgerouter.conf
index d6fd934fa5..75bc5e5f28 100644
--- a/meta-yocto-bsp/conf/machine/edgerouter.conf
+++ b/meta-yocto-bsp/conf/machine/edgerouter.conf
@@ -11,7 +11,7 @@ KERNEL_ALT_IMAGETYPE = "vmlinux.bin"
11KERNEL_IMAGE_STRIP_EXTRA_SECTIONS = ".comment" 11KERNEL_IMAGE_STRIP_EXTRA_SECTIONS = ".comment"
12 12
13PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto" 13PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto"
14PREFERRED_VERSION_linux-yocto ?= "5.4%" 14PREFERRED_VERSION_linux-yocto ?= "5.8%"
15 15
16SERIAL_CONSOLES = "115200;ttyS0" 16SERIAL_CONSOLES = "115200;ttyS0"
17USE_VT ?= "0" 17USE_VT ?= "0"
diff --git a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_5.8.bbappend b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_5.8.bbappend
new file mode 100644
index 0000000000..5d844423af
--- /dev/null
+++ b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_5.8.bbappend
@@ -0,0 +1,23 @@
1KBRANCH_genericx86 = "v5.8/standard/base"
2KBRANCH_genericx86-64 = "v5.8/standard/base"
3KBRANCH_edgerouter = "v5.8/standard/edgerouter"
4KBRANCH_beaglebone-yocto = "v5.8/standard/beaglebone"
5
6KMACHINE_genericx86 ?= "common-pc"
7KMACHINE_genericx86-64 ?= "common-pc-64"
8KMACHINE_beaglebone-yocto ?= "beaglebone"
9
10SRCREV_machine_genericx86 ?= "912adf166eb0688e011154048f5fa0e5863249c3"
11SRCREV_machine_genericx86-64 ?= "912adf166eb0688e011154048f5fa0e5863249c3"
12SRCREV_machine_edgerouter ?= "912adf166eb0688e011154048f5fa0e5863249c3"
13SRCREV_machine_beaglebone-yocto ?= "912adf166eb0688e011154048f5fa0e5863249c3"
14
15COMPATIBLE_MACHINE_genericx86 = "genericx86"
16COMPATIBLE_MACHINE_genericx86-64 = "genericx86-64"
17COMPATIBLE_MACHINE_edgerouter = "edgerouter"
18COMPATIBLE_MACHINE_beaglebone-yocto = "beaglebone-yocto"
19
20LINUX_VERSION_genericx86 = "5.8.2"
21LINUX_VERSION_genericx86-64 = "5.8.2"
22LINUX_VERSION_edgerouter = "5.8.2"
23LINUX_VERSION_beaglebone-yocto = "5.8.2"