summaryrefslogtreecommitdiffstats
path: root/meta-yocto-bsp
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2014-03-28 18:07:01 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-03-31 23:04:36 +0100
commit7254dfb642cb0262c7e14ef2a4c8a7a42afada60 (patch)
treec44528e8dd5afcd6c9ac623243650129a5c08a68 /meta-yocto-bsp
parentaf1e58a6107290e8d1dadb4617cb29eed17dd5d3 (diff)
downloadpoky-7254dfb642cb0262c7e14ef2a4c8a7a42afada60.tar.gz
Drop beagleboard, replaced by beaglebone
(From meta-yocto rev: b125761e5e31fc506f7b5b87308850cd573ab1b6) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-yocto-bsp')
-rw-r--r--meta-yocto-bsp/conf/machine/beagleboard.conf43
-rw-r--r--meta-yocto-bsp/recipes-core/init-ifupdown/init-ifupdown-1.0/beagleboard/interfaces27
-rw-r--r--meta-yocto-bsp/recipes-core/init-ifupdown/init-ifupdown_1.0.bbappend1
-rw-r--r--meta-yocto-bsp/recipes-graphics/xorg-xserver/xserver-xf86-config/beagleboard/xorg.conf33
-rw-r--r--meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.10.bbappend3
-rw-r--r--meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.4.bbappend3
6 files changed, 0 insertions, 110 deletions
diff --git a/meta-yocto-bsp/conf/machine/beagleboard.conf b/meta-yocto-bsp/conf/machine/beagleboard.conf
deleted file mode 100644
index 138c43a700..0000000000
--- a/meta-yocto-bsp/conf/machine/beagleboard.conf
+++ /dev/null
@@ -1,43 +0,0 @@
1#@TYPE: Machine
2#@NAME: Beagleboard machine
3#@DESCRIPTION: Machine configuration for the http://beagleboard.org/ board
4
5PREFERRED_PROVIDER_virtual/xserver ?= "xserver-xorg"
6XSERVER ?= "xserver-xorg \
7 xf86-input-evdev \
8 xf86-input-mouse \
9 xf86-video-omapfb \
10 xf86-input-keyboard"
11
12# Ship all kernel modules by default
13MACHINE_EXTRA_RRECOMMENDS = " kernel-modules"
14
15# Allow for MMC booting (required by the NAND-less Beagleboard XM)
16EXTRA_IMAGEDEPENDS += "u-boot"
17
18# Uncomment the following line to enable the hard floating point abi. Note that
19# this breaks some binary libraries and 3D (neither of which ship with
20# meta-yocto). For maximum compatibility, leave this disabled.
21#DEFAULTTUNE ?= "cortexa8hf-neon"
22include conf/machine/include/tune-cortexa8.inc
23
24IMAGE_FSTYPES += "tar.bz2 jffs2"
25EXTRA_IMAGECMD_jffs2 = "-lnp "
26
27# 2.6.37 and later kernels use OMAP_SERIAL, ttyO2
28# earlier kernels use ttyS2
29SERIAL_CONSOLE = "115200 ttyO2"
30
31PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto"
32PREFERRED_VERSION_linux-yocto ?= "3.10%"
33
34KERNEL_IMAGETYPE = "zImage"
35KERNEL_DEVICETREE = "${S}/arch/arm/boot/dts/omap3-beagle.dts ${S}/arch/arm/boot/dts/omap3-beagle-xm.dts"
36
37SPL_BINARY = "MLO"
38UBOOT_SUFFIX = "img"
39UBOOT_MACHINE = "omap3_beagle_config"
40UBOOT_ENTRYPOINT = "0x80008000"
41UBOOT_LOADADDRESS = "0x80008000"
42
43MACHINE_FEATURES = "usbgadget usbhost vfat alsa"
diff --git a/meta-yocto-bsp/recipes-core/init-ifupdown/init-ifupdown-1.0/beagleboard/interfaces b/meta-yocto-bsp/recipes-core/init-ifupdown/init-ifupdown-1.0/beagleboard/interfaces
deleted file mode 100644
index b6935c11af..0000000000
--- a/meta-yocto-bsp/recipes-core/init-ifupdown/init-ifupdown-1.0/beagleboard/interfaces
+++ /dev/null
@@ -1,27 +0,0 @@
1# /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)
2
3# The loopback interface
4auto lo
5iface lo inet loopback
6
7# Wireless interfaces
8iface wlan0 inet dhcp
9 wireless_mode managed
10 wireless_essid any
11 wpa-driver wext
12 wpa-conf /etc/wpa_supplicant.conf
13
14iface atml0 inet dhcp
15
16# Wired or wireless interfaces
17auto eth0
18iface eth0 inet dhcp
19iface eth1 inet dhcp
20
21# Ethernet/RNDIS gadget (g_ether) or LAN9514 on BeagleBoard xM
22auto usb0
23iface usb0 inet dhcp
24
25# Bluetooth networking
26iface bnep0 inet dhcp
27
diff --git a/meta-yocto-bsp/recipes-core/init-ifupdown/init-ifupdown_1.0.bbappend b/meta-yocto-bsp/recipes-core/init-ifupdown/init-ifupdown_1.0.bbappend
deleted file mode 100644
index 56223033bd..0000000000
--- a/meta-yocto-bsp/recipes-core/init-ifupdown/init-ifupdown_1.0.bbappend
+++ /dev/null
@@ -1 +0,0 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}-${PV}:"
diff --git a/meta-yocto-bsp/recipes-graphics/xorg-xserver/xserver-xf86-config/beagleboard/xorg.conf b/meta-yocto-bsp/recipes-graphics/xorg-xserver/xserver-xf86-config/beagleboard/xorg.conf
deleted file mode 100644
index 264f3c91ad..0000000000
--- a/meta-yocto-bsp/recipes-graphics/xorg-xserver/xserver-xf86-config/beagleboard/xorg.conf
+++ /dev/null
@@ -1,33 +0,0 @@
1Section "Module"
2 Load "extmod"
3 Load "dbe"
4 Load "glx"
5 Load "freetype"
6 Load "type1"
7 Load "record"
8 Load "dri"
9EndSection
10
11Section "Monitor"
12 Identifier "Builtin Default Monitor"
13EndSection
14
15Section "Device"
16 Identifier "Builtin Default fbdev Device 0"
17 Driver "omapfb"
18EndSection
19
20Section "Screen"
21 Identifier "Builtin Default fbdev Screen 0"
22 Device "Builtin Default fbdev Device 0"
23 Monitor "Builtin Default Monitor"
24EndSection
25
26Section "ServerLayout"
27 Identifier "Builtin Default Layout"
28 Screen "Builtin Default fbdev Screen 0"
29EndSection
30
31Section "ServerFlags"
32 Option "DontZap" "0"
33EndSection
diff --git a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.10.bbappend b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.10.bbappend
index 5ff899e1ca..c24ffb8d94 100644
--- a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.10.bbappend
+++ b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.10.bbappend
@@ -2,7 +2,6 @@ KBRANCH_genericx86 = "standard/common-pc/base"
2KBRANCH_genericx86-64 = "standard/common-pc-64/base" 2KBRANCH_genericx86-64 = "standard/common-pc-64/base"
3KBRANCH_routerstationpro = "standard/routerstationpro" 3KBRANCH_routerstationpro = "standard/routerstationpro"
4KBRANCH_mpc8315e-rdb = "standard/fsl-mpc8315e-rdb" 4KBRANCH_mpc8315e-rdb = "standard/fsl-mpc8315e-rdb"
5KBRANCH_beagleboard = "standard/beagleboard"
6 5
7KMACHINE_genericx86 ?= "common-pc" 6KMACHINE_genericx86 ?= "common-pc"
8KMACHINE_genericx86-64 ?= "common-pc-64" 7KMACHINE_genericx86-64 ?= "common-pc-64"
@@ -11,13 +10,11 @@ SRCREV_machine_genericx86 ?= "2ee37bfe732c73f7d39af55875ce8d30b282471c"
11SRCREV_machine_genericx86-64 ?= "2ee37bfe732c73f7d39af55875ce8d30b282471c" 10SRCREV_machine_genericx86-64 ?= "2ee37bfe732c73f7d39af55875ce8d30b282471c"
12SRCREV_machine_routerstationpro ?= "628fb65e665a4179b6df049563f47f521f9dfb4e" 11SRCREV_machine_routerstationpro ?= "628fb65e665a4179b6df049563f47f521f9dfb4e"
13SRCREV_machine_mpc8315e-rdb ?= "2688f74bf2bb01ec355bbdd4b6fa00a0d39302de" 12SRCREV_machine_mpc8315e-rdb ?= "2688f74bf2bb01ec355bbdd4b6fa00a0d39302de"
14SRCREV_machine_beagleboard ?= "dbd7d0033e92dcec6682760982228e88df9982e2"
15 13
16COMPATIBLE_MACHINE_genericx86 = "genericx86" 14COMPATIBLE_MACHINE_genericx86 = "genericx86"
17COMPATIBLE_MACHINE_genericx86-64 = "genericx86-64" 15COMPATIBLE_MACHINE_genericx86-64 = "genericx86-64"
18COMPATIBLE_MACHINE_mpc8315e-rdb = "mpc8315e-rdb" 16COMPATIBLE_MACHINE_mpc8315e-rdb = "mpc8315e-rdb"
19COMPATIBLE_MACHINE_routerstationpro = "routerstationpro" 17COMPATIBLE_MACHINE_routerstationpro = "routerstationpro"
20COMPATIBLE_MACHINE_beagleboard = "beagleboard"
21 18
22# routerstationpro has a flash size of 16mb 19# routerstationpro has a flash size of 16mb
23KERNEL_IMAGE_MAXSIZE_routerstationpro = "16777216" 20KERNEL_IMAGE_MAXSIZE_routerstationpro = "16777216"
diff --git a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.4.bbappend b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.4.bbappend
index 7c2bd67708..0ff485f46a 100644
--- a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.4.bbappend
+++ b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.4.bbappend
@@ -1,15 +1,12 @@
1KBRANCH_routerstationpro = "standard/routerstationpro" 1KBRANCH_routerstationpro = "standard/routerstationpro"
2KBRANCH_mpc8315e-rdb = "standard/fsl-mpc8315e-rdb" 2KBRANCH_mpc8315e-rdb = "standard/fsl-mpc8315e-rdb"
3KBRANCH_beagleboard = "standard/beagleboard"
4 3
5SRCREV_machine_genericx86 ?= "cdd7a546922ca1c46c94adeec3b9c90dc9aaad2d" 4SRCREV_machine_genericx86 ?= "cdd7a546922ca1c46c94adeec3b9c90dc9aaad2d"
6SRCREV_machine_routerstationpro ?= "62b86dc8ac794cd97c61a99418d7429e6a83ec1a" 5SRCREV_machine_routerstationpro ?= "62b86dc8ac794cd97c61a99418d7429e6a83ec1a"
7SRCREV_machine_mpc8315e-rdb ?= "b2f78892b3ff6cc940e4661f7b2017a73b289c73" 6SRCREV_machine_mpc8315e-rdb ?= "b2f78892b3ff6cc940e4661f7b2017a73b289c73"
8SRCREV_machine_beagleboard ?= "cdd7a546922ca1c46c94adeec3b9c90dc9aaad2d"
9 7
10COMPATIBLE_MACHINE_mpc8315e-rdb = "mpc8315e-rdb" 8COMPATIBLE_MACHINE_mpc8315e-rdb = "mpc8315e-rdb"
11COMPATIBLE_MACHINE_routerstationpro = "routerstationpro" 9COMPATIBLE_MACHINE_routerstationpro = "routerstationpro"
12COMPATIBLE_MACHINE_beagleboard = "beagleboard"
13 10
14# routerstationpro has a flash size of 16mb 11# routerstationpro has a flash size of 16mb
15KERNEL_IMAGE_MAXSIZE_append_routerstationpro = "16777216" 12KERNEL_IMAGE_MAXSIZE_append_routerstationpro = "16777216"