summaryrefslogtreecommitdiffstats
path: root/meta-yocto-bsp
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2013-07-29 16:22:54 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-07-31 06:59:59 +0100
commit2bdb4788970270c146165d43e5b26aa007db4723 (patch)
tree6875a8b942329dab6c4c3627723639a99abc9410 /meta-yocto-bsp
parent06feb0eed978632aa34dc624bc23162ca66f7d4b (diff)
downloadpoky-2bdb4788970270c146165d43e5b26aa007db4723.tar.gz
genericx86: add new BSP
This BSP aims to support "most" contemporary x86 hardware. It's a direct copy of atom-pc initially. (From meta-yocto rev: 1a73ef79e16d0cbcd60fa3ad9854dbc121e3282d) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-yocto-bsp')
-rw-r--r--meta-yocto-bsp/conf/machine/genericx86.conf37
-rw-r--r--meta-yocto-bsp/recipes-bsp/formfactor/formfactor/genericx86/machconfig6
-rw-r--r--meta-yocto-bsp/recipes-core/packagegroups/packagegroup-core-tools-profile.bbappend1
-rw-r--r--meta-yocto-bsp/recipes-core/uclibc/uclibc/genericx86/uClibc.machine69
-rw-r--r--meta-yocto-bsp/recipes-gnome/packagegroups/packagegroup-core-sdk-gmae.bbappend1
-rw-r--r--meta-yocto-bsp/recipes-gnome/packagegroups/packagegroup-core-standalone-gmae-sdk-target.bbappend1
-rw-r--r--meta-yocto-bsp/recipes-graphics/xorg-xserver/xserver-xf86-config/genericx86/xorg.conf0
-rw-r--r--meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.4.bbappend3
-rw-r--r--meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.8.bbappend3
9 files changed, 121 insertions, 0 deletions
diff --git a/meta-yocto-bsp/conf/machine/genericx86.conf b/meta-yocto-bsp/conf/machine/genericx86.conf
new file mode 100644
index 0000000000..5cb2b5bf5c
--- /dev/null
+++ b/meta-yocto-bsp/conf/machine/genericx86.conf
@@ -0,0 +1,37 @@
1#@TYPE: Machine
2#@NAME: Generic X86.
3
4#@DESCRIPTION: Machine configuration for generic X86 (32-bit) PCs. Supports a moderately wide range of drivers that should boot and be usable on "typical" hardware.
5
6include conf/machine/include/tune-atom.inc
7
8MACHINE_FEATURES = "screen keyboard pci usbhost ext2 ext3 x86 wifi acpi alsa"
9
10KERNEL_IMAGETYPE = "bzImage"
11
12PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto"
13PREFERRED_VERSION_linux-yocto ?= "3.8%"
14PREFERRED_PROVIDER_virtual/xserver ?= "xserver-xorg"
15XSERVER ?= "xserver-xorg \
16 xserver-xorg-extension-glx \
17 xf86-input-mouse \
18 xf86-input-keyboard \
19 xf86-input-evdev \
20 xf86-input-synaptics \
21 xf86-video-intel \
22 mesa-driver-i915 \
23 mesa-driver-i965"
24
25#MACHINE_EXTRA_RDEPENDS = "rt2860"
26
27MACHINE_EXTRA_RRECOMMENDS = "kernel-modules eee-acpi-scripts"
28
29IMAGE_FSTYPES ?= "ext3 cpio.gz live"
30
31APPEND += "usbcore.autosuspend=1"
32
33GLIBC_ADDONS = "nptl"
34
35EXTRA_OECONF_append_pn-matchbox-panel-2 = " --with-battery=acpi"
36
37ROOTLESS_X = "1"
diff --git a/meta-yocto-bsp/recipes-bsp/formfactor/formfactor/genericx86/machconfig b/meta-yocto-bsp/recipes-bsp/formfactor/formfactor/genericx86/machconfig
new file mode 100644
index 0000000000..a81a23bf5b
--- /dev/null
+++ b/meta-yocto-bsp/recipes-bsp/formfactor/formfactor/genericx86/machconfig
@@ -0,0 +1,6 @@
1HAVE_TOUCHSCREEN=0
2HAVE_KEYBOARD=1
3
4DISPLAY_CAN_ROTATE=0
5DISPLAY_ORIENTATION=0
6DISPLAY_DPI=133
diff --git a/meta-yocto-bsp/recipes-core/packagegroups/packagegroup-core-tools-profile.bbappend b/meta-yocto-bsp/recipes-core/packagegroups/packagegroup-core-tools-profile.bbappend
index 352c1f9f22..e3aa5e8f99 100644
--- a/meta-yocto-bsp/recipes-core/packagegroups/packagegroup-core-tools-profile.bbappend
+++ b/meta-yocto-bsp/recipes-core/packagegroups/packagegroup-core-tools-profile.bbappend
@@ -1,2 +1,3 @@
1RDEPENDS_${PN}_append_atom-pc = " lttng-ust systemtap" 1RDEPENDS_${PN}_append_atom-pc = " lttng-ust systemtap"
2RDEPENDS_${PN}_append_genericx86 = " lttng-ust systemtap"
2 3
diff --git a/meta-yocto-bsp/recipes-core/uclibc/uclibc/genericx86/uClibc.machine b/meta-yocto-bsp/recipes-core/uclibc/uclibc/genericx86/uClibc.machine
new file mode 100644
index 0000000000..5df15f94cb
--- /dev/null
+++ b/meta-yocto-bsp/recipes-core/uclibc/uclibc/genericx86/uClibc.machine
@@ -0,0 +1,69 @@
1#
2# Automatically generated make config: don't edit
3# Fri Nov 23 15:49:33 2007
4#
5# TARGET_alpha is not set
6# TARGET_arm is not set
7# TARGET_bfin is not set
8# TARGET_cris is not set
9# TARGET_e1 is not set
10# TARGET_frv is not set
11# TARGET_h8300 is not set
12# TARGET_hppa is not set
13TARGET_i386=y
14# TARGET_i960 is not set
15# TARGET_ia64 is not set
16# TARGET_m68k is not set
17# TARGET_microblaze is not set
18# TARGET_mips is not set
19# TARGET_nios is not set
20# TARGET_nios2 is not set
21# TARGET_powerpc is not set
22# TARGET_sh is not set
23# TARGET_sh64 is not set
24# TARGET_sparc is not set
25# TARGET_v850 is not set
26# TARGET_vax is not set
27# TARGET_x86_64 is not set
28
29#
30# Target Architecture Features and Options
31#
32TARGET_ARCH="i386"
33FORCE_OPTIONS_FOR_ARCH=y
34CONFIG_GENERIC_386=y
35# CONFIG_386 is not set
36# CONFIG_486 is not set
37# CONFIG_586 is not set
38# CONFIG_586MMX is not set
39# CONFIG_686 is not set
40# CONFIG_PENTIUMII is not set
41# CONFIG_PENTIUMIII is not set
42# CONFIG_PENTIUM4 is not set
43# CONFIG_K6 is not set
44# CONFIG_K7 is not set
45# CONFIG_ELAN is not set
46# CONFIG_CRUSOE is not set
47# CONFIG_WINCHIPC6 is not set
48# CONFIG_WINCHIP2 is not set
49# CONFIG_CYRIXIII is not set
50# CONFIG_NEHEMIAH is not set
51TARGET_SUBARCH=""
52
53#
54# Using ELF file format
55#
56ARCH_LITTLE_ENDIAN=y
57
58#
59# Using Little Endian
60#
61ARCH_HAS_MMU=y
62ARCH_USE_MMU=y
63UCLIBC_HAS_FLOATS=y
64UCLIBC_HAS_FPU=y
65DO_C99_MATH=y
66KERNEL_HEADERS="/usr/include"
67HAVE_DOT_CONFIG=y
68
69UCLIBC_HAS_FENV=y
diff --git a/meta-yocto-bsp/recipes-gnome/packagegroups/packagegroup-core-sdk-gmae.bbappend b/meta-yocto-bsp/recipes-gnome/packagegroups/packagegroup-core-sdk-gmae.bbappend
index 0105adee05..d7de19fda5 100644
--- a/meta-yocto-bsp/recipes-gnome/packagegroups/packagegroup-core-sdk-gmae.bbappend
+++ b/meta-yocto-bsp/recipes-gnome/packagegroups/packagegroup-core-sdk-gmae.bbappend
@@ -1 +1,2 @@
1SDK-EXTRAS_atom-pc ?= " lttng-ust-dev" 1SDK-EXTRAS_atom-pc ?= " lttng-ust-dev"
2SDK-EXTRAS_genericx86 ?= " lttng-ust-dev"
diff --git a/meta-yocto-bsp/recipes-gnome/packagegroups/packagegroup-core-standalone-gmae-sdk-target.bbappend b/meta-yocto-bsp/recipes-gnome/packagegroups/packagegroup-core-standalone-gmae-sdk-target.bbappend
index 0105adee05..d7de19fda5 100644
--- a/meta-yocto-bsp/recipes-gnome/packagegroups/packagegroup-core-standalone-gmae-sdk-target.bbappend
+++ b/meta-yocto-bsp/recipes-gnome/packagegroups/packagegroup-core-standalone-gmae-sdk-target.bbappend
@@ -1 +1,2 @@
1SDK-EXTRAS_atom-pc ?= " lttng-ust-dev" 1SDK-EXTRAS_atom-pc ?= " lttng-ust-dev"
2SDK-EXTRAS_genericx86 ?= " lttng-ust-dev"
diff --git a/meta-yocto-bsp/recipes-graphics/xorg-xserver/xserver-xf86-config/genericx86/xorg.conf b/meta-yocto-bsp/recipes-graphics/xorg-xserver/xserver-xf86-config/genericx86/xorg.conf
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/meta-yocto-bsp/recipes-graphics/xorg-xserver/xserver-xf86-config/genericx86/xorg.conf
diff --git a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.4.bbappend b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.4.bbappend
index 9e3efc9385..c3d12904af 100644
--- a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.4.bbappend
+++ b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.4.bbappend
@@ -1,9 +1,11 @@
1KBRANCH_atom-pc = "standard/common-pc/atom-pc" 1KBRANCH_atom-pc = "standard/common-pc/atom-pc"
2KBRANCH_genericx86 = "standard/common-pc/atom-pc"
2KBRANCH_routerstationpro = "standard/routerstationpro" 3KBRANCH_routerstationpro = "standard/routerstationpro"
3KBRANCH_mpc8315e-rdb = "standard/fsl-mpc8315e-rdb" 4KBRANCH_mpc8315e-rdb = "standard/fsl-mpc8315e-rdb"
4KBRANCH_beagleboard = "standard/beagleboard" 5KBRANCH_beagleboard = "standard/beagleboard"
5 6
6SRCREV_machine_atom-pc ?= "cdd7a546922ca1c46c94adeec3b9c90dc9aaad2d" 7SRCREV_machine_atom-pc ?= "cdd7a546922ca1c46c94adeec3b9c90dc9aaad2d"
8SRCREV_machine_genericx86 ?= "cdd7a546922ca1c46c94adeec3b9c90dc9aaad2d"
7SRCREV_machine_routerstationpro ?= "62b86dc8ac794cd97c61a99418d7429e6a83ec1a" 9SRCREV_machine_routerstationpro ?= "62b86dc8ac794cd97c61a99418d7429e6a83ec1a"
8SRCREV_machine_mpc8315e-rdb ?= "b2f78892b3ff6cc940e4661f7b2017a73b289c73" 10SRCREV_machine_mpc8315e-rdb ?= "b2f78892b3ff6cc940e4661f7b2017a73b289c73"
9SRCREV_machine_beagleboard ?= "cdd7a546922ca1c46c94adeec3b9c90dc9aaad2d" 11SRCREV_machine_beagleboard ?= "cdd7a546922ca1c46c94adeec3b9c90dc9aaad2d"
@@ -12,6 +14,7 @@ COMPATIBLE_MACHINE_mpc8315e-rdb = "mpc8315e-rdb"
12COMPATIBLE_MACHINE_routerstationpro = "routerstationpro" 14COMPATIBLE_MACHINE_routerstationpro = "routerstationpro"
13COMPATIBLE_MACHINE_beagleboard = "beagleboard" 15COMPATIBLE_MACHINE_beagleboard = "beagleboard"
14COMPATIBLE_MACHINE_atom-pc = "atom-pc" 16COMPATIBLE_MACHINE_atom-pc = "atom-pc"
17COMPATIBLE_MACHINE_genericx86 = "genericx86"
15 18
16# routerstationpro has a flash size of 16mb 19# routerstationpro has a flash size of 16mb
17KERNEL_IMAGE_MAXSIZE_append_routerstationpro = "16777216" 20KERNEL_IMAGE_MAXSIZE_append_routerstationpro = "16777216"
diff --git a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.8.bbappend b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.8.bbappend
index 0686d4b275..c4c005db92 100644
--- a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.8.bbappend
+++ b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.8.bbappend
@@ -1,9 +1,11 @@
1KBRANCH_atom-pc = "standard/common-pc/atom-pc" 1KBRANCH_atom-pc = "standard/common-pc/atom-pc"
2KBRANCH_genericx86 = "standard/common-pc/atom-pc"
2KBRANCH_routerstationpro = "standard/routerstationpro" 3KBRANCH_routerstationpro = "standard/routerstationpro"
3KBRANCH_mpc8315e-rdb = "standard/fsl-mpc8315e-rdb" 4KBRANCH_mpc8315e-rdb = "standard/fsl-mpc8315e-rdb"
4KBRANCH_beagleboard = "standard/beagleboard" 5KBRANCH_beagleboard = "standard/beagleboard"
5 6
6SRCREV_machine_atom-pc ?= "f20047520a57322f05d95a18a5fbd082fb15cb87" 7SRCREV_machine_atom-pc ?= "f20047520a57322f05d95a18a5fbd082fb15cb87"
8SRCREV_machine_genericx86 ?= "f20047520a57322f05d95a18a5fbd082fb15cb87"
7SRCREV_machine_routerstationpro ?= "4a94f39d429fa284ce69b13bb635b29b1319e372" 9SRCREV_machine_routerstationpro ?= "4a94f39d429fa284ce69b13bb635b29b1319e372"
8SRCREV_machine_mpc8315e-rdb ?= "f467c72937de0e4a2a66e21b9855c4aee844f936" 10SRCREV_machine_mpc8315e-rdb ?= "f467c72937de0e4a2a66e21b9855c4aee844f936"
9SRCREV_machine_beagleboard ?= "f20047520a57322f05d95a18a5fbd082fb15cb87" 11SRCREV_machine_beagleboard ?= "f20047520a57322f05d95a18a5fbd082fb15cb87"
@@ -12,6 +14,7 @@ COMPATIBLE_MACHINE_mpc8315e-rdb = "mpc8315e-rdb"
12COMPATIBLE_MACHINE_routerstationpro = "routerstationpro" 14COMPATIBLE_MACHINE_routerstationpro = "routerstationpro"
13COMPATIBLE_MACHINE_beagleboard = "beagleboard" 15COMPATIBLE_MACHINE_beagleboard = "beagleboard"
14COMPATIBLE_MACHINE_atom-pc = "atom-pc" 16COMPATIBLE_MACHINE_atom-pc = "atom-pc"
17COMPATIBLE_MACHINE_genericx86 = "genericx86"
15 18
16# routerstationpro has a flash size of 16mb 19# routerstationpro has a flash size of 16mb
17KERNEL_IMAGE_MAXSIZE_routerstationpro = "16777216" 20KERNEL_IMAGE_MAXSIZE_routerstationpro = "16777216"