summaryrefslogtreecommitdiffstats
path: root/meta-yocto-bsp
diff options
context:
space:
mode:
authorKevin Hao <kexin.hao@windriver.com>2021-09-23 18:32:29 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-09-24 10:15:29 +0100
commit06dcace68b021b020f14327c35358d58ecc698fa (patch)
tree378b26ed49956e99d06f9d23e8d215b0bb0e73f5 /meta-yocto-bsp
parent414c5f1103ba890df0b9604a69054b4092abe4d5 (diff)
downloadpoky-06dcace68b021b020f14327c35358d58ecc698fa.tar.gz
meta-yocto-bsp: Update the default kernel to v5.14
Introduce the bbappend for v5.14 and also set the default kernel to v5.14 for all the boards. (From meta-yocto rev: bed70a64b5b772fd71a7ff88a9f3719082e9398c) Signed-off-by: Kevin Hao <kexin.hao@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-yocto-bsp')
-rw-r--r--meta-yocto-bsp/conf/machine/beaglebone-yocto.conf2
-rw-r--r--meta-yocto-bsp/conf/machine/edgerouter.conf2
-rw-r--r--meta-yocto-bsp/conf/machine/include/genericx86-common.inc2
-rw-r--r--meta-yocto-bsp/recipes-kernel/linux/linux-yocto_5.14.bbappend23
4 files changed, 26 insertions, 3 deletions
diff --git a/meta-yocto-bsp/conf/machine/beaglebone-yocto.conf b/meta-yocto-bsp/conf/machine/beaglebone-yocto.conf
index 618af40306..b3d960a8cd 100644
--- a/meta-yocto-bsp/conf/machine/beaglebone-yocto.conf
+++ b/meta-yocto-bsp/conf/machine/beaglebone-yocto.conf
@@ -24,7 +24,7 @@ SERIAL_CONSOLES ?= "115200;ttyS0 115200;ttyO0 115200;ttyAMA0"
24SERIAL_CONSOLES_CHECK = "${SERIAL_CONSOLES}" 24SERIAL_CONSOLES_CHECK = "${SERIAL_CONSOLES}"
25 25
26PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto" 26PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto"
27PREFERRED_VERSION_linux-yocto ?= "5.13%" 27PREFERRED_VERSION_linux-yocto ?= "5.14%"
28 28
29KERNEL_IMAGETYPE = "zImage" 29KERNEL_IMAGETYPE = "zImage"
30KERNEL_DEVICETREE = "am335x-bone.dtb am335x-boneblack.dtb am335x-bonegreen.dtb" 30KERNEL_DEVICETREE = "am335x-bone.dtb am335x-boneblack.dtb am335x-bonegreen.dtb"
diff --git a/meta-yocto-bsp/conf/machine/edgerouter.conf b/meta-yocto-bsp/conf/machine/edgerouter.conf
index 9c95f4632f..32be4b9c39 100644
--- a/meta-yocto-bsp/conf/machine/edgerouter.conf
+++ b/meta-yocto-bsp/conf/machine/edgerouter.conf
@@ -11,7 +11,7 @@ KERNEL_ALT_IMAGETYPE = "vmlinux.bin"
11KERNEL_IMAGE_STRIP_EXTRA_SECTIONS = ".comment" 11KERNEL_IMAGE_STRIP_EXTRA_SECTIONS = ".comment"
12 12
13PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto" 13PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto"
14PREFERRED_VERSION_linux-yocto ?= "5.13%" 14PREFERRED_VERSION_linux-yocto ?= "5.14%"
15 15
16SERIAL_CONSOLES = "115200;ttyS0" 16SERIAL_CONSOLES = "115200;ttyS0"
17USE_VT ?= "0" 17USE_VT ?= "0"
diff --git a/meta-yocto-bsp/conf/machine/include/genericx86-common.inc b/meta-yocto-bsp/conf/machine/include/genericx86-common.inc
index adc8ca879a..4651b37e5d 100644
--- a/meta-yocto-bsp/conf/machine/include/genericx86-common.inc
+++ b/meta-yocto-bsp/conf/machine/include/genericx86-common.inc
@@ -2,7 +2,7 @@ include conf/machine/include/x86/x86-base.inc
2require conf/machine/include/x86/qemuboot-x86.inc 2require conf/machine/include/x86/qemuboot-x86.inc
3MACHINE_FEATURES += "wifi efi pcbios" 3MACHINE_FEATURES += "wifi efi pcbios"
4 4
5PREFERRED_VERSION_linux-yocto ?= "5.13%" 5PREFERRED_VERSION_linux-yocto ?= "5.14%"
6PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto" 6PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto"
7PREFERRED_PROVIDER_virtual/xserver ?= "xserver-xorg" 7PREFERRED_PROVIDER_virtual/xserver ?= "xserver-xorg"
8XSERVER ?= "${XSERVER_X86_BASE} \ 8XSERVER ?= "${XSERVER_X86_BASE} \
diff --git a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_5.14.bbappend b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_5.14.bbappend
new file mode 100644
index 0000000000..52371ff66a
--- /dev/null
+++ b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_5.14.bbappend
@@ -0,0 +1,23 @@
1KBRANCH:genericx86 = "v5.14/standard/base"
2KBRANCH:genericx86-64 = "v5.14/standard/base"
3KBRANCH:edgerouter = "v5.14/standard/edgerouter"
4KBRANCH:beaglebone-yocto = "v5.14/standard/beaglebone"
5
6KMACHINE:genericx86 ?= "common-pc"
7KMACHINE:genericx86-64 ?= "common-pc-64"
8KMACHINE:beaglebone-yocto ?= "beaglebone"
9
10SRCREV_machine:genericx86 ?= "7ae156be3bdbf033839f7f3ec2e9a0ffffb18818"
11SRCREV_machine:genericx86-64 ?= "7ae156be3bdbf033839f7f3ec2e9a0ffffb18818"
12SRCREV_machine:edgerouter ?= "7ae156be3bdbf033839f7f3ec2e9a0ffffb18818"
13SRCREV_machine:beaglebone-yocto ?= "7ae156be3bdbf033839f7f3ec2e9a0ffffb18818"
14
15COMPATIBLE_MACHINE:genericx86 = "genericx86"
16COMPATIBLE_MACHINE:genericx86-64 = "genericx86-64"
17COMPATIBLE_MACHINE:edgerouter = "edgerouter"
18COMPATIBLE_MACHINE:beaglebone-yocto = "beaglebone-yocto"
19
20LINUX_VERSION:genericx86 = "5.14.6"
21LINUX_VERSION:genericx86-64 = "5.14.6"
22LINUX_VERSION:edgerouter = "5.14.6"
23LINUX_VERSION:beaglebone-yocto = "5.14.6"